aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-07-13 13:59:11 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-07-13 13:59:11 +0000
commitd80c5e9df63c4ca47a3b39903b09d22aae7669bd (patch)
tree72a1e1ba94a14f030d77be9bdd4dfce6429ff4cb /math
parent1833fc55ddeb57713ba5148d584fb5f74ce84a88 (diff)
downloadports-d80c5e9df63c4ca47a3b39903b09d22aae7669bd.tar.gz
ports-d80c5e9df63c4ca47a3b39903b09d22aae7669bd.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/goblin/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/math/goblin/Makefile b/math/goblin/Makefile
index b7c889f0c541..76ad34ab557c 100644
--- a/math/goblin/Makefile
+++ b/math/goblin/Makefile
@@ -16,7 +16,7 @@ CONFLICTS= glpk-*
USE_GCC= any
NO_CCACHE= yes
USE_TK= yes
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
MAKE_ARGS= CC="${CC}" CCFLAGS="${CFLAGS}" \
CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
@@ -26,6 +26,8 @@ MAKE_ARGS= CC="${CC}" CCFLAGS="${CFLAGS}" \
ALL_TARGET= all shared
PLIST_SUB+= VERSION=${PORTVERSION:R}
+MAKE_JOBS_UNSAFE= yes
+
CFLAGS+= -I${LOCALBASE}/include/tcl${TCL_VER} -I${LOCALBASE}/include/ \
-I${LOCALBASE}/include/tk${TK_VER} ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib -ltcl${USE_TCL} -ltk${USE_TK} ${PTHREAD_LIBS}