aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2016-04-18 05:31:57 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2016-04-18 05:31:57 +0000
commitf050cb454909dd14e40907fe537710e06e086f4a (patch)
tree0110531c779f464627caa5c0273abe332a6ce435 /math
parent61d69ef66b69bd41c82f3a2acb027017cecb909f (diff)
downloadports-f050cb454909dd14e40907fe537710e06e086f4a.tar.gz
ports-f050cb454909dd14e40907fe537710e06e086f4a.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/py-luminol/Makefile23
-rw-r--r--math/py-luminol/distinfo2
-rw-r--r--math/py-luminol/pkg-descr5
3 files changed, 30 insertions, 0 deletions
diff --git a/math/py-luminol/Makefile b/math/py-luminol/Makefile
new file mode 100644
index 000000000000..ff4ea9676ec9
--- /dev/null
+++ b/math/py-luminol/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= luminol
+PORTVERSION= 0.3.1
+DISTVERSIONPREFIX= v
+CATEGORIES= math python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= araujo@FreeBSD.org
+COMMENT= Light weight python library for time series data analysis
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.6.2:math/py-numpy
+
+USES= python
+USE_PYTHON= autoplist distutils
+USE_GITHUB= yes
+GH_ACCOUNT= linkedin
+
+.include <bsd.port.mk>
diff --git a/math/py-luminol/distinfo b/math/py-luminol/distinfo
new file mode 100644
index 000000000000..18a91583b2df
--- /dev/null
+++ b/math/py-luminol/distinfo
@@ -0,0 +1,2 @@
+SHA256 (linkedin-luminol-v0.3.1_GH0.tar.gz) = 31c2c5697dffa0e4b9c3468189b2a4f25e5dd2c59ee351f51fdbf5a770fe8c7b
+SIZE (linkedin-luminol-v0.3.1_GH0.tar.gz) = 141854
diff --git a/math/py-luminol/pkg-descr b/math/py-luminol/pkg-descr
new file mode 100644
index 000000000000..fa66fe1317a0
--- /dev/null
+++ b/math/py-luminol/pkg-descr
@@ -0,0 +1,5 @@
+Luminol is a light weight python library for time series data analysis.
+The two major functionalities it supports are anomaly detection and
+correlation. It can be used to investigate possible causes of anomaly.
+
+WWW: https://github.com/linkedin/luminol