aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-06-19 11:43:50 +0000
committerRene Ladan <rene@FreeBSD.org>2013-06-19 11:43:50 +0000
commitfa8b5883ec578fc2924499691f19ab793c7dc220 (patch)
tree6f975de03789af2ae90bb7c9899cd8d11668ee16 /math
parent9ae289ac1a12489159ebf49b1acaa2139cc47ba8 (diff)
downloadports-fa8b5883ec578fc2924499691f19ab793c7dc220.tar.gz
ports-fa8b5883ec578fc2924499691f19ab793c7dc220.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/petsc/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index 1ff2de37803c..6b48ba641141 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -14,8 +14,6 @@ COMMENT= Portable, Extensible Toolkit for Scientific computation
RUN_DEPENDS= ksh:${PORTSDIR}/shells/pdksh \
qsub:${PORTSDIR}/sysutils/torque
-SLAVEDIRS= math/petsc-mpich
-
HAS_CONFIGURE= yes
USE_PYTHON= yes
CONFIGURE_SCRIPT= config/configure.py
@@ -54,7 +52,9 @@ CONFIGURE_ARGS+= --with-umfpack-include="${LOCALBASE}/include/suitesparse" \
--with-umfpack-lib="[${UMFPACK_LIBS:C/^/${L}/:C/,/, ${L}/g}]"
.endif
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= *
#USE_TEX= latex:build
#BUILD_DEPENDS+= c2html:${PORTSDIR}/textproc/c2html \
@@ -65,8 +65,6 @@ LIBSCALAPACK= ${LOCALBASE}/lib/libscalapack.a
LIBBLACS= ${LOCALBASE}/lib/libblacs.a
MPIDIR= ${LOCALBASE}
-.include <bsd.port.pre.mk>
-
.if exists(${LOCALBASE}/mpi/openmpi/bin/mpirun)
WITH_OPENMPI= yes
MPIDIR= ${LOCALBASE}/mpi/openmpi
@@ -270,7 +268,7 @@ post-install:
${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/${PFX}/bin
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/${PFX}/bmake
${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/${PFX}/bmake
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \
${MAKEFILE} ${MAKE_ARGS} install_docs)
.endif
@@ -295,4 +293,4 @@ regression-test:
. endif
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>