aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2021-01-01 10:11:34 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2021-01-01 10:11:34 +0000
commit26b4c8f71f91d22e081b27814782686edde0c90a (patch)
tree1c321c39372c25d8634e75b5c8e08edc676b296d /math
parent548f16bd1a2915f08878b716eed92ff3267e6de2 (diff)
downloadports-26b4c8f71f91d22e081b27814782686edde0c90a.tar.gz
ports-26b4c8f71f91d22e081b27814782686edde0c90a.zip
Revert r559792 to unbreak INDEX and bulk -a
It seems a lot of reverse dependencies were missed With hat: portmgr
Notes
Notes: svn path=/head/; revision=559822
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/gringo/Makefile30
-rw-r--r--math/gringo/distinfo3
-rw-r--r--math/gringo/files/patch-SConscript11
-rw-r--r--math/gringo/files/patch-SConstruct20
-rw-r--r--math/gringo/files/patch-libgringo_src_term.cc10
-rw-r--r--math/gringo/pkg-descr6
7 files changed, 81 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 7b2e9fa1e641..4061dc50c7f0 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -311,6 +311,7 @@
SUBDIR += graphthing
SUBDIR += gretl
SUBDIR += gri
+ SUBDIR += gringo
SUBDIR += grpn
SUBDIR += gsl
SUBDIR += half
diff --git a/math/gringo/Makefile b/math/gringo/Makefile
new file mode 100644
index 000000000000..408136b78ee1
--- /dev/null
+++ b/math/gringo/Makefile
@@ -0,0 +1,30 @@
+# Created by: Vsevolod Stakhov <vsevolod@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gringo
+DISTVERSION= 4.5.4
+DISTVERSIONSUFFIX= -source
+PORTREVISION= 3
+CATEGORIES= math devel
+MASTER_SITES= SOURCEFORGE/potassco/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= vsevolod@FreeBSD.org
+COMMENT= Grounding algorithm based on semi-naive database evaluation
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= re2c:devel/re2c
+
+USES= bison compiler:c++11-lib python:2.7 scons:python2
+MAKE_ARGS= ${MAKE_ENV}
+CXXFLAGS+= -std=c++11
+MAKE_ENV= WITH_LUA=no
+
+PLIST_FILES= bin/${PORTNAME} bin/clingo
+
+do-install:
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/build/debug/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/build/debug/clingo ${STAGEDIR}${PREFIX}/bin/clingo
+
+.include <bsd.port.mk>
diff --git a/math/gringo/distinfo b/math/gringo/distinfo
new file mode 100644
index 000000000000..ea7b46341f2b
--- /dev/null
+++ b/math/gringo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532665392
+SHA256 (gringo-4.5.4-source.tar.gz) = 81f8bbbb1b06236778028e5f1b8627ee38a712ec708724112fb08aecf9bc649a
+SIZE (gringo-4.5.4-source.tar.gz) = 1677479
diff --git a/math/gringo/files/patch-SConscript b/math/gringo/files/patch-SConscript
new file mode 100644
index 000000000000..ca548bd49f60
--- /dev/null
+++ b/math/gringo/files/patch-SConscript
@@ -0,0 +1,11 @@
+--- SConscript.orig 2015-08-17 12:39:49 UTC
++++ SConscript
+@@ -202,7 +202,7 @@ if env['WITH_LUA'] == "auto":
+ if conf.CheckWithPkgConfig("lua", ["lua", "lua5.1", "lua-5.1", "lua5.2", "lua-5.2", "lua5.3", "lua-5.3"]):
+ with_lua = True
+ DEFS["WITH_LUA"] = 1
+-elif env['WITH_LUA']:
++elif env['WITH_LUA'] != "no":
+ if not conf.CheckLibs("lua", env['WITH_LUA'], "lua.hpp"):
+ failure = True
+ else:
diff --git a/math/gringo/files/patch-SConstruct b/math/gringo/files/patch-SConstruct
new file mode 100644
index 000000000000..3d488727f4f8
--- /dev/null
+++ b/math/gringo/files/patch-SConstruct
@@ -0,0 +1,20 @@
+--- SConstruct.orig 2015-07-13 17:25:17 UTC
++++ SConstruct
+@@ -19,7 +19,7 @@
+
+ # }}}
+
+-from os import mkdir
++from os import mkdir, environ
+ from os.path import join, exists
+
+ if not exists("build"): mkdir("build")
+@@ -52,7 +52,7 @@ opts.AddVariables(
+ ('WITH_CPPUNIT' , 'enable target test, running unit tests using cppunit; None, "auto", or library name or test'),
+ )
+
+-env = Environment()
++env = Environment(ENV = environ)
+ env['BISON'] = 'bison'
+ env['RE2C'] = 're2c'
+ env['CXX'] = 'g++'
diff --git a/math/gringo/files/patch-libgringo_src_term.cc b/math/gringo/files/patch-libgringo_src_term.cc
new file mode 100644
index 000000000000..eb0e5fcaf30a
--- /dev/null
+++ b/math/gringo/files/patch-libgringo_src_term.cc
@@ -0,0 +1,10 @@
+--- libgringo/src/term.cc.orig 2018-09-25 16:02:56 UTC
++++ libgringo/src/term.cc
+@@ -21,6 +21,7 @@
+ #include "gringo/term.hh"
+ #include "gringo/logger.hh"
+ #include "gringo/graph.hh"
++#include <cmath>
+
+ namespace Gringo {
+
diff --git a/math/gringo/pkg-descr b/math/gringo/pkg-descr
new file mode 100644
index 000000000000..fed7edffef2f
--- /dev/null
+++ b/math/gringo/pkg-descr
@@ -0,0 +1,6 @@
+Current answer set solvers work on variable-free programs. Hence, a grounder is
+needed that, given an input program with first-order variables, computes an
+equivalent ground (variable-free) program. Gringo is such a grounder. Its
+output can be processed further with clasp.
+
+WWW: https://potassco.org/