aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-04-01 08:41:13 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-04-01 08:41:13 +0000
commitd02c2961d0ab7a1fc63c61cc3c7329229f9f4530 (patch)
treed8fe290be85578b6b783b006b3e7b13d36e5cdf8 /math
parent3b3348b1e153a0c21f502ec2d2acb76881ecaee5 (diff)
downloadports-d02c2961d0ab7a1fc63c61cc3c7329229f9f4530.tar.gz
ports-d02c2961d0ab7a1fc63c61cc3c7329229f9f4530.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/facile/Makefile19
-rw-r--r--math/facile/files/patch-ocaml411
-rw-r--r--math/facile/pkg-descr2
3 files changed, 23 insertions, 9 deletions
diff --git a/math/facile/Makefile b/math/facile/Makefile
index 0b922a347a53..761dcf8abf3d 100644
--- a/math/facile/Makefile
+++ b/math/facile/Makefile
@@ -3,23 +3,26 @@
PORTNAME= facile
PORTVERSION= 1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= http://www.recherche.enac.fr/log/facile/distrib/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A Functional Constraint Library
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Functional Constraint Library
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= gmake
USE_OCAML= yes
HAS_CONFIGURE= yes
-USE_GMAKE= yes
ALL_TARGET= compile
-NO_STAGE= yes
-post-patch:
- ${REINPLACE_CMD} -e "s,make,${GMAKE},; \
- s,cp,${INSTALL_DATA}," ${WRKSRC}/Makefile
+post-configure:
+ ${REINPLACE_CMD} -e "s,make,${MAKE_CMD},; \
+ s,cp,${INSTALL_DATA},;\
+ s,mkdir,${MKDIR}," ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e "s,${LOCALBASE},${STAGEDIR}${PREFIX}," \
+ ${WRKSRC}/config_Makefile
.include <bsd.port.mk>
diff --git a/math/facile/files/patch-ocaml4 b/math/facile/files/patch-ocaml4
new file mode 100644
index 000000000000..e1b9c61eae7e
--- /dev/null
+++ b/math/facile/files/patch-ocaml4
@@ -0,0 +1,11 @@
+--- ./src/fcl_data.ml
++++ ./src/fcl_data.ml
+@@ -16,7 +16,7 @@ end
+
+ module Hashtbl = struct
+ type ('a, 'b) t = ('a, 'b) Hashtbl.t
+- let create = Hashtbl.create
++ let create n = Hashtbl.create n
+ let get h = h
+
+ let add h k d =
diff --git a/math/facile/pkg-descr b/math/facile/pkg-descr
index 226ae21ea401..a4b6260f9a63 100644
--- a/math/facile/pkg-descr
+++ b/math/facile/pkg-descr
@@ -7,4 +7,4 @@ FaCiLe allows as well to build easily user-defined constraints and goals,
making pervasive use of OCaml higher-order functionals to provide a simple
and flexible interface for the user.
-WWW: http://www.recherche.enac.fr/log/facile/
+WWW: http://www.recherche.enac.fr/log/facile/