aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-02-15 16:53:02 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-02-15 16:53:02 +0000
commit9d1ecd00cf53d2480ac47baa899895167b0abe88 (patch)
tree0fe0ad44347e4146af478e79245c5c2bbc2f99c4 /math
parent7dfaf82cf7af59ff031d62e933c91ae92f3f36af (diff)
downloadports-9d1ecd00cf53d2480ac47baa899895167b0abe88.tar.gz
ports-9d1ecd00cf53d2480ac47baa899895167b0abe88.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/rpc/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/math/rpc/Makefile b/math/rpc/Makefile
index 8e58f48b66ab..b74e3e57ea30 100644
--- a/math/rpc/Makefile
+++ b/math/rpc/Makefile
@@ -19,10 +19,28 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libccm.so:${PORTSDIR}/math/ccmath
RUN_DEPENDS= ${LOCALBASE}/lib/libccm.so:${PORTSDIR}/math/ccmath
USE_GMAKE= yes
+USE_REINPLACE= yes # to avoid cumbersome patching: see below
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+post-patch:
+#
+# Get rid of inline function body in implementation...
+#
+ @${REINPLACE_CMD} -e '483,488d' ${WRKSRC}/src/RpcComplex.cpp
+ @${REINPLACE_CMD} -e '428,433d' ${WRKSRC}/src/RpcComplexMatrix.cpp
+ @${REINPLACE_CMD} -e '591,596d' ${WRKSRC}/src/RpcDouble.cpp
+ @${REINPLACE_CMD} -e '350,355d' ${WRKSRC}/src/RpcIntegerConst.cpp
+ @${REINPLACE_CMD} -e '394,399d' ${WRKSRC}/src/RpcRealMatrix.cpp
+#
+# ...and put it right into class declaration instead, to please newer GCC
+#
+ @${REINPLACE_CMD} -E 's,([[:alnum:]]+ getData\( void \));,inline \1 { return data; },' \
+ ${WRKSRC}/src/RpcComplex.h ${WRKSRC}/src/RpcComplexMatrix.h \
+ ${WRKSRC}/src/RpcDouble.h ${WRKSRC}/src/RpcIntegerConst.h \
+ ${WRKSRC}/src/RpcRealMatrix.h
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}