aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-21 10:35:44 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-21 10:35:44 +0000
commitca55ab571893a4cd2f4207580718ee602770ec3c (patch)
tree0200b4edc6f09225518d16134e28aa7e351fa3ca /math
parent107cce2791b885165c552be6e6c4ee8fbd7b04ef (diff)
downloadports-ca55ab571893a4cd2f4207580718ee602770ec3c.tar.gz
ports-ca55ab571893a4cd2f4207580718ee602770ec3c.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/rapid/Makefile14
-rw-r--r--math/rapid/files/patch-sample_client.C11
-rw-r--r--math/rapid/pkg-plist1
3 files changed, 17 insertions, 9 deletions
diff --git a/math/rapid/Makefile b/math/rapid/Makefile
index 886496453b25..50a0d9b89768 100644
--- a/math/rapid/Makefile
+++ b/math/rapid/Makefile
@@ -19,21 +19,17 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
ALL_TARGET=
MAKE_JOBS_UNSAFE= yes
-MAN1= rapid.1
+MAKE_ENV+= V=1
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-extract:
${REINPLACE_CMD} -E "s/friend RAPID_Collide/friend int RAPID_Collide/" ${WRKSRC}/RAPID_private.H
do-install:
- ${MKDIR} ${PREFIX}/include/RAPID
- ${INSTALL_DATA} ${WRKSRC}/*.H ${PREFIX}/include/RAPID
- ${INSTALL_DATA} ${WRKSRC}/libRAPID.a ${PREFIX}/lib
- ${INSTALL_MAN} ${FILESDIR}/rapid.1 ${MANPREFIX}/man/man1
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/RAPID
+ ${INSTALL_DATA} ${WRKSRC}/*.H ${STAGEDIR}${PREFIX}/include/RAPID
+ ${INSTALL_DATA} ${WRKSRC}/libRAPID.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_MAN} ${FILESDIR}/rapid.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.post.mk>
diff --git a/math/rapid/files/patch-sample_client.C b/math/rapid/files/patch-sample_client.C
new file mode 100644
index 000000000000..ea604b4b0542
--- /dev/null
+++ b/math/rapid/files/patch-sample_client.C
@@ -0,0 +1,11 @@
+--- ./sample_client.C.orig 2014-02-21 11:34:06.215654443 +0100
++++ ./sample_client.C 2014-02-21 11:34:17.068652509 +0100
+@@ -42,7 +42,7 @@
+ #define LISTS 0
+
+
+-main()
++int main()
+ {
+ // first, get a couple of boxes in which to put our models
+
diff --git a/math/rapid/pkg-plist b/math/rapid/pkg-plist
index a0f872e2ea78..44bf8911e55f 100644
--- a/math/rapid/pkg-plist
+++ b/math/rapid/pkg-plist
@@ -6,4 +6,5 @@ include/RAPID/moments.H
include/RAPID/obb.H
include/RAPID/overlap.H
lib/libRAPID.a
+man/man1/rapid.1.gz
@dirrm include/RAPID