aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-03-18 20:02:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-03-18 20:02:59 +0000
commite0193cf54abca0accff7064b3dbec34a54249501 (patch)
tree66161e59d4bc336e74834024b003e20940dd2b6e /math
parentbcb2160bcc50bf80ee9001f2f6476dcbdd31cf59 (diff)
downloadports-e0193cf54abca0accff7064b3dbec34a54249501.tar.gz
ports-e0193cf54abca0accff7064b3dbec34a54249501.zip
New port: math/s2geometry: Geometry library for manipulating geometric shapes
Notes
Notes: svn path=/head/; revision=568759
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/s2geometry/Makefile23
-rw-r--r--math/s2geometry/distinfo3
-rw-r--r--math/s2geometry/files/patch-CMakeLists.txt48
-rw-r--r--math/s2geometry/pkg-descr6
-rw-r--r--math/s2geometry/pkg-plist174
6 files changed, 255 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 8178d4320728..c94ba37f5c8e 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -923,6 +923,7 @@
SUBDIR += rubygem-prime
SUBDIR += rubygem-rb-gsl
SUBDIR += rumur
+ SUBDIR += s2geometry
SUBDIR += saga
SUBDIR += sage
SUBDIR += sc
diff --git a/math/s2geometry/Makefile b/math/s2geometry/Makefile
new file mode 100644
index 000000000000..b51c89badbe1
--- /dev/null
+++ b/math/s2geometry/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= s2geometry
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.9.0-27
+DISTVERSIONSUFFIX= -g0c4c460
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Geometry library for manipulating geometric shapes
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake compiler:c++11-lang ssl
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= google
+
+CMAKE_OFF= BUILD_EXAMPLES
+
+.include <bsd.port.mk>
diff --git a/math/s2geometry/distinfo b/math/s2geometry/distinfo
new file mode 100644
index 000000000000..de2ff67f9fd0
--- /dev/null
+++ b/math/s2geometry/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1616096455
+SHA256 (google-s2geometry-v0.9.0-27-g0c4c460_GH0.tar.gz) = 99e2a8d3564668e623a60c79c71409f95275d09598b75659cafc432d2f0ddfd4
+SIZE (google-s2geometry-v0.9.0-27-g0c4c460_GH0.tar.gz) = 1128790
diff --git a/math/s2geometry/files/patch-CMakeLists.txt b/math/s2geometry/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..ba1131276406
--- /dev/null
+++ b/math/s2geometry/files/patch-CMakeLists.txt
@@ -0,0 +1,48 @@
+- Tests are fused with code: https://github.com/google/s2geometry/issues/179
+- Python binding is unconditional: https://github.com/google/s2geometry/issues/180
+
+--- CMakeLists.txt.orig 2021-03-16 08:18:05 UTC
++++ CMakeLists.txt
+@@ -65,7 +65,8 @@ find_package(Threads REQUIRED)
+ find_package(SWIG)
+ # Use Python3_ROOT_DIR to help find python3, if the correct location is not
+ # being found by default.
+-find_package(Python3 COMPONENTS Interpreter Development)
++#find_package(Python3 COMPONENTS Interpreter Development)
++set(Python3_FOUND FALSE)
+
+ if (WIN32)
+ # Use unsigned characters
+@@ -200,10 +201,10 @@ add_library(s2
+ src/s2/util/math/exactfloat/exactfloat.cc
+ src/s2/util/math/mathutil.cc
+ src/s2/util/units/length-units.cc)
+-add_library(s2testing STATIC
+- src/s2/s2builderutil_testing.cc
+- src/s2/s2shapeutil_testing.cc
+- src/s2/s2testing.cc)
++#add_library(s2testing STATIC
++# src/s2/s2builderutil_testing.cc
++# src/s2/s2shapeutil_testing.cc
++# src/s2/s2testing.cc)
+ target_link_libraries(
+ s2
+ ${GFLAGS_LIBRARIES} ${GLOG_LIBRARIES} ${OPENSSL_LIBRARIES}
+@@ -414,7 +415,7 @@ install(FILES src/s2/util/math/mathutil.h
+ install(FILES src/s2/util/units/length-units.h
+ src/s2/util/units/physical-units.h
+ DESTINATION include/s2/util/units)
+-install(TARGETS s2 s2testing DESTINATION lib)
++install(TARGETS s2 DESTINATION lib)
+
+ message("GTEST_ROOT: ${GTEST_ROOT}")
+ if (GTEST_ROOT)
+@@ -529,7 +530,7 @@ if (GTEST_ROOT)
+ add_executable(${test} ${test_cc})
+ target_link_libraries(
+ ${test}
+- s2testing s2 gtest_main)
++ s2 gtest_main)
+ add_test(${test} ${test})
+ endforeach()
+ endif()
diff --git a/math/s2geometry/pkg-descr b/math/s2geometry/pkg-descr
new file mode 100644
index 000000000000..8cca027412db
--- /dev/null
+++ b/math/s2geometry/pkg-descr
@@ -0,0 +1,6 @@
+s2geometry is a package for manipulating geometric shapes. Unlike many geometry
+libraries, S2 is primarily designed to work with spherical geometry, i.e.,
+shapes drawn on a sphere rather than on a planar 2D map. This makes it
+especially suitable for working with geographic data.
+
+WWW: https://github.com/google/s2geometry
diff --git a/math/s2geometry/pkg-plist b/math/s2geometry/pkg-plist
new file mode 100644
index 000000000000..8f83b0f04345
--- /dev/null
+++ b/math/s2geometry/pkg-plist
@@ -0,0 +1,174 @@
+include/s2/_fp_contract_off.h
+include/s2/base/casts.h
+include/s2/base/commandlineflags.h
+include/s2/base/integral_types.h
+include/s2/base/log_severity.h
+include/s2/base/logging.h
+include/s2/base/mutex.h
+include/s2/base/port.h
+include/s2/base/spinlock.h
+include/s2/encoded_s2cell_id_vector.h
+include/s2/encoded_s2point_vector.h
+include/s2/encoded_s2shape_index.h
+include/s2/encoded_string_vector.h
+include/s2/encoded_uint_vector.h
+include/s2/id_set_lexicon.h
+include/s2/mutable_s2shape_index.h
+include/s2/r1interval.h
+include/s2/r2.h
+include/s2/r2rect.h
+include/s2/s1angle.h
+include/s2/s1chord_angle.h
+include/s2/s1interval.h
+include/s2/s2boolean_operation.h
+include/s2/s2builder.h
+include/s2/s2builder_graph.h
+include/s2/s2builder_layer.h
+include/s2/s2builderutil_closed_set_normalizer.h
+include/s2/s2builderutil_find_polygon_degeneracies.h
+include/s2/s2builderutil_graph_shape.h
+include/s2/s2builderutil_lax_polygon_layer.h
+include/s2/s2builderutil_s2point_vector_layer.h
+include/s2/s2builderutil_s2polygon_layer.h
+include/s2/s2builderutil_s2polyline_layer.h
+include/s2/s2builderutil_s2polyline_vector_layer.h
+include/s2/s2builderutil_snap_functions.h
+include/s2/s2builderutil_testing.h
+include/s2/s2cap.h
+include/s2/s2cell.h
+include/s2/s2cell_id.h
+include/s2/s2cell_index.h
+include/s2/s2cell_union.h
+include/s2/s2centroids.h
+include/s2/s2closest_cell_query.h
+include/s2/s2closest_cell_query_base.h
+include/s2/s2closest_edge_query.h
+include/s2/s2closest_edge_query_base.h
+include/s2/s2closest_point_query.h
+include/s2/s2closest_point_query_base.h
+include/s2/s2contains_point_query.h
+include/s2/s2contains_vertex_query.h
+include/s2/s2convex_hull_query.h
+include/s2/s2coords.h
+include/s2/s2coords_internal.h
+include/s2/s2crossing_edge_query.h
+include/s2/s2debug.h
+include/s2/s2distance_target.h
+include/s2/s2earth.h
+include/s2/s2edge_clipping.h
+include/s2/s2edge_crosser.h
+include/s2/s2edge_crossings.h
+include/s2/s2edge_distances.h
+include/s2/s2edge_tessellator.h
+include/s2/s2edge_vector_shape.h
+include/s2/s2error.h
+include/s2/s2furthest_edge_query.h
+include/s2/s2latlng.h
+include/s2/s2latlng_rect.h
+include/s2/s2latlng_rect_bounder.h
+include/s2/s2lax_loop_shape.h
+include/s2/s2lax_polygon_shape.h
+include/s2/s2lax_polyline_shape.h
+include/s2/s2loop.h
+include/s2/s2loop_measures.h
+include/s2/s2max_distance_targets.h
+include/s2/s2measures.h
+include/s2/s2metrics.h
+include/s2/s2min_distance_targets.h
+include/s2/s2padded_cell.h
+include/s2/s2point.h
+include/s2/s2point_compression.h
+include/s2/s2point_index.h
+include/s2/s2point_region.h
+include/s2/s2point_span.h
+include/s2/s2point_vector_shape.h
+include/s2/s2pointutil.h
+include/s2/s2polygon.h
+include/s2/s2polyline.h
+include/s2/s2polyline_alignment.h
+include/s2/s2polyline_measures.h
+include/s2/s2polyline_simplifier.h
+include/s2/s2predicates.h
+include/s2/s2projections.h
+include/s2/s2r2rect.h
+include/s2/s2region.h
+include/s2/s2region_coverer.h
+include/s2/s2region_intersection.h
+include/s2/s2region_term_indexer.h
+include/s2/s2region_union.h
+include/s2/s2shape.h
+include/s2/s2shape_index.h
+include/s2/s2shape_index_buffered_region.h
+include/s2/s2shape_index_region.h
+include/s2/s2shape_measures.h
+include/s2/s2shapeutil_build_polygon_boundaries.h
+include/s2/s2shapeutil_coding.h
+include/s2/s2shapeutil_contains_brute_force.h
+include/s2/s2shapeutil_count_edges.h
+include/s2/s2shapeutil_edge_iterator.h
+include/s2/s2shapeutil_get_reference_point.h
+include/s2/s2shapeutil_range_iterator.h
+include/s2/s2shapeutil_shape_edge.h
+include/s2/s2shapeutil_shape_edge_id.h
+include/s2/s2shapeutil_testing.h
+include/s2/s2shapeutil_visit_crossing_edge_pairs.h
+include/s2/s2testing.h
+include/s2/s2text_format.h
+include/s2/s2wedge_relations.h
+include/s2/sequence_lexicon.h
+include/s2/strings/ostringstream.h
+include/s2/third_party/absl/algorithm/algorithm.h
+include/s2/third_party/absl/base/attributes.h
+include/s2/third_party/absl/base/casts.h
+include/s2/third_party/absl/base/config.h
+include/s2/third_party/absl/base/dynamic_annotations.h
+include/s2/third_party/absl/base/internal/identity.h
+include/s2/third_party/absl/base/internal/inline_variable.h
+include/s2/third_party/absl/base/internal/invoke.h
+include/s2/third_party/absl/base/internal/throw_delegate.h
+include/s2/third_party/absl/base/internal/unaligned_access.h
+include/s2/third_party/absl/base/log_severity.h
+include/s2/third_party/absl/base/macros.h
+include/s2/third_party/absl/base/optimization.h
+include/s2/third_party/absl/base/policy_checks.h
+include/s2/third_party/absl/base/port.h
+include/s2/third_party/absl/base/thread_annotations.h
+include/s2/third_party/absl/container/inlined_vector.h
+include/s2/third_party/absl/container/internal/compressed_tuple.h
+include/s2/third_party/absl/container/internal/container_memory.h
+include/s2/third_party/absl/container/internal/layout.h
+include/s2/third_party/absl/memory/memory.h
+include/s2/third_party/absl/meta/type_traits.h
+include/s2/third_party/absl/numeric/int128.h
+include/s2/third_party/absl/numeric/int128_have_intrinsic.inc
+include/s2/third_party/absl/numeric/int128_no_intrinsic.inc
+include/s2/third_party/absl/strings/numbers.h
+include/s2/third_party/absl/strings/str_cat.h
+include/s2/third_party/absl/strings/string_view.h
+include/s2/third_party/absl/types/span.h
+include/s2/third_party/absl/utility/utility.h
+include/s2/util/bits/bits.h
+include/s2/util/coding/coder.h
+include/s2/util/coding/varint.h
+include/s2/util/endian/endian.h
+include/s2/util/gtl/btree.h
+include/s2/util/gtl/btree_container.h
+include/s2/util/gtl/btree_map.h
+include/s2/util/gtl/btree_set.h
+include/s2/util/gtl/compact_array.h
+include/s2/util/gtl/container_logging.h
+include/s2/util/gtl/dense_hash_set.h
+include/s2/util/gtl/densehashtable.h
+include/s2/util/gtl/hashtable_common.h
+include/s2/util/gtl/layout.h
+include/s2/util/hash/mix.h
+include/s2/util/math/mathutil.h
+include/s2/util/math/matrix3x3.h
+include/s2/util/math/vector.h
+include/s2/util/math/vector3_hash.h
+include/s2/util/units/length-units.h
+include/s2/util/units/physical-units.h
+include/s2/value_lexicon.h
+lib/libs2.so
+lib/libs2.so.0
+lib/libs2.so.0.10.0