aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2020-09-27 13:54:24 +0000
committerNicola Vitale <nivit@FreeBSD.org>2020-09-27 13:54:24 +0000
commit0e5bdc3ed6164e4b5231a6c8a829cd0a7126e495 (patch)
treed7132643e0a460dead62293292aacc74071a4366 /math
parent84c0f6e6af0ad57feaba093f290726de6b804441 (diff)
downloadports-0e5bdc3ed6164e4b5231a6c8a829cd0a7126e495.tar.gz
ports-0e5bdc3ed6164e4b5231a6c8a829cd0a7126e495.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/asymptote/Makefile23
-rw-r--r--math/asymptote/distinfo6
-rw-r--r--math/asymptote/files/patch-xstream.h28
-rw-r--r--math/asymptote/pkg-plist181
4 files changed, 116 insertions, 122 deletions
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 2524fc8d2c97..8ed09cd34cc7 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= asymptote
-PORTVERSION= 2.56
-PORTREVISION= 3
+PORTVERSION= 2.67
+PORTREVISION= 0
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -16,13 +16,15 @@ LICENSE_COMB= dual
ONLY_FOR_ARCHS= amd64 i386
-LIB_DEPENDS= libsigsegv.so:devel/libsigsegv
-RUN_DEPENDS= animate:graphics/ImageMagick6 \
- gv:print/gv \
- ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR} \
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libsigsegv.so:devel/libsigsegv
+RUN_DEPENDS= rsvg-convert:graphics/librsvg2 \
+ ${PYTHON_PKGNAMEPREFIX}cson>=0.8:devel/py-cson@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}qt5-svg>0:graphics/py-qt5-svg@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}qt5-widgets>0:x11-toolkits/py-qt5-widgets@${PY_FLAVOR} \
${PY_PILLOW}
-USES= compiler:c++14-lang gettext-runtime ghostscript gl gmake ncurses perl5 python \
+USES= compiler:c++14-lang gettext-runtime ghostscript gl gmake ncurses perl5 python:3.6+ \
shebangfix tar:tgz
SHEBANG_FILES= GUI/*.py
USE_GL= gl glu glut
@@ -72,15 +74,16 @@ OFFSCREEN_LIB_DEPENDS= libOSMesa.so:graphics/libosmesa
READLINE_CONFIGURE_ENABLE= readline
READLINE_USES= readline:port
+TEST_TARGET= test
+TEST_WRKSRC= ${WRKSRC}/tests
+
post-patch:
@${REINPLACE_CMD} 's/-lgc/-lgc-threaded/' ${WRKSRC}/configure
- @${REINPLACE_CMD} 's,/usr/lib/libgs.so,${LOCALBASE}/lib/libgs.so,' \
- ${WRKSRC}/settings.cc
@${REINPLACE_CMD} 's,makeinfo,${LOCALBASE}/bin/makeinfo,' \
${WRKSRC}/doc/png/Makefile.in
# Fix the python interpreter in the generated file share/asymptote/GUI/xasyVersion.py:
- @${REINPLACE_CMD} 's,/usr/bin/env python,${PYTHON_CMD},' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} 's,/usr/bin/env python3,${PYTHON_CMD},' ${WRKSRC}/Makefile.in
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/asy
diff --git a/math/asymptote/distinfo b/math/asymptote/distinfo
index aa49b4d1539f..7eaaec226d2d 100644
--- a/math/asymptote/distinfo
+++ b/math/asymptote/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1570174816
-SHA256 (asymptote-2.56.src.tgz) = 5d43a3e586045e149d077dcc367e30b603e97bd430fbf957d05049f52035851b
-SIZE (asymptote-2.56.src.tgz) = 4125617
+TIMESTAMP = 1601134257
+SHA256 (asymptote-2.67.src.tgz) = 8a1e574b81140b3fc1f5be659468bf90a313255a5a548ddd9fd11d4155e72d9b
+SIZE (asymptote-2.67.src.tgz) = 4668696
diff --git a/math/asymptote/files/patch-xstream.h b/math/asymptote/files/patch-xstream.h
index fb97b38e644d..362604ebb1e0 100644
--- a/math/asymptote/files/patch-xstream.h
+++ b/math/asymptote/files/patch-xstream.h
@@ -1,23 +1,11 @@
---- xstream.h.orig 2018-06-10 15:14:47 UTC
+--- xstream.h.orig 2020-08-06 02:32:59 UTC
+++ xstream.h
-@@ -31,7 +31,7 @@
- #define quad_t long long
- #define u_quad_t unsigned long long
-
--#if defined(__CYGWIN__) || defined(__FreeBSD__)
-+#if defined(__CYGWIN__)
- #include <sys/select.h>
- #define u_char unsigned char
- #define u_int unsigned int
-@@ -41,6 +41,11 @@ extern "C" int fseeko(FILE *, off_t, int
+@@ -41,7 +41,7 @@ extern "C" int fseeko(FILE *, off_t, int);
extern "C" off_t ftello(FILE *);
- #endif
+ #endif
-+#ifdef __FreeBSD__
-+#define xdr_longlong_t xdr_int64_t
-+#define xdr_u_longlong_t xdr_u_int64_t
-+#endif
-+
- #ifdef _POSIX_SOURCE
- #undef _POSIX_SOURCE
- #include <rpc/rpc.h>
+-#ifdef __APPLE__
++if defined(__APPLE__) || defined(__FreeBSD__)
+ #include <rpc/xdr.h>
+
+ inline bool_t xdr_long(XDR *__xdrs, long *__lp) {
diff --git a/math/asymptote/pkg-plist b/math/asymptote/pkg-plist
index cbfd904108fb..32eb1fcfce16 100644
--- a/math/asymptote/pkg-plist
+++ b/math/asymptote/pkg-plist
@@ -1,87 +1,5 @@
bin/asy
bin/xasy
-share/info/asymptote/Bode.png
-share/info/asymptote/CAD1.png
-share/info/asymptote/CDlabel.png
-share/info/asymptote/GaussianSurface.png
-share/info/asymptote/HermiteSpline.png
-share/info/asymptote/Hobbycontrol.png
-share/info/asymptote/Hobbydir.png
-share/info/asymptote/asymptote.info
-share/info/asymptote/axis3.png
-share/info/asymptote/bezier.png
-share/info/asymptote/bezier2.png
-share/info/asymptote/beziercurve.png
-share/info/asymptote/bigdiagonal.png
-share/info/asymptote/binarytreetest.png
-share/info/asymptote/brokenaxis.png
-share/info/asymptote/colons.png
-share/info/asymptote/colors.png
-share/info/asymptote/cube.png
-share/info/asymptote/cylinderskeleton.png
-share/info/asymptote/datagraph.png
-share/info/asymptote/diagonal.png
-share/info/asymptote/diatom.png
-share/info/asymptote/dots.png
-share/info/asymptote/eetomumu.png
-share/info/asymptote/elliptic.png
-share/info/asymptote/errorbars.png
-share/info/asymptote/exp.png
-share/info/asymptote/filegraph.png
-share/info/asymptote/flow.png
-share/info/asymptote/flowchartdemo.png
-share/info/asymptote/generalaxis.png
-share/info/asymptote/generalaxis3.png
-share/info/asymptote/graphmarkers.png
-share/info/asymptote/grid3xyz.png
-share/info/asymptote/hatch.png
-share/info/asymptote/helix.png
-share/info/asymptote/histogram.png
-share/info/asymptote/icon.png
-share/info/asymptote/image.png
-share/info/asymptote/imagecontour.png
-share/info/asymptote/irregularcontour.png
-share/info/asymptote/join.png
-share/info/asymptote/join3.png
-share/info/asymptote/knots.png
-share/info/asymptote/labelsquare.png
-share/info/asymptote/latexusage.png
-share/info/asymptote/leastsquares.png
-share/info/asymptote/legend.png
-share/info/asymptote/lineargraph.png
-share/info/asymptote/lineargraph0.png
-share/info/asymptote/linetype.png
-share/info/asymptote/log2graph.png
-share/info/asymptote/loggraph.png
-share/info/asymptote/loggrid.png
-share/info/asymptote/logimage.png
-share/info/asymptote/logo.png
-share/info/asymptote/logticks.png
-share/info/asymptote/makepen.png
-share/info/asymptote/markers1.png
-share/info/asymptote/markers2.png
-share/info/asymptote/mexicanhat.png
-share/info/asymptote/monthaxis.png
-share/info/asymptote/multicontour.png
-share/info/asymptote/onecontour.png
-share/info/asymptote/parametricgraph.png
-share/info/asymptote/penfunctionimage.png
-share/info/asymptote/penimage.png
-share/info/asymptote/planes.png
-share/info/asymptote/quartercircle.png
-share/info/asymptote/saddle.png
-share/info/asymptote/scaledgraph.png
-share/info/asymptote/secondaryaxis.png
-share/info/asymptote/shadedtiling.png
-share/info/asymptote/slopefield1.png
-share/info/asymptote/square.png
-share/info/asymptote/subpictures.png
-share/info/asymptote/superpath.png
-share/info/asymptote/tile.png
-share/info/asymptote/triangulate.png
-share/info/asymptote/unitcircle3.png
-share/info/asymptote/vectorfield.png
-share/info/asymptote/westnile.png
man/man1/asy.1.gz
man/man1/xasy.1x.gz
%%DATADIR%%/CAD.asy
@@ -196,8 +114,8 @@ man/man1/xasy.1x.gz
%%DATADIR%%/interpolate.asy
%%DATADIR%%/labelpath.asy
%%DATADIR%%/labelpath3.asy
-%%DATADIR%%/latin1.asy
%%DATADIR%%/lmfit.asy
+%%DATADIR%%/map.asy
%%DATADIR%%/markers.asy
%%DATADIR%%/math.asy
%%DATADIR%%/metapost.asy
@@ -250,17 +168,15 @@ man/man1/xasy.1x.gz
%%DATADIR%%/tree.asy
%%DATADIR%%/trembling.asy
%%DATADIR%%/tube.asy
-%%DATADIR%%/unicode.asy
%%DATADIR%%/version.asy
-%%DATADIR%%/webgl/WebGLfooter.html
-%%DATADIR%%/webgl/WebGLheader.html
-%%DATADIR%%/webgl/asygl-1.00.js
+%%DATADIR%%/webgl/asygl.js
%%DATADIR%%/x11colors.asy
%%PORTDOCS%%%%DOCSDIR%%/CAD.pdf
%%PORTDOCS%%%%DOCSDIR%%/TeXShopAndAsymptote.pdf
%%PORTDOCS%%%%DOCSDIR%%/asy-latex.pdf
%%PORTDOCS%%%%DOCSDIR%%/asyRefCard.pdf
%%PORTDOCS%%%%DOCSDIR%%/asymptote.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/100d.pdb1
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/100d.views
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/1overx.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/BezierPatch.asy
@@ -309,6 +225,7 @@ man/man1/xasy.1x.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/animations/wheel.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/annotation.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arrows3.asy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/axialshade.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/axis3.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bars3.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/basealign.asy
@@ -463,7 +380,7 @@ man/man1/xasy.1x.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/onecontour.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/oneoverx.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/orthocenter.asy
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/p-orbital.asy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pOrbital.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/parametricelevation.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/parametricgraph.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/parametricsurface.asy
@@ -474,7 +391,7 @@ man/man1/xasy.1x.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/penfunctionimage.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/penimage.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/phase.asy
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/piicon.eps
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/piicon.png
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pipeintersection.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pipes.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pixel.pdf
@@ -548,8 +465,10 @@ man/man1/xasy.1x.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/thermodynamics.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/threeviews.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tile.asy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tiling.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/torus.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/transparency.asy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/transparentCubes.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/treetest.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/trefoilknot.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/triads.asy
@@ -564,6 +483,7 @@ man/man1/xasy.1x.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unitcircle.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unitcircle3.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unitoctant.asy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unitoctantx.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upint.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vectorfield.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vectorfield3.asy
@@ -579,12 +499,95 @@ man/man1/xasy.1x.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/workcone.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/worksheet.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/worldmap.asy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/worldmap.dat
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xsin1x.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xstitch.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xxsq01.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xxsq01x-1.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/xxsq01y.asy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/yingyang.asy
+share/info/asymptote/Bode.png
+share/info/asymptote/CAD1.png
+share/info/asymptote/CDlabel.png
+share/info/asymptote/GaussianSurface.png
+share/info/asymptote/HermiteSpline.png
+share/info/asymptote/Hobbycontrol.png
+share/info/asymptote/Hobbydir.png
+share/info/asymptote/asymptote.info
+share/info/asymptote/axis3.png
+share/info/asymptote/bezier.png
+share/info/asymptote/bezier2.png
+share/info/asymptote/beziercurve.png
+share/info/asymptote/bigdiagonal.png
+share/info/asymptote/binarytreetest.png
+share/info/asymptote/brokenaxis.png
+share/info/asymptote/colons.png
+share/info/asymptote/colors.png
+share/info/asymptote/cube.png
+share/info/asymptote/cylinderskeleton.png
+share/info/asymptote/datagraph.png
+share/info/asymptote/diagonal.png
+share/info/asymptote/diatom.png
+share/info/asymptote/dots.png
+share/info/asymptote/eetomumu.png
+share/info/asymptote/elliptic.png
+share/info/asymptote/errorbars.png
+share/info/asymptote/exp.png
+share/info/asymptote/filegraph.png
+share/info/asymptote/flow.png
+share/info/asymptote/flowchartdemo.png
+share/info/asymptote/generalaxis.png
+share/info/asymptote/generalaxis3.png
+share/info/asymptote/graphmarkers.png
+share/info/asymptote/grid3xyz.png
+share/info/asymptote/hatch.png
+share/info/asymptote/helix.png
+share/info/asymptote/histogram.png
+share/info/asymptote/icon.png
+share/info/asymptote/image.png
+share/info/asymptote/imagecontour.png
+share/info/asymptote/irregularcontour.png
+share/info/asymptote/join.png
+share/info/asymptote/join3.png
+share/info/asymptote/knots.png
+share/info/asymptote/labelsquare.png
+share/info/asymptote/latexusage.png
+share/info/asymptote/leastsquares.png
+share/info/asymptote/legend.png
+share/info/asymptote/lineargraph.png
+share/info/asymptote/lineargraph0.png
+share/info/asymptote/linetype.png
+share/info/asymptote/log2graph.png
+share/info/asymptote/loggraph.png
+share/info/asymptote/loggrid.png
+share/info/asymptote/logimage.png
+share/info/asymptote/logo.png
+share/info/asymptote/logticks.png
+share/info/asymptote/makepen.png
+share/info/asymptote/markers1.png
+share/info/asymptote/markers2.png
+share/info/asymptote/mexicanhat.png
+share/info/asymptote/monthaxis.png
+share/info/asymptote/multicontour.png
+share/info/asymptote/onecontour.png
+share/info/asymptote/parametricgraph.png
+share/info/asymptote/penfunctionimage.png
+share/info/asymptote/penimage.png
+share/info/asymptote/planes.png
+share/info/asymptote/quartercircle.png
+share/info/asymptote/saddle.png
+share/info/asymptote/scaledgraph.png
+share/info/asymptote/secondaryaxis.png
+share/info/asymptote/shadedtiling.png
+share/info/asymptote/slopefield1.png
+share/info/asymptote/square.png
+share/info/asymptote/subpictures.png
+share/info/asymptote/superpath.png
+share/info/asymptote/tile.png
+share/info/asymptote/triangulate.png
+share/info/asymptote/unitcircle3.png
+share/info/asymptote/vectorfield.png
+share/info/asymptote/westnile.png
%%TEXMFLOCALDIR%%/tex/context/third/asymptote/colo-asy.tex
%%TEXMFLOCALDIR%%/tex/latex/asymptote/asycolors.sty
%%TEXMFLOCALDIR%%/tex/latex/asymptote/asymptote.sty