aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-10-24 16:44:52 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-10-24 16:44:52 +0000
commit3236d3695df8e68edcc2e5f3c4173c9659f8f304 (patch)
tree1b0d50862b4eff3d2d8caeb8605fcfe3925b64fc /math
parent314c90269945539748a00b81797626ae93cecf6d (diff)
downloadports-3236d3695df8e68edcc2e5f3c4173c9659f8f304.tar.gz
ports-3236d3695df8e68edcc2e5f3c4173c9659f8f304.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/scilab/Makefile2
-rw-r--r--math/scilab/files/patch-configure18
2 files changed, 19 insertions, 1 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index f133adfb55da..cd0188327dad 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -201,7 +201,7 @@ post-extract:
post-patch:
@# Configure fixes
@${REINPLACE_CMD} -e 's|-ldl | |' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-lumfpack|-lumfpack -lamd -lcholmod -lcolamd $$LAPACK_LIBS $$BLAS_LIBS|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lumfpack|-lumfpack -lsuitesparseconfig -lamd -lcholmod -lcolamd $$LAPACK_LIBS $$BLAS_LIBS|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|TCLTK_LIBS=" -ldl"|TCLTK_LIBS=" "|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|"x=" ==|"x" =|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|"x" ==|"x" =|g' ${WRKSRC}/configure
diff --git a/math/scilab/files/patch-configure b/math/scilab/files/patch-configure
index fa5df8b0e352..d0079959df09 100644
--- a/math/scilab/files/patch-configure
+++ b/math/scilab/files/patch-configure
@@ -1,5 +1,23 @@
--- ./configure.orig 2011-07-20 08:15:42.000000000 +0000
+++ ./configure 2013-10-23 11:59:48.722499060 +0000
+@@ -12226,14 +12226,15 @@
+
+ public class conftest {
+ public static void main(String[] argv) {
+- String minVersion="1.8.4";
++ int minVersion=10804;
+ int[] vers = new int[3];
+ try { H5.H5get_libversion(vers); }
+ catch (Throwable ex) {System.exit(-1);}
+ String ver = vers[0] + "."+ vers[1] +"."+vers[2];
++ int Version = 10000*vers[0] + 100*vers[1] + vers[2];
+
+ System.out.println(ver);
+- if (minVersion.compareTo(ver) > 0) {
++ if (minVersion > Version) {
+ System.exit(-1);
+ }
+
@@ -12281,14 +12281,15 @@
public class conftest {