aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-11 19:25:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-11 19:25:17 +0000
commit5d7dcdec462a1e66891ba4ef178ccfc2c88016d3 (patch)
tree34d2fa2d280a591e71fb76d52f28f1b48eb6621a /math
parent3808749df3ed9b6980a6b6003903720f9424e2d1 (diff)
downloadports-5d7dcdec462a1e66891ba4ef178ccfc2c88016d3.tar.gz
ports-5d7dcdec462a1e66891ba4ef178ccfc2c88016d3.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/chryzodus/Makefile31
-rw-r--r--math/chryzodus/distinfo2
-rw-r--r--math/chryzodus/files/patch-gui.cpp12
-rw-r--r--math/chryzodus/files/patch-makefile.unx12
-rw-r--r--math/chryzodus/pkg-descr10
-rw-r--r--math/chryzodus/pkg-plist10
7 files changed, 78 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 35e579180589..c30fc42f43c3 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -28,6 +28,7 @@
SUBDIR += calcoo
SUBDIR += calctool
SUBDIR += ccmath
+ SUBDIR += chryzodus
SUBDIR += clarence
SUBDIR += cln
SUBDIR += concorde
diff --git a/math/chryzodus/Makefile b/math/chryzodus/Makefile
new file mode 100644
index 000000000000..a280d709e161
--- /dev/null
+++ b/math/chryzodus/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: chryzodus
+# Date created: 2005-07-09
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= chryzodus
+PORTVERSION= 0.32
+DISTVERSIONSUFFIX= -src
+CATEGORIES= math
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= nivit@email.it
+COMMENT= A chryzode (http//www.chryzode.org) explorer
+
+LIB_DEPENDS= alleg.41:${PORTSDIR}/devel/allegro
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKEFILE= makefile.unx
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/chryzodus/distinfo b/math/chryzodus/distinfo
new file mode 100644
index 000000000000..82f4edc79f5c
--- /dev/null
+++ b/math/chryzodus/distinfo
@@ -0,0 +1,2 @@
+MD5 (chryzodus-0.32-src.tar.gz) = d89eafdb85d236bb2c1ed7e3acba37ae
+SIZE (chryzodus-0.32-src.tar.gz) = 18834
diff --git a/math/chryzodus/files/patch-gui.cpp b/math/chryzodus/files/patch-gui.cpp
new file mode 100644
index 000000000000..5dec7726e2cd
--- /dev/null
+++ b/math/chryzodus/files/patch-gui.cpp
@@ -0,0 +1,12 @@
+$FreeBSD$
+--- gui.cpp Tue Jun 29 17:16:38 2004
++++ gui.cpp.port Sat Jul 9 21:25:43 2005
+@@ -121,7 +121,7 @@
+ {
+ // utiliser d_chryzode_proc pour tenir jour la bitmap ??????
+ destroy_bitmap((BITMAP *)main_dialog[MAIN_D_CHRYZODE].dp);
+- (BITMAP *)main_dialog[MAIN_D_CHRYZODE].dp = create_bitmap(SCREEN_W, SCREEN_H);
++ main_dialog[MAIN_D_CHRYZODE].dp = (BITMAP *)create_bitmap(SCREEN_W, SCREEN_H);
+ ((Cchryzode *)main_dialog[MAIN_D_CHRYZODE].dp2)->set_bmp((BITMAP *)main_dialog[MAIN_D_CHRYZODE].dp);
+ main_dialog[MAIN_D_CHRYZODE].w = SCREEN_W;
+ main_dialog[MAIN_D_CHRYZODE].h = SCREEN_H;
diff --git a/math/chryzodus/files/patch-makefile.unx b/math/chryzodus/files/patch-makefile.unx
new file mode 100644
index 000000000000..495b1d6bda18
--- /dev/null
+++ b/math/chryzodus/files/patch-makefile.unx
@@ -0,0 +1,12 @@
+$FreeBSD$
+--- makefile.unx Tue Jun 29 17:16:38 2004
++++ makefile.unx.port Sat Jul 9 21:43:27 2005
+@@ -6,7 +6,7 @@
+ #--------------------------------------#
+
+ CXX = g++
+-CFLAGS = -Wall
++CFLAGS = -Wall `allegro-config --cflags`
+ LDFLAGS = -s -lstdc++ `allegro-config --libs`
+
+ OBJECTS = main.o gui.o compute.o
diff --git a/math/chryzodus/pkg-descr b/math/chryzodus/pkg-descr
new file mode 100644
index 000000000000..bc2a37e121f6
--- /dev/null
+++ b/math/chryzodus/pkg-descr
@@ -0,0 +1,10 @@
+Chryzodus is a cross-platform graphical program drawing
+beautiful and colorful chryzodes.
+If you do not know what chryzodes are, take a look at
+http://www.chryzode.org/. Then you will be able to explore
+the world of chryzodes by yourself using Chryzodus.
+But one does not even need to know much about chryzodes
+to use Chryzodus and see beautiful images appear on the screen!
+
+Author: Florian LHERBETTE
+WWW: http://chryzodus.sourceforge.net/
diff --git a/math/chryzodus/pkg-plist b/math/chryzodus/pkg-plist
new file mode 100644
index 000000000000..3f82ef9a2b2d
--- /dev/null
+++ b/math/chryzodus/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+bin/chryzodus
+%%PORTDOCS%%%%DOCSDIR%%/chryzode.html
+%%PORTDOCS%%%%DOCSDIR%%/file.html
+%%PORTDOCS%%%%DOCSDIR%%/help.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/keyboard.html
+%%PORTDOCS%%%%DOCSDIR%%/overview.html
+%%PORTDOCS%%%%DOCSDIR%%/zoom.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%