aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2012-06-16 20:28:03 +0000
committerJohan van Selst <johans@FreeBSD.org>2012-06-16 20:28:03 +0000
commit6d226e5bb02e420d249e3b47fc1b1b5d6d0b5fd5 (patch)
treec031c7487a92aff70ba5d0696f2d922ccd9f7d14 /math
parent9bcc3c664c2585ad8dc2f00b3b20f20c00e9cae1 (diff)
downloadports-6d226e5bb02e420d249e3b47fc1b1b5d6d0b5fd5.tar.gz
ports-6d226e5bb02e420d249e3b47fc1b1b5d6d0b5fd5.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/ocaml-ocamlgraph/Makefile21
-rw-r--r--math/ocaml-ocamlgraph/distinfo4
-rw-r--r--math/ocaml-ocamlgraph/pkg-plist3
3 files changed, 19 insertions, 9 deletions
diff --git a/math/ocaml-ocamlgraph/Makefile b/math/ocaml-ocamlgraph/Makefile
index ca7e57064c5b..6fe5801a561c 100644
--- a/math/ocaml-ocamlgraph/Makefile
+++ b/math/ocaml-ocamlgraph/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ocamlgraph
-PORTVERSION= 1.8.1
-PORTREVISION= 1
+PORTVERSION= 1.8.2
CATEGORIES= math
MASTER_SITES= http://ocamlgraph.lri.fr/download/
PKGNAMEPREFIX= ocaml-
@@ -15,7 +14,9 @@ PKGNAMEPREFIX= ocaml-
MAINTAINER= johans@FreeBSD.org
COMMENT= Graph manipulation library for OCaml
-OPTIONS= GUI "Include user programs: viewer and editor" on
+OPTIONS_DEFINE= GUI
+OPTIONS_DEFAULT=GUI
+GUI_DESC= Include GUI user programs: viewer and editor
USE_OCAML= yes
USE_OCAML_FINDLIB= yes
@@ -29,9 +30,11 @@ PLIST_SUB+= OCAMLGRAPHDIR="${OCAML_LIBDIR}/${PORTNAME}"
ALL_TARGET= all
INSTALL_TARGET= install install-findlib
-.include <bsd.port.pre.mk>
+PORTSCOUT= skipv:1.81
-.ifdef WITH_GUI
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGUI}
BUILD_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
RUN_DEPENDS+= lablgtk2:${PORTSDIR}/x11-toolkits/ocaml-lablgtk2
PLIST_SUB+= GUI=""
@@ -40,16 +43,20 @@ CONFIGURE_ARGS+= LABLGTK2=no
PLIST_SUB+= GUI="@comment "
.endif
-.ifndef NOPORTDOCS
+.if ${PORT_OPTIONS:MDOCS}
ALL_TARGET+= doc
PORTDOCS= *
post-patch:
@${REINPLACE_CMD} -e '/VIEWER_DIR. doc/d' ${WRKSRC}/Makefile.in
+.if empty(PORT_OPTIONS:MGUI)
+ # Override auto-detection
+ @${REINPLACE_CMD} -Ee 's/(LABLGTK2)=yes/\1=no/' ${WRKSRC}/configure
+.endif
post-install:
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc; ${INSTALL_DATA} * ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/ocaml-ocamlgraph/distinfo b/math/ocaml-ocamlgraph/distinfo
index 6ceda864d886..d12e6b013a2d 100644
--- a/math/ocaml-ocamlgraph/distinfo
+++ b/math/ocaml-ocamlgraph/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ocamlgraph-1.8.1.tar.gz) = ba6388ffc2c15139b0f26330ef6dd922f0ff0f364eee99a3202bf1cd93512b43
-SIZE (ocamlgraph-1.8.1.tar.gz) = 252502
+SHA256 (ocamlgraph-1.8.2.tar.gz) = e54ae60cd977a032854166dad56348d0fb76c6cd8e03e960af455268f0c8b5a6
+SIZE (ocamlgraph-1.8.2.tar.gz) = 249253
diff --git a/math/ocaml-ocamlgraph/pkg-plist b/math/ocaml-ocamlgraph/pkg-plist
index 532070651bcd..69da1ba4ab93 100644
--- a/math/ocaml-ocamlgraph/pkg-plist
+++ b/math/ocaml-ocamlgraph/pkg-plist
@@ -9,6 +9,7 @@
%%OCAMLGRAPHDIR%%/cliquetree.mli
%%OCAMLGRAPHDIR%%/coloring.mli
%%OCAMLGRAPHDIR%%/components.mli
+%%OCAMLGRAPHDIR%%/contraction.mli
%%OCAMLGRAPHDIR%%/delaunay.mli
%%OCAMLGRAPHDIR%%/dot.mli
%%OCAMLGRAPHDIR%%/dot_ast.mli
@@ -26,9 +27,11 @@
%%OCAMLGRAPHDIR%%/graphviz.mli
%%OCAMLGRAPHDIR%%/imperative.mli
%%OCAMLGRAPHDIR%%/kruskal.mli
+%%OCAMLGRAPHDIR%%/leaderlist.mli
%%OCAMLGRAPHDIR%%/mcs_m.mli
%%OCAMLGRAPHDIR%%/md.mli
%%OCAMLGRAPHDIR%%/minsep.mli
+%%OCAMLGRAPHDIR%%/nonnegative.mli
%%OCAMLGRAPHDIR%%/oper.mli
%%OCAMLGRAPHDIR%%/pack.mli
%%OCAMLGRAPHDIR%%/path.mli