aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorRainer Hurling <rhurlin@FreeBSD.org>2021-09-24 12:55:14 +0000
committerRainer Hurling <rhurlin@FreeBSD.org>2021-09-24 13:00:48 +0000
commit0f8d4e530763194051d20cceb4c739550bf0b6b1 (patch)
treed108f7862f9a0d03cbee0512157d67672bc0817e /math
parent53681f2fc5d3a5f8ddaec7d4bd772ca75f6777eb (diff)
downloadports-0f8d4e530763194051d20cceb4c739550bf0b6b1.tar.gz
ports-0f8d4e530763194051d20cceb4c739550bf0b6b1.zip
math/saga: Update to 8.0.0
Major update with many new features, enhancements and bugfixes. - Switch from autoconf to cmake - wxWidgets >= v3.1 needed - dev_tools and excercises enabled - Tool numbers instead of library ones Changelog: https://sourceforge.net/p/saga-gis/wiki/Changelog%208.0.0/attachment/changelog_saga_8.0.0.txt Reported by: portscout
Diffstat (limited to 'math')
-rw-r--r--math/saga/Makefile54
-rw-r--r--math/saga/distinfo6
-rw-r--r--math/saga/files/patch-configure19
-rw-r--r--math/saga/files/patch-configure.ac31
-rw-r--r--math/saga/files/patch-src_saga__core_saga__cmd_saga__cmd.cpp6
-rw-r--r--math/saga/files/patch-src_tools_io_io__shapes__las_Makefile.am11
-rw-r--r--math/saga/pkg-plist27
7 files changed, 38 insertions, 116 deletions
diff --git a/math/saga/Makefile b/math/saga/Makefile
index 49777ce408ad..360b0b0248cb 100644
--- a/math/saga/Makefile
+++ b/math/saga/Makefile
@@ -1,7 +1,7 @@
# Created by: Rainer Hurling <rhurlin@gwdg.de>
PORTNAME= saga
-PORTVERSION= 7.9.1
+PORTVERSION= 8.0.0
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]\.[[:digit:]]*$//}/SAGA%20-%20${PORTVERSION}
@@ -16,6 +16,7 @@ BUILD_DEPENDS= clang${LLVM_DEFAULT}:devel/llvm${LLVM_DEFAULT} \
LIB_DEPENDS= libcurl.so:ftp/curl \
libfftw3.so:math/fftw3 \
libgdal.so:graphics/gdal \
+ libhdf5.so:science/hdf5 \
libhpdf.so:print/libharu \
libjasper.so:graphics/jasper \
liblas12.so:devel/liblas12 \
@@ -23,25 +24,28 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libopencv_core.so:graphics/opencv \
libpdal_base.so:math/pdal \
libproj.so:graphics/proj \
+ libqhull_r.so:math/qhull \
libsvm.so:science/libsvm \
- libtbb.so:devel/onetbb \
+ libsz.so:science/szip \
libtiff.so:graphics/tiff
RUN_DEPENDS:= swig:devel/swig
-USES= autoreconf compiler:c++11-lib dos2unix gnome \
+USES= cmake compiler:c++11-lib dos2unix gnome \
iconv:wchar_t libtool localbase pkgconfig python
+DOS2UNIX_GLOB= *.cpp *.h
+INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-USE_WX= 3.0+
+USE_WX= 3.1+
-CONFIGURE_ARGS= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
- --enable-python --with-system-svm
-CONFIGURE_ENV= SWIG="${LOCALBASE}/bin/swig"
-GNU_CONFIGURE= yes
+CMAKE_ARGS+= -DLAS_INCLUDE:PATH=${LOCALBASE}/include/liblas12/capi/liblas.h \
+ -DLAS_LIBRARY:FILEPATH=${LOCALBASE}/lib/liblas12.so \
+ -DSVM_INCLUDE:PATH=${LOCALBASE}/include/svm.h
+CMAKE_ON= WITH_DEV_TOOLS WITH_EXCERCISES WITH_SYSTEM_SVM
+CMAKE_ON+= CMAKE_VERBOSE_MAKEFILE
+CMAKE_OFF+= WITH_TRIANGLE
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/saga-gis
-INSTALLS_ICONS= yes
-DOS2UNIX_GLOB= *.cpp *.h
PLIST_SUB= PORTVERSION=${PORTVERSION}
OPTIONS_DEFINE= PGSQL OPENMP VIGRA
@@ -54,13 +58,11 @@ OPENMP_DESC= Enable Multiprocessing (only amd64 and i386)
VIGRA_DESC= Enable 'Vision with Generic Algorithms' Library
OPENMP_CONFIGURE_ENABLE= openmp
-PGSQL_CONFIGURE_WITH= postgresql
PGSQL_USES= pgsql
+PGSQL_CONFIGURE_WITH= postgresql
VIGRA_BUILD_DEPENDS= ${LOCALBASE}/lib/libvigraimpex.so:graphics/vigra
VIGRA_RUN_DEPENDS= ${LOCALBASE}/lib/libvigraimpex.so:graphics/vigra
-INSTALL_TARGET= install-strip
-
.include <bsd.port.pre.mk>
# make describe needs them here
@@ -70,24 +72,6 @@ CXX= clang++${LLVM_DEFAULT}
SUB_FILES= pkg-message
-post-extract:
- @${REINPLACE_CMD} -e 's|wx-config |${WX_CONFIG} |g' \
- ${WRKSRC}/configure.ac \
- ${WRKSRC}/src/saga_core/saga_api/Makefile.am \
- ${WRKSRC}/src/saga_core/saga_cmd/Makefile.am \
- ${WRKSRC}/src/saga_core/saga_gdi/Makefile.am \
- ${WRKSRC}/src/saga_core/saga_gui/Makefile.am \
- ${WRKSRC}/src/tools/garden/garden_3d_viewer/Makefile.am \
- ${WRKSRC}/src/tools/garden/garden_webservices/Makefile.am \
- ${WRKSRC}/src/tools/io/io_grid_image/Makefile.am \
- ${WRKSRC}/src/tools/io/io_shapes/Makefile.am \
- ${WRKSRC}/src/tools/io/io_virtual/Makefile.am \
- ${WRKSRC}/src/tools/io/io_webservices/Makefile.am \
- ${WRKSRC}/src/tools/pointcloud/pointcloud_tools/Makefile.am \
- ${WRKSRC}/src/tools/pointcloud/pointcloud_viewer/Makefile.am \
- ${WRKSRC}/src/tools/statistics/statistics_kriging/Makefile.am \
- ${WRKSRC}/src/tools/tin/tin_viewer/Makefile.am
-
post-patch:
.if ${ARCH} == "powerpc"
@${REINPLACE_CMD} -e 's|typedef unsigned long DWORD;|typedef unsigned int DWORD;|' \
@@ -97,10 +81,8 @@ post-patch:
${WRKSRC}/src/saga_core/saga_gui/dlg_about.cpp
@${REINPLACE_CMD} -e 's|-lgomp|-lomp|' \
${WRKSRC}/src/accessories/templates/template4saga-tools/my_tool_library/Makefile
-
-post-configure:
- @${REINPLACE_CMD} -e 's|^LDFLAGS = .*|& -lopencv_core|' \
- ${WRKSRC}/src/tools/imagery/imagery_opencv/Makefile
+ @${REINPLACE_CMD} -e 's|COMMAND python -c|COMMAND python${PYTHON_VER} -c|' \
+ ${WRKSRC}/src/saga_core/saga_api/saga_api_python/CMakeLists.txt
post-install:
${MKDIR} ${STAGEDIR}${DATADIR}
diff --git a/math/saga/distinfo b/math/saga/distinfo
index 26366aa83144..9f798d08cdd6 100644
--- a/math/saga/distinfo
+++ b/math/saga/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1628004746
-SHA256 (saga-7.9.1.tar.gz) = 26ad4b84149e26eabd4a5365fe4a3923cfa39e36672cc7c660d3549f3556a3bc
-SIZE (saga-7.9.1.tar.gz) = 5512365
+TIMESTAMP = 1632426943
+SHA256 (saga-8.0.0.tar.gz) = 80d615a3b6ff5f2ba8b3c710dfd3551089c9b87c6e999b8f032dbd0f97707c87
+SIZE (saga-8.0.0.tar.gz) = 8103668
diff --git a/math/saga/files/patch-configure b/math/saga/files/patch-configure
deleted file mode 100644
index 449f2ebf29e9..000000000000
--- a/math/saga/files/patch-configure
+++ /dev/null
@@ -1,19 +0,0 @@
---- configure.orig 2018-10-05 11:27:46 UTC
-+++ configure
-@@ -16241,13 +16241,13 @@ if test "x$ac_cv_lib_fftw3_fftw_execute" = xyes; then
- FFTWFOUND=1
- fi
-
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for LAS_GetVersion in -llas" >&5
--$as_echo_n "checking for LAS_GetVersion in -llas... " >&6; }
-+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for LAS_GetVersion in -llas12" >&5
-+$as_echo_n "checking for LAS_GetVersion in -llas12... " >&6; }
- if ${ac_cv_lib_las_LAS_GetVersion+:} false; then :
- $as_echo_n "(cached) " >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-llas $LIBS"
-+LIBS="-llas12 $LIBS"
- cat confdefs.h - <<_ACEOF >conftest.$ac_ext
- /* end confdefs.h. */
-
diff --git a/math/saga/files/patch-configure.ac b/math/saga/files/patch-configure.ac
deleted file mode 100644
index ad0db9408e5a..000000000000
--- a/math/saga/files/patch-configure.ac
+++ /dev/null
@@ -1,31 +0,0 @@
---- configure.ac.orig 2021-08-03 15:33:59 UTC
-+++ configure.ac
-@@ -20,7 +20,7 @@ AC_PROG_LIBTOOL
- AC_CHECK_LIB([opencv_core], [cvGetRows], CVFOUND=1,,)
- AC_CHECK_LIB([geotrans], [Set_Mercator_Coordinates])
- AC_CHECK_LIB([fftw3],[fftw_execute],FFTWFOUND=1,)
--AC_CHECK_LIB([las], [LAS_GetVersion], LASFOUND=1,,)
-+AC_CHECK_LIB([las12], [LAS_GetVersion], LASFOUND=1,,)
- AC_CHECK_LIB(hpdf, HPDF_Pages_New, HARUFOUND=1,,)
- AC_CHECK_LIB([odbc], [SQLFetch], ODBCFOUND=1,[ODBC \(libodbc\) library not found])
- # PROJ4 has projects.h and old API function:
-@@ -30,8 +30,8 @@ AC_CHECK_HEADER([projects.h],[AC_CHECK_HEADER([proj.h]
- # PROJ6 has dropped projects.h in favour of proj.h and has new API function:
- AC_CHECK_HEADER([proj.h],[AC_CHECK_LIB([proj], [proj_info], PROJ6FOUND=1,,)])
- AC_CHECK_LIB([vigraimpex], [VIGRA_RGBE_ReadPixels_Raw],VIGRAFOUND=1,)
--AC_CHECK_LIB([gomp], [omp_get_num_threads], GOMPFOUND=1,,)
--AC_CHECK_HEADER([libsvm/svm.h],[AC_CHECK_LIB([svm], [svm_get_svm_type], SVMFOUND=1,,)])
-+AC_CHECK_LIB([omp], [omp_get_num_threads], GOMPFOUND=1,,)
-+AC_CHECK_HEADER([svm.h],[AC_CHECK_LIB([svm], [svm_get_svm_type], SVMFOUND=1,,)])
- PKG_CHECK_MODULES([DXFLIB], [dxflib], [LIBDXFFOUND=1],[LIBDXFFOUND=0])
- PKG_CHECK_MODULES([HDF5],[hdf5],LIBHDF5FOUND=1,LIBHDF5FOUND=0)
- LIBCURL_CHECK_CONFIG([yes], [7.7.2],,)
-@@ -163,7 +163,7 @@ AC_ARG_ENABLE(openmp,
- else
- if test -n "$GOMPFOUND" ; then
- AC_MSG_RESULT([ Building with OpenMP support using libgomp])
-- GOMPFLAGS="-fopenmp -lgomp"
-+ GOMPFLAGS="-fopenmp -lomp"
- else
- AC_MSG_RESULT([ libgomp not found, OpenMP support disabled])
- GOMPFLAGS=""
diff --git a/math/saga/files/patch-src_saga__core_saga__cmd_saga__cmd.cpp b/math/saga/files/patch-src_saga__core_saga__cmd_saga__cmd.cpp
index 003a5e0036df..c1c029cae9ea 100644
--- a/math/saga/files/patch-src_saga__core_saga__cmd_saga__cmd.cpp
+++ b/math/saga/files/patch-src_saga__core_saga__cmd_saga__cmd.cpp
@@ -1,6 +1,6 @@
---- src/saga_core/saga_cmd/saga_cmd.cpp.orig 2018-11-22 07:53:06 UTC
+--- src/saga_core/saga_cmd/saga_cmd.cpp.orig 2020-02-07 16:57:34 UTC
+++ src/saga_core/saga_cmd/saga_cmd.cpp
-@@ -64,6 +64,7 @@
+@@ -52,6 +52,7 @@
#include <wx/app.h>
#include <wx/utils.h>
@@ -8,7 +8,7 @@
#include "config.h"
#include "callback.h"
-@@ -168,7 +169,7 @@ _except(1)
+@@ -165,7 +166,7 @@ _except(1)
//---------------------------------------------------------
bool Run(int argc, char *argv[])
{
diff --git a/math/saga/files/patch-src_tools_io_io__shapes__las_Makefile.am b/math/saga/files/patch-src_tools_io_io__shapes__las_Makefile.am
deleted file mode 100644
index 1ae2d2bbadf4..000000000000
--- a/math/saga/files/patch-src_tools_io_io__shapes__las_Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tools/io/io_shapes_las/Makefile.am.orig 2018-10-24 14:16:06 UTC
-+++ src/tools/io/io_shapes_las/Makefile.am
-@@ -6,7 +6,7 @@ DBGFLAGS = -g -DDEBUG
- endif
-
- if HAVE_LLAS
--DEP_LIBS = -llas
-+DEP_LIBS = -llas12
- DEF_SAGA = -D_SAGA_LINUX -D_TYPEDEF_BYTE -D_TYPEDEF_WORD
- CXX_INCS = -I$(top_srcdir)/src/saga_core
- AM_CXXFLAGS = -fPIC $(CXX_INCS) $(DEF_SAGA) $(DBGFLAGS) $(GOMPFLAGS)
diff --git a/math/saga/pkg-plist b/math/saga/pkg-plist
index b20593a5dc59..37ccb99c675a 100644
--- a/math/saga/pkg-plist
+++ b/math/saga/pkg-plist
@@ -29,26 +29,26 @@ include/saga/saga_core/saga_gdi/sgdi_diagram.h
include/saga/saga_core/saga_gdi/sgdi_dialog.h
include/saga/saga_core/saga_gdi/sgdi_helper.h
include/saga/saga_core/saga_gdi/sgdi_layout_items.h
-lib/libsaga_api-%%PORTVERSION%%.so
lib/libsaga_api.so
-lib/libsaga_gdi-%%PORTVERSION%%.so
+lib/libsaga_api.so.8
+lib/libsaga_api.so.%%PORTVERSION%%
lib/libsaga_gdi.so
-%%PYTHON_SITELIBDIR%%/__pycache__/saga_api%%PYTHON_EXT_SUFFIX%%.opt-1.pyc
-%%PYTHON_SITELIBDIR%%/__pycache__/saga_api%%PYTHON_EXT_SUFFIX%%.pyc
-%%PYTHON_SITELIBDIR%%/_saga_api-%%PORTVERSION%%.so
-%%PYTHON_SITELIBDIR%%/_saga_api.a
+lib/libsaga_gdi.so.8
+lib/libsaga_gdi.so.%%PORTVERSION%%
%%PYTHON_SITELIBDIR%%/_saga_api.so
%%PYTHON_SITELIBDIR%%/saga_api.py
+%%PYTHON_SITELIBDIR%%/saga_helper.py
lib/saga/libclimate_tools.so
lib/saga/libcontrib_perego.so
lib/saga/libdb_odbc.so
%%PGSQL%%lib/saga/libdb_pgsql.so
+lib/saga/libdev_exercises.so
+lib/saga/libdev_tools.so
lib/saga/libdocs_html.so
lib/saga/libdocs_pdf.so
lib/saga/libgarden_3d_viewer.so
lib/saga/libgarden_fractals.so
lib/saga/libgarden_games.so
-lib/saga/libgarden_learn_to_program.so
lib/saga/libgarden_webservices.so
lib/saga/libgrid_analysis.so
lib/saga/libgrid_calculus.so
@@ -73,6 +73,7 @@ lib/saga/libio_gdal.so
lib/saga/libio_gps.so
lib/saga/libio_grid.so
lib/saga/libio_grid_image.so
+lib/saga/libio_pdal.so
lib/saga/libio_shapes.so
lib/saga/libio_shapes_dxf.so
lib/saga/libio_shapes_las.so
@@ -80,6 +81,7 @@ lib/saga/libio_table.so
lib/saga/libio_virtual.so
lib/saga/libio_webservices.so
lib/saga/libpj_georeference.so
+lib/saga/libpj_geotrans.so
lib/saga/libpj_proj4.so
lib/saga/libpointcloud_tools.so
lib/saga/libpointcloud_viewer.so
@@ -117,8 +119,6 @@ lib/saga/libtable_calculus.so
lib/saga/libtable_tools.so
lib/saga/libtin_tools.so
lib/saga/libtin_viewer.so
-man/man1/saga_cmd.1.gz
-man/man1/saga_gui.1.gz
share/applications/saga.desktop
share/icons/hicolor/128x128/apps/saga.png
share/icons/hicolor/16x16/apps/saga.png
@@ -133,14 +133,16 @@ share/icons/hicolor/72x72/apps/saga.png
share/icons/hicolor/80x80/apps/saga.png
share/icons/hicolor/8x8/apps/saga.png
share/icons/hicolor/96x96/apps/saga.png
+share/man/man1/saga_cmd.1.gz
+share/man/man1/saga_gui.1.gz
share/metainfo/org.saga-gis.saga-gui.appdata.xml
share/pixmaps/saga.png
-@mode 0777
-@dir %%DATADIR%%
-@mode 0666
%%DATADIR%%/docs/saga_on_mac.odt
%%DATADIR%%/docs/saga_toolchains_cheat_sheet.xml
%%DATADIR%%/docs/saga_toolchains_manual.odt
+@mode 0777
+@dir %%DATADIR%%
+@mode 0666
%%DATADIR%%/helper/doxygen_saga_api_chm
%%DATADIR%%/helper/doxygen_saga_api_html
%%DATADIR%%/helper/make_arcsaga_toolboxes.bat
@@ -226,7 +228,6 @@ share/pixmaps/saga.png
%%DATADIR%%/toolchains/ta_flow_accumulation.xml
%%DATADIR%%/toolchains/ta_ls_factor.xml
%%DATADIR%%/toolchains/ta_summits.xml
-%%DATADIR%%/toolchains/temperature_downscaling.xml
%%DATADIR%%/toolchains/temperature_downscaling_bulk.xml
%%DATADIR%%/toolchains/terrain_analysis.xml
%%DATADIR%%/toolchains/terrain_segmentation.xml