aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-08-06 08:50:49 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-08-06 08:50:49 +0000
commit2c25cf429d2666ce14bd7dc8623ba038953a470e (patch)
tree5aa3cd74114ed035ad4ba813977c32381a693ed0 /math
parent9bb16a96a346d4c10541421482ceac831cf26d46 (diff)
downloadports-2c25cf429d2666ce14bd7dc8623ba038953a470e.tar.gz
ports-2c25cf429d2666ce14bd7dc8623ba038953a470e.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/p5-GIS-Distance-Lite/Makefile3
-rw-r--r--math/p5-Math-Random-ISAAC-XS/Makefile3
-rw-r--r--math/p5-Math-Random-ISAAC/Makefile9
-rw-r--r--math/p5-Statistics-Benford/Makefile9
4 files changed, 10 insertions, 14 deletions
diff --git a/math/p5-GIS-Distance-Lite/Makefile b/math/p5-GIS-Distance-Lite/Makefile
index 5e5ee3df7529..3a615e248a84 100644
--- a/math/p5-GIS-Distance-Lite/Makefile
+++ b/math/p5-GIS-Distance-Lite/Makefile
@@ -14,7 +14,8 @@ COMMENT= Calculate geographic distances in geodetic WGS84 format
RUN_DEPENDS= p5-Math-Complex>1.0.3:${PORTSDIR}/math/p5-Math-Complex
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= GIS::Distance::Lite.3 \
diff --git a/math/p5-Math-Random-ISAAC-XS/Makefile b/math/p5-Math-Random-ISAAC-XS/Makefile
index c251e09fae6f..391d2b2d09e4 100644
--- a/math/p5-Math-Random-ISAAC-XS/Makefile
+++ b/math/p5-Math-Random-ISAAC-XS/Makefile
@@ -14,7 +14,8 @@ COMMENT= C implementation of the ISAAC PRNG Algorithm
BUILD_DEPENDS= p5-Test-NoWarnings>0:${PORTSDIR}/devel/p5-Test-NoWarnings
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Math::Random::ISAAC::XS.3
diff --git a/math/p5-Math-Random-ISAAC/Makefile b/math/p5-Math-Random-ISAAC/Makefile
index 51d962a1725a..c58a6f8c2e35 100644
--- a/math/p5-Math-Random-ISAAC/Makefile
+++ b/math/p5-Math-Random-ISAAC/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Math::Random::ISAAC
-# Date created: 07 Dec, 2009
-# Whom: Wen Heping <wen@FreeBSD.org>
-#
+# Created by: Wen Heping <wen@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Math-Random-ISAAC
PORTVERSION= 1.004
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Test-NoWarnings>0:${PORTSDIR}/devel/p5-Test-NoWarnings
RUN_DEPENDS:= ${BUILD_DEPENDS} \
p5-Math-Random-ISAAC-XS>0:${PORTSDIR}/math/p5-Math-Random-ISAAC-XS
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Math::Random::ISAAC::PP.3 \
Math::Random::ISAAC.3
diff --git a/math/p5-Statistics-Benford/Makefile b/math/p5-Statistics-Benford/Makefile
index e1fff6b20428..c2a7414467db 100644
--- a/math/p5-Statistics-Benford/Makefile
+++ b/math/p5-Statistics-Benford/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Statistics-Benford
-# Date created: 03 May, 2009
-# Whom: Wen Heping <wenheping@gmail.com>
-#
+# Created by: Wen Heping <wenheping@gmail.com>
# $FreeBSD$
-#
PORTNAME= Statistics-Benford
PORTVERSION= 0.08
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= wen@FreeBSD.org
COMMENT= Calculate the deviation from Benford's Law
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Statistics::Benford.3