aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-06 17:32:42 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-07 06:14:38 +0000
commit49b120d5b0e55031d89b1564a12eee65064e5eaf (patch)
treee94c088f5c9b0864372be5f211148cfbd847433e /math
parentf92407c62025d8facd2b8093fdaf7257ce86eb95 (diff)
downloadports-49b120d5b0e55031d89b1564a12eee65064e5eaf.tar.gz
ports-49b120d5b0e55031d89b1564a12eee65064e5eaf.zip
Diffstat (limited to 'math')
-rw-r--r--math/dune-common/Makefile10
-rw-r--r--math/dune-common/distinfo6
-rw-r--r--math/dune-common/files/patch-CMakeLists.txt18
-rw-r--r--math/dune-common/pkg-plist23
4 files changed, 31 insertions, 26 deletions
diff --git a/math/dune-common/Makefile b/math/dune-common/Makefile
index 68694c42208f..dfe6dadc09b1 100644
--- a/math/dune-common/Makefile
+++ b/math/dune-common/Makefile
@@ -1,7 +1,6 @@
PORTNAME= dune-common
DISTVERSIONPREFIX= v
-DISTVERSION= 2.7.1
-PORTREVISION= 3
+DISTVERSION= 2.8.0
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -16,13 +15,13 @@ LIB_DEPENDS= libopenblas.so:math/openblas \
libtbb.so:devel/onetbb
USES= cmake compiler:c++17-lang fortran pkgconfig python shebangfix
-SHEBANG_FILES= bin/dune-ctest cmake/scripts/extract_cmake_data.py
+SHEBANG_FILES= bin/dune-ctest bin/setup-dunepy.py bin/dunepackaging.py bin/rmgenerated.py cmake/scripts/extract_cmake_data.py
USE_GITLAB= yes
USE_LDCONFIG= yes
GL_SITE= https://gitlab.dune-project.org
GL_ACCOUNT= core
-GL_COMMIT= aa689abba532f40db8f5663fa379ea77211c1953
+GL_COMMIT= df65b1282ea89ad40d2cb6565983f7e633ccce31
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_ARGS= -DTBB_INCLUDE_DIR=${LOCALBASE}/include -DTBB_LIBRARIES=${LOCALBASE}/lib/libtbb.so
@@ -42,7 +41,4 @@ PORTDOCS= *
post-install:
@${RM} ${STAGEDIR}${PREFIX}/share/dune/cmake/scripts/run-in-dune-env.sh.in # https://gitlab.dune-project.org/core/dune-common/-/issues/229
-post-stage-DOCS-on: # https://gitlab.dune-project.org/core/dune-common/issues/191
- @${RMDIR} ${STAGEDIR}${DOCSDIR}/comm
-
.include <bsd.port.mk>
diff --git a/math/dune-common/distinfo b/math/dune-common/distinfo
index 0193b9754a8a..9b9f89c4ffab 100644
--- a/math/dune-common/distinfo
+++ b/math/dune-common/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1617891536
-SHA256 (core-dune-common-aa689abba532f40db8f5663fa379ea77211c1953_GL0.tar.gz) = 6c28fde93647281a4765fd6a1abbb111a7dc26f45eae8b09a20847d30a0aae8a
-SIZE (core-dune-common-aa689abba532f40db8f5663fa379ea77211c1953_GL0.tar.gz) = 574602
+TIMESTAMP = 1630946353
+SHA256 (core-dune-common-df65b1282ea89ad40d2cb6565983f7e633ccce31_GL0.tar.gz) = e518620820edd77258266c1856eb46435e884bc7770ae00c7c181c222b98be48
+SIZE (core-dune-common-df65b1282ea89ad40d2cb6565983f7e633ccce31_GL0.tar.gz) = 772263
diff --git a/math/dune-common/files/patch-CMakeLists.txt b/math/dune-common/files/patch-CMakeLists.txt
index 29b64ae6dd74..d1dcdae2a5b0 100644
--- a/math/dune-common/files/patch-CMakeLists.txt
+++ b/math/dune-common/files/patch-CMakeLists.txt
@@ -1,12 +1,12 @@
---- CMakeLists.txt.orig 2020-03-14 17:13:03 UTC
+--- CMakeLists.txt.orig 2021-08-31 14:25:00 UTC
+++ CMakeLists.txt
-@@ -21,7 +21,9 @@ add_subdirectory("lib")
- add_subdirectory("share")
- add_subdirectory("dune")
- add_subdirectory("bin")
+@@ -16,7 +16,9 @@ dune_project()
+ # add subdirectories to execute CMakeLists.txt there
+ add_subdirectory(bin)
+ add_subdirectory(cmake)
+if (FREEBSD_INSTALL_DOCS)
- add_subdirectory("doc")
+ add_subdirectory(doc)
+endif()
- add_subdirectory("cmake/modules")
- add_subdirectory("cmake/scripts")
-
+ add_subdirectory(dune)
+ add_subdirectory(lib)
+ add_subdirectory(share)
diff --git a/math/dune-common/pkg-plist b/math/dune-common/pkg-plist
index cbbe200ba42d..57b50447ee0f 100644
--- a/math/dune-common/pkg-plist
+++ b/math/dune-common/pkg-plist
@@ -1,7 +1,10 @@
bin/dune-ctest
bin/dune-git-whitespace-hook
bin/dunecontrol
+bin/dunepackaging.py
bin/duneproject
+bin/rmgenerated.py
+bin/setup-dunepy.py
include/dune/common/alignedallocator.hh
include/dune/common/arraylist.hh
include/dune/common/assertandreturn.hh
@@ -102,8 +105,8 @@ include/dune/common/simd/vc.hh
include/dune/common/singleton.hh
include/dune/common/sllist.hh
include/dune/common/std/apply.hh
+include/dune/common/std/functional.hh
include/dune/common/std/make_array.hh
-include/dune/common/std/memory.hh
include/dune/common/std/optional.hh
include/dune/common/std/type_traits.hh
include/dune/common/std/utility.hh
@@ -119,6 +122,7 @@ include/dune/common/test/iteratortest.hh
include/dune/common/test/testsuite.hh
include/dune/common/timer.hh
include/dune/common/to_unique_ptr.hh
+include/dune/common/transpose.hh
include/dune/common/tupleutility.hh
include/dune/common/tuplevector.hh
include/dune/common/typelist.hh
@@ -141,16 +145,20 @@ share/bash-completion/completions/dunecontrol
%%DATADIR%%/config.h.cmake
%%DOCS%%%%DATADIR%%/doc/doxygen/Doxystyle
%%DOCS%%%%DATADIR%%/doc/doxygen/doxygen-macros
+share/dune/cmake/modules/AddBLASLapackFlags.cmake
share/dune/cmake/modules/AddGMPFlags.cmake
share/dune/cmake/modules/AddMETISFlags.cmake
+share/dune/cmake/modules/AddMPIFlags.cmake
share/dune/cmake/modules/AddPTScotchFlags.cmake
share/dune/cmake/modules/AddParMETISFlags.cmake
share/dune/cmake/modules/AddQuadMathFlags.cmake
share/dune/cmake/modules/AddSuiteSparseFlags.cmake
-share/dune/cmake/modules/AddUMFPackFlags.cmake
+share/dune/cmake/modules/AddTBBFlags.cmake
+share/dune/cmake/modules/AddThreadsFlags.cmake
share/dune/cmake/modules/AddVcFlags.cmake
share/dune/cmake/modules/CMakeBuiltinFunctionsDocumentation.cmake
share/dune/cmake/modules/CheckCXXFeatures.cmake
+share/dune/cmake/modules/DuneAddPybind11Module.cmake
share/dune/cmake/modules/DuneCMakeCompat.cmake
share/dune/cmake/modules/DuneCommonMacros.cmake
share/dune/cmake/modules/DuneCxaDemangle.cmake
@@ -166,10 +174,11 @@ share/dune/cmake/modules/DunePkgConfig.cmake
share/dune/cmake/modules/DunePythonCommonMacros.cmake
share/dune/cmake/modules/DunePythonFindPackage.cmake
share/dune/cmake/modules/DunePythonInstallPackage.cmake
-share/dune/cmake/modules/DunePythonRequireVersion.cmake
+share/dune/cmake/modules/DunePythonMacros.cmake
share/dune/cmake/modules/DunePythonTestCommand.cmake
share/dune/cmake/modules/DunePythonVirtualenv.cmake
share/dune/cmake/modules/DuneSphinxCMakeDoc.cmake
+share/dune/cmake/modules/DuneSphinxDoc.cmake
share/dune/cmake/modules/DuneStreams.cmake
share/dune/cmake/modules/DuneSymlinkOrCopy.cmake
share/dune/cmake/modules/DuneTestMacros.cmake
@@ -177,18 +186,18 @@ share/dune/cmake/modules/FindGMP.cmake
share/dune/cmake/modules/FindInkscape.cmake
share/dune/cmake/modules/FindLatexMk.cmake
share/dune/cmake/modules/FindMETIS.cmake
-share/dune/cmake/modules/FindMProtect.cmake
share/dune/cmake/modules/FindPTScotch.cmake
share/dune/cmake/modules/FindParMETIS.cmake
+share/dune/cmake/modules/FindPkgConfig/FindPkgConfig.cmake
+share/dune/cmake/modules/FindPython3/FindPython3.cmake
+share/dune/cmake/modules/FindPython3/Support.cmake
+share/dune/cmake/modules/FindQuadMath.cmake
share/dune/cmake/modules/FindSphinx.cmake
share/dune/cmake/modules/FindSuiteSparse.cmake
share/dune/cmake/modules/FindTBB.cmake
-share/dune/cmake/modules/FindUMFPack.cmake
share/dune/cmake/modules/Headercheck.cmake
-share/dune/cmake/modules/LanguageSupport.cmake
share/dune/cmake/modules/OverloadCompilerFlags.cmake
share/dune/cmake/modules/UseInkscape.cmake
-share/dune/cmake/modules/UseLATEX.cmake
share/dune/cmake/modules/UseLatexMk.cmake
share/dune/cmake/modules/latexmkrc.cmake
share/dune/cmake/scripts/CreateDoxyFile.cmake