aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-08-29 16:19:38 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-08-29 16:19:38 +0000
commit4a1f19112d13e0740f461f51d40d06948dce2da9 (patch)
tree2b45461306e9341418c8c754aacee7f82ce34204 /math
parent56ab16b366c8404ce11dec582d48adda198e0871 (diff)
downloadports-4a1f19112d13e0740f461f51d40d06948dce2da9.tar.gz
ports-4a1f19112d13e0740f461f51d40d06948dce2da9.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/PDL/Makefile104
1 files changed, 36 insertions, 68 deletions
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index 0432762b2acc..8863a3c324b1 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -5,11 +5,10 @@ PORTNAME= PDL
PORTVERSION= 2.4.11
PORTREVISION= 4
CATEGORIES= math perl5
-MASTER_SITES= CPAN/${PORTNAME}:cpan \
- SF/pdl/PDL/${PORTVERSION}:sf
-DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:cpan,sf
+MASTER_SITES= CPAN/${PORTNAME} SF/pdl/PDL/${PORTVERSION}
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Perl Data Language
BUILD_DEPENDS= p5-Astro-FITS-Header>=0:${PORTSDIR}/astro/p5-Astro-FITS-Header \
@@ -28,7 +27,12 @@ PLIST_FILES= bin/pdl bin/pdldoc bin/perldl bin/pptemplate \
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= PGPLOT PLPLOT OPENGL GD FFTW GSL HDF PROJ F77 READLINE SINK
-OPTIONS_DEFAULT= PGPLOT OPENGL FFTW F77
+OPTIONS_DEFAULT= PGPLOT FFTW F77
+
+# graphics/p5-OpenGL require manual building
+.if empty(PACKAGE_BUILDING)
+OPTIONS_DEFAULT+= OPENGL
+.endif
PGPLOT_DESC= Enable PDL::Graphics::PGPLOT
PLPLOT_DESC= Enable PDL::Graphics::PLplot
@@ -42,58 +46,22 @@ F77_DESC= Enable PDL::Minuit and PDL::Slatec
READLINE_DESC= Use GNU readline
SINK_DESC= Include PDL kitchen sink
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPGPLOT}
-BUILD_DEPENDS+= p5-PGPLOT>=0:${PORTSDIR}/graphics/p5-PGPLOT
-.endif
-
-.if ${PORT_OPTIONS:MPLPLOT}
-LIB_DEPENDS+= libplplotd.so:${PORTSDIR}/math/plplot
-.endif
-
-.if ${PORT_OPTIONS:MOPENGL}
-BUILD_DEPENDS+= p5-OpenGL>=0.65:${PORTSDIR}/graphics/p5-OpenGL
-RUN_DEPENDS+= p5-OpenGL>=0.65:${PORTSDIR}/graphics/p5-OpenGL
-USE_GL= yes
-.endif
-
-.if ${PORT_OPTIONS:MGD}
-LIB_DEPENDS+= libgd.so:${PORTSDIR}/graphics/gd
-.endif
-
-.if ${PORT_OPTIONS:MF77}
-BUILD_DEPENDS+= p5-ExtUtils-F77>=0:${PORTSDIR}/lang/p5-ExtUtils-F77
-.endif
-
-.if ${PORT_OPTIONS:MFFTW}
-LIB_DEPENDS+= libfftw.so:${PORTSDIR}/math/fftw
-.endif
-
-.if ${PORT_OPTIONS:MGSL}
-LIB_DEPENDS+= libgsl.so:${PORTSDIR}/math/gsl
-.endif
-
-.if ${PORT_OPTIONS:MHDF}
-LIB_DEPENDS+= libdf.so:${PORTSDIR}/science/hdf
-.endif
-
-.if ${PORT_OPTIONS:MPROJ}
-LIB_DEPENDS+= libproj.so:${PORTSDIR}/graphics/proj
-.endif
-
-.if ${PORT_OPTIONS:MREADLINE}
-RUN_DEPENDS+= p5-ReadLine-Gnu>=0:${PORTSDIR}/devel/p5-ReadLine-Gnu
-.else
-RUN_DEPENDS+= p5-ReadLine-Perl>=0:${PORTSDIR}/devel/p5-ReadLine-Perl
-.endif
-
-.if ${PORT_OPTIONS:MSINK}
-RUN_DEPENDS+= ppmtogif:${PORTSDIR}/graphics/netpbm \
- mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
- saoimage:${PORTSDIR}/astro/saoimage
-.endif
+PGPLOT_BUILD_DEPENDS= p5-PGPLOT>=0:${PORTSDIR}/graphics/p5-PGPLOT
+PLPLOT_LIB_DEPENDS= libplplotd.so:${PORTSDIR}/math/plplot
+OPENGL_BUILD_DEPENDS= p5-OpenGL>=0.65:${PORTSDIR}/graphics/p5-OpenGL
+OPENGL_RUN_DEPENDS:= ${OPENGL_BUILD_DEPENDS}
+OPENGL_USE= gl=yes
+GD_LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
+F77_BUILD_DEPENDS= p5-ExtUtils-F77>=0:${PORTSDIR}/lang/p5-ExtUtils-F77
+FFTW_LIB_DEPENDS= libfftw.so:${PORTSDIR}/math/fftw
+GSL_LIB_DEPENDS= libgsl.so:${PORTSDIR}/math/gsl
+HDF_LIB_DEPENDS= libdf.so:${PORTSDIR}/science/hdf
+PROJ_LIB_DEPENDS= libproj.so:${PORTSDIR}/graphics/proj
+READLINE_RUN_DEPENDS= p5-ReadLine-Gnu>=0:${PORTSDIR}/devel/p5-ReadLine-Gnu
+READLINE_RUN_DEPENDS_OFF= p5-ReadLine-Perl>=0:${PORTSDIR}/devel/p5-ReadLine-Perl
+SINK_RUN_DEPENDS= ppmtogif:${PORTSDIR}/graphics/netpbm \
+ mpeg_encode:${PORTSDIR}/multimedia/mpeg_encode \
+ saoimage:${PORTSDIR}/astro/saoimage
post-patch:
@${GREP} -lR '#!/usr/local/bin/perl' ${WRKSRC}/ | ${XARGS} ${SED} -e 's|#!/usr/local/bin/perl|#!${PERL}|' -i ''
@@ -109,19 +77,19 @@ test: build
# autogen plist
post-install:
- @(cd ${WRKSRC}; ${PERL} Doc/scantree.pl)
+ @(cd ${WRKSRC}; ${PERL} -Iblib/lib -Iblib/arch Doc/scantree.pl)
@(cd ${WRKSRC}/blib/man3 ; \
- ${FIND} *.3 | ${SED} "s,^,${MAN3PREFIX:S,^${PREFIX}/,,}/man/man3/," \
+ ${FIND} *.3 | ${SED} "s,^,${MAN3PREFIX:S,^${PREFIX}/,,}/man/man3/,;s/3$$/3.gz/" \
>> ${TMPPLIST} ; \
cd ${WRKSRC}/blib/man1 ; \
- ${FIND} *.1 | ${SED} "s,^,man/man1/," >> ${TMPPLIST})
- @(${FIND} ${SITE_PERL}/${PERL_ARCH}/PDL* -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST} ; \
- ${FIND} ${SITE_PERL}/${PERL_ARCH}/PDL* -type d | ${SORT} -r | \
- ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST} ; \
- ${FIND} ${SITE_PERL}/${PERL_ARCH}/auto/PDL -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST} ; \
- ${FIND} ${SITE_PERL}/${PERL_ARCH}/auto/PDL -type d | ${SORT} -r | \
- ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST})
+ ${FIND} *.1 | ${SED} "s,^,man/man1/,;s/1$$/1.gz/" >> ${TMPPLIST})
+ @(${FIND} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/PDL* -type f | \
+ ${SED} "s,^${STAGEDIR}${PREFIX}/,," >> ${TMPPLIST} ; \
+ ${FIND} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/PDL -type f ! -name '*.bs' | \
+ ${SED} "s,^${STAGEDIR}${PREFIX}/,," >> ${TMPPLIST} ; \
+ ${FIND} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/PDL* -type d | ${SORT} -r | \
+ ${SED} "s,^${STAGEDIR}${PREFIX}/,@dirrm ," >> ${TMPPLIST} ; \
+ ${FIND} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/PDL -type d | ${SORT} -r | \
+ ${SED} "s,^${STAGEDIR}${PREFIX}/,@dirrm ," >> ${TMPPLIST})
.include <bsd.port.mk>