aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-09-07 06:24:40 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-09-07 06:24:40 +0000
commit81272ea0d3fc3fce53f664d2347a3056171c1781 (patch)
tree1a2a145811a457d40c42f647057b06ec0ed17b96 /math
parent8fbf9c67fa798aa5da4106cbfd548246a5bbd1ad (diff)
downloadports-81272ea0d3fc3fce53f664d2347a3056171c1781.tar.gz
ports-81272ea0d3fc3fce53f664d2347a3056171c1781.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/elemental/Makefile20
-rw-r--r--math/elemental/distinfo6
-rw-r--r--math/elemental/files/patch-CMakeLists.txt21
-rw-r--r--math/elemental/files/patch-cmake_modules_ElCheckFunctionExists.cmake10
-rw-r--r--math/elemental/pkg-descr2
-rw-r--r--math/elemental/pkg-plist256
6 files changed, 135 insertions, 180 deletions
diff --git a/math/elemental/Makefile b/math/elemental/Makefile
index 5a0e77f781b3..91a5a113ca8e 100644
--- a/math/elemental/Makefile
+++ b/math/elemental/Makefile
@@ -2,8 +2,7 @@
PORTNAME= elemental
DISTVERSIONPREFIX= v
-DISTVERSION= 0.87.7
-PORTREVISION= 1
+DISTVERSION= 1.4.0
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -21,13 +20,16 @@ LIB_DEPENDS= libgmp.so:math/gmp \
libmpi_cxx.so:net/openmpi \
libopenblas.so:math/openblas \
libqd.so:math/qd
+TEST_DEPENDS= catch>0:devel/catch
-USES= cmake compiler:c++11-lang fortran
+USES= cmake compiler:c++14-lang fortran
USE_GITHUB= yes
+GH_ACCOUNT= LLNL
GH_PROJECT= Elemental
USE_LDCONFIG= yes
-CMAKE_ON= EL_DISABLE_PARMETIS
+CMAKE_ON= BUILD_SHARED_LIBS EL_DISABLE_PARMETIS
+CMAKE_OFF= Hydrogen_ENABLE_TESTING
CMAKE_ARGS= -DGFORTRAN_LIB:STRING=${LOCALBASE}/lib/gcc${GCC_DEFAULT}/libgfortran.so \
-DFREEBSD_GCC_LIB:STRING=${LOCALBASE}/lib/gcc${GCC_DEFAULT}/libgcc_s.so
@@ -37,10 +39,10 @@ OPTIONS_DEFINE= DOCS
PORTDOCS= *
-post-install:
- @cd ${STAGEDIR}${PREFIX} && \
- ${MV} CMake lib/cmake && \
- ${RM} -r ${STAGEDIR}${PREFIX}/python && \
- ${RM} -r ${STAGEDIR}${PREFIX}/conf
+do-test:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DHydrogen_ENABLE_TESTING:BOOL=ON -DHydrogen_ENABLE_UNIT_TESTS:BOOL=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
.include <bsd.port.mk>
diff --git a/math/elemental/distinfo b/math/elemental/distinfo
index ff1326460314..6d1ef93bcaa5 100644
--- a/math/elemental/distinfo
+++ b/math/elemental/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1534478643
-SHA256 (elemental-Elemental-v0.87.7_GH0.tar.gz) = 7becfdbc223e9c72e65ae876d842c48d2037d13f83e9f41cea285e21b840d7d9
-SIZE (elemental-Elemental-v0.87.7_GH0.tar.gz) = 3011641
+TIMESTAMP = 1599457255
+SHA256 (LLNL-Elemental-v1.4.0_GH0.tar.gz) = c13374ff4a6c4d1076e47ba8c8d91a7082588b9958d1ed89cffb12f1d2e1452e
+SIZE (LLNL-Elemental-v1.4.0_GH0.tar.gz) = 2714341
diff --git a/math/elemental/files/patch-CMakeLists.txt b/math/elemental/files/patch-CMakeLists.txt
index 728b31cd83ff..dfb587bc0540 100644
--- a/math/elemental/files/patch-CMakeLists.txt
+++ b/math/elemental/files/patch-CMakeLists.txt
@@ -1,20 +1,11 @@
---- CMakeLists.txt.orig 2017-02-07 01:23:30 UTC
+--- CMakeLists.txt.orig 2020-06-05 22:37:07 UTC
+++ CMakeLists.txt
-@@ -25,6 +25,8 @@ project(Elemental C CXX)
- set(EL_VERSION_MAJOR 0)
- set(EL_VERSION_MINOR 87)
+@@ -65,6 +65,8 @@ set(EL_VERSION_MAJOR ${HYDROGEN_VERSION_MAJOR})
+ set(EL_VERSION_MINOR ${HYDROGEN_VERSION_MINOR})
+ set(EL_VERSION_PATCH ${HYDROGEN_VERSION_PATCH})
+set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+
- list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
- list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules")
+ string(TOUPPER "${PROJECT_NAME}" UPPER_PROJECT_NAME)
-@@ -100,7 +102,7 @@ option(EL_HYBRID "Make use of OpenMP within MPI packin
-
- option(EL_C_INTERFACE "Build C interface" ON)
-
--if(BUILD_SHARED_LIBS AND EL_C_INTERFACE)
-+if(FALSE AND BUILD_SHARED_LIBS AND EL_C_INTERFACE) # disable Python
- # Define PYTHON_SITE_PACKAGES if you want to install the python package
- # somewhere other than the default system-wide location (e.g., within your
- # home directory). Alternatively, if you do NOT define PYTHON_SITE_PACKAGES
+ if (NOT CMAKE_BUILD_TYPE MATCHES "Debug")
diff --git a/math/elemental/files/patch-cmake_modules_ElCheckFunctionExists.cmake b/math/elemental/files/patch-cmake_modules_ElCheckFunctionExists.cmake
deleted file mode 100644
index ccdae44c3ee2..000000000000
--- a/math/elemental/files/patch-cmake_modules_ElCheckFunctionExists.cmake
+++ /dev/null
@@ -1,10 +0,0 @@
---- cmake/modules/ElCheckFunctionExists.cmake.orig 2018-08-17 05:32:25 UTC
-+++ cmake/modules/ElCheckFunctionExists.cmake
-@@ -93,6 +93,7 @@ macro(EL_CHECK_FUNCTION_EXISTS FUNCTION
- ${CHECK_FUNCTION_EXISTS_ADD_LIBRARIES}
- CMAKE_FLAGS -DCOMPILE_DEFINITIONS:STRING=${MACRO_CHECK_FUNCTION_DEFINITIONS} ${CHECK_FUNCTION_EXISTS_ADD_LINKER_FLAGS}
- "${CHECK_FUNCTION_EXISTS_ADD_INCLUDES}"
-+ LINK_LIBRARIES ${FREEBSD_GCC_LIB}
- OUTPUT_VARIABLE OUTPUT)
- if(${VARIABLE})
- set(${VARIABLE} 1 CACHE INTERNAL "Have function ${FUNCTION}")
diff --git a/math/elemental/pkg-descr b/math/elemental/pkg-descr
index 3e5bdb56df40..e12cf9e1db1b 100644
--- a/math/elemental/pkg-descr
+++ b/math/elemental/pkg-descr
@@ -1,4 +1,4 @@
Distributed-memory, arbitrary-precision, dense and sparse-direct linear algebra,
conic optimization, and lattice reduction.
-WWW: https://github.com/elemental/Elemental
+WWW: https://github.com/LLNL/Elemental
diff --git a/math/elemental/pkg-plist b/math/elemental/pkg-plist
index d6d3eb8b1c1c..f6eda8f8de35 100644
--- a/math/elemental/pkg-plist
+++ b/math/elemental/pkg-plist
@@ -1,11 +1,6 @@
-include/El-lite.h
include/El-lite.hpp
-include/El.h
include/El.hpp
-include/El/FCMangle.h
-include/El/blas_like.h
include/El/blas_like.hpp
-include/El/blas_like/level1.h
include/El/blas_like/level1.hpp
include/El/blas_like/level1/AllReduce.hpp
include/El/blas_like/level1/Axpy.hpp
@@ -43,6 +38,11 @@ include/El/blas_like/level1/Copy/TransposeDist.hpp
include/El/blas_like/level1/Copy/internal_decl.hpp
include/El/blas_like/level1/Copy/internal_impl.hpp
include/El/blas_like/level1/Copy/util.hpp
+include/El/blas_like/level1/CopyAsyncDistMatrix.hpp
+include/El/blas_like/level1/CopyAsyncLocal.hpp
+include/El/blas_like/level1/CopyDistMatrix.hpp
+include/El/blas_like/level1/CopyFromRoot.hpp
+include/El/blas_like/level1/CopyLocal.hpp
include/El/blas_like/level1/DiagonalScale.hpp
include/El/blas_like/level1/DiagonalScaleTrapezoid.hpp
include/El/blas_like/level1/DiagonalSolve.hpp
@@ -51,7 +51,6 @@ include/El/blas_like/level1/EntrywiseFill.hpp
include/El/blas_like/level1/EntrywiseMap.hpp
include/El/blas_like/level1/Fill.hpp
include/El/blas_like/level1/FillDiagonal.hpp
-include/El/blas_like/level1/Full.hpp
include/El/blas_like/level1/GetDiagonal.hpp
include/El/blas_like/level1/GetMappedDiagonal.hpp
include/El/blas_like/level1/GetSubmatrix.hpp
@@ -99,26 +98,21 @@ include/El/blas_like/level1/UpdateSubmatrix.hpp
include/El/blas_like/level1/Zero.hpp
include/El/blas_like/level1/decl.hpp
include/El/blas_like/level1/impl.hpp
-include/El/blas_like/level2.h
include/El/blas_like/level2.hpp
include/El/blas_like/level2/CReflect.hpp
-include/El/blas_like/level3.h
include/El/blas_like/level3.hpp
include/El/blas_like/level3/CReflect.hpp
include/El/config.h
-include/El/control.h
include/El/control.hpp
-include/El/core.h
include/El/core.hpp
+include/El/core/AbstractMatrix.hpp
+include/El/core/AbstractMatrix/decl.hpp
+include/El/core/AbstractMatrix/impl.hpp
include/El/core/CReflect.hpp
-include/El/core/DistGraph.h
-include/El/core/DistGraph.hpp
-include/El/core/DistGraph/decl.hpp
include/El/core/DistMap.hpp
include/El/core/DistMap/decl.hpp
-include/El/core/DistMatrix.h
include/El/core/DistMatrix.hpp
-include/El/core/DistMatrix/Abstract.hpp
+include/El/core/DistMatrix/AbstractDistMatrix.hpp
include/El/core/DistMatrix/Block.hpp
include/El/core/DistMatrix/Block/CIRC_CIRC.hpp
include/El/core/DistMatrix/Block/MC_MR.hpp
@@ -134,81 +128,67 @@ include/El/core/DistMatrix/Block/STAR_VC.hpp
include/El/core/DistMatrix/Block/STAR_VR.hpp
include/El/core/DistMatrix/Block/VC_STAR.hpp
include/El/core/DistMatrix/Block/VR_STAR.hpp
-include/El/core/DistMatrix/Element.hpp
-include/El/core/DistMatrix/Element/CIRC_CIRC.hpp
-include/El/core/DistMatrix/Element/MC_MR.hpp
-include/El/core/DistMatrix/Element/MC_STAR.hpp
-include/El/core/DistMatrix/Element/MD_STAR.hpp
-include/El/core/DistMatrix/Element/MR_MC.hpp
-include/El/core/DistMatrix/Element/MR_STAR.hpp
-include/El/core/DistMatrix/Element/STAR_MC.hpp
-include/El/core/DistMatrix/Element/STAR_MD.hpp
-include/El/core/DistMatrix/Element/STAR_MR.hpp
-include/El/core/DistMatrix/Element/STAR_STAR.hpp
-include/El/core/DistMatrix/Element/STAR_VC.hpp
-include/El/core/DistMatrix/Element/STAR_VR.hpp
-include/El/core/DistMatrix/Element/VC_STAR.hpp
-include/El/core/DistMatrix/Element/VR_STAR.hpp
-include/El/core/DistMultiVec.h
-include/El/core/DistMultiVec.hpp
-include/El/core/DistMultiVec/decl.hpp
-include/El/core/DistMultiVec/impl.hpp
+include/El/core/DistMatrix/ElementMatrix.hpp
+include/El/core/DistMatrix/ElementMatrix/CIRC_CIRC.hpp
+include/El/core/DistMatrix/ElementMatrix/MC_MR.hpp
+include/El/core/DistMatrix/ElementMatrix/MC_STAR.hpp
+include/El/core/DistMatrix/ElementMatrix/MD_STAR.hpp
+include/El/core/DistMatrix/ElementMatrix/MR_MC.hpp
+include/El/core/DistMatrix/ElementMatrix/MR_STAR.hpp
+include/El/core/DistMatrix/ElementMatrix/STAR_MC.hpp
+include/El/core/DistMatrix/ElementMatrix/STAR_MD.hpp
+include/El/core/DistMatrix/ElementMatrix/STAR_MR.hpp
+include/El/core/DistMatrix/ElementMatrix/STAR_STAR.hpp
+include/El/core/DistMatrix/ElementMatrix/STAR_VC.hpp
+include/El/core/DistMatrix/ElementMatrix/STAR_VR.hpp
+include/El/core/DistMatrix/ElementMatrix/VC_STAR.hpp
+include/El/core/DistMatrix/ElementMatrix/VR_STAR.hpp
include/El/core/DistPermutation.hpp
-include/El/core/DistSparseMatrix.h
-include/El/core/DistSparseMatrix.hpp
-include/El/core/DistSparseMatrix/decl.hpp
-include/El/core/DistSparseMatrix/impl.hpp
-include/El/core/Element.h
include/El/core/Element.hpp
include/El/core/Element/Complex/decl.hpp
include/El/core/Element/Complex/impl.hpp
include/El/core/Element/decl.hpp
include/El/core/Element/impl.hpp
include/El/core/FlamePart.hpp
-include/El/core/FlamePart/Merge.h
include/El/core/FlamePart/Merge.hpp
-include/El/core/FlamePart/Partition.h
include/El/core/FlamePart/Partition.hpp
-include/El/core/FlamePart/Repartition.h
include/El/core/FlamePart/Repartition.hpp
-include/El/core/FlamePart/SlidePartition.h
include/El/core/FlamePart/SlidePartition.hpp
-include/El/core/Graph.h
-include/El/core/Graph.hpp
-include/El/core/Graph/decl.hpp
-include/El/core/Grid.h
include/El/core/Grid.hpp
-include/El/core/Matrix.h
include/El/core/Matrix.hpp
include/El/core/Matrix/decl.hpp
include/El/core/Matrix/impl.hpp
+include/El/core/Matrix/impl_cpu.hpp
+include/El/core/Matrix/impl_gpu.hpp
include/El/core/Memory.hpp
include/El/core/Memory/decl.hpp
include/El/core/Memory/impl.hpp
-include/El/core/Permutation.h
+include/El/core/MemoryPool.hpp
include/El/core/Permutation.hpp
+include/El/core/Profiling.hpp
include/El/core/Proxy.hpp
+include/El/core/ProxyDevice.hpp
include/El/core/Serialize.hpp
-include/El/core/SparseMatrix.h
-include/El/core/SparseMatrix.hpp
-include/El/core/SparseMatrix/decl.hpp
-include/El/core/SparseMatrix/impl.hpp
include/El/core/Timer.hpp
-include/El/core/View.h
include/El/core/View.hpp
include/El/core/View/decl.hpp
include/El/core/View/impl.hpp
-include/El/core/environment.h
include/El/core/environment/decl.hpp
include/El/core/environment/impl.hpp
+include/El/core/imports/aluminum.hpp
include/El/core/imports/blas.hpp
include/El/core/imports/choice.hpp
include/El/core/imports/flame.hpp
include/El/core/imports/lapack.hpp
include/El/core/imports/mkl.hpp
include/El/core/imports/mpfr.hpp
-include/El/core/imports/mpi.h
include/El/core/imports/mpi.hpp
+include/El/core/imports/mpi/aluminum_comm.hpp
+include/El/core/imports/mpi/comm.hpp
+include/El/core/imports/mpi/comm_impl.hpp
+include/El/core/imports/mpi/error.hpp
+include/El/core/imports/mpi/meta.hpp
+include/El/core/imports/mpi/plain_comm.hpp
include/El/core/imports/mpi_choice.hpp
include/El/core/imports/omp.hpp
include/El/core/imports/openblas.hpp
@@ -225,9 +205,8 @@ include/El/core/indexing/impl.hpp
include/El/core/limits.hpp
include/El/core/random/decl.hpp
include/El/core/random/impl.hpp
-include/El/core/types.h
include/El/core/types.hpp
-include/El/io.h
+include/El/hydrogen_config.h
include/El/io.hpp
include/El/io/CReflect.hpp
include/El/io/ComplexDisplayWindow-premoc.hpp
@@ -235,17 +214,13 @@ include/El/io/DisplayWidget.hpp
include/El/io/DisplayWindow-premoc.hpp
include/El/io/SpyWidget.hpp
include/El/io/SpyWindow.hpp
-include/El/lapack_like.h
include/El/lapack_like.hpp
include/El/lapack_like/CReflect.hpp
-include/El/lapack_like/condense.h
include/El/lapack_like/condense.hpp
include/El/lapack_like/condense/CReflect.hpp
include/El/lapack_like/equilibrate.hpp
-include/El/lapack_like/euclidean_min.h
include/El/lapack_like/euclidean_min.hpp
include/El/lapack_like/euclidean_min/CReflect.hpp
-include/El/lapack_like/factor.h
include/El/lapack_like/factor.hpp
include/El/lapack_like/factor/CReflect.hpp
include/El/lapack_like/factor/ldl/sparse/numeric.hpp
@@ -253,20 +228,15 @@ include/El/lapack_like/factor/ldl/sparse/symbolic.hpp
include/El/lapack_like/factor/ldl/sparse/symbolic/NodeInfo.hpp
include/El/lapack_like/factor/ldl/sparse/symbolic/Separator.hpp
include/El/lapack_like/factor/qr/ProxyHouseholder.hpp
-include/El/lapack_like/funcs.h
include/El/lapack_like/funcs.hpp
include/El/lapack_like/perm.hpp
-include/El/lapack_like/props.h
include/El/lapack_like/props.hpp
include/El/lapack_like/props/CReflect.hpp
-include/El/lapack_like/reflect.h
include/El/lapack_like/reflect.hpp
-include/El/lapack_like/solve.h
include/El/lapack_like/solve.hpp
include/El/lapack_like/solve/FGMRES.hpp
include/El/lapack_like/solve/LGMRES.hpp
include/El/lapack_like/solve/Refined.hpp
-include/El/lapack_like/spectral.h
include/El/lapack_like/spectral.hpp
include/El/lapack_like/spectral/CReflect.hpp
include/El/lapack_like/spectral/HermitianEig.hpp
@@ -274,86 +244,88 @@ include/El/lapack_like/spectral/Lanczos.hpp
include/El/lapack_like/spectral/ProductLanczos.hpp
include/El/lapack_like/spectral/SVD.hpp
include/El/lapack_like/spectral/Schur.hpp
-include/El/lapack_like/util.h
include/El/lapack_like/util.hpp
include/El/macros/CInstantiate.h
+include/El/macros/DeviceGuardAndPayload.h
include/El/macros/GuardAndPayload.h
include/El/macros/Instantiate.h
include/El/macros/NestedGuardAndPayload.h
-include/El/matrices.h
include/El/matrices.hpp
include/El/matrices/deterministic/classical/Circulant.hpp
include/El/matrices/deterministic/lattice/NTRUAttack.hpp
-include/El/number_theory.h
-include/El/number_theory.hpp
-include/El/number_theory/DynamicSieve.hpp
-include/El/number_theory/JacobiSymbol.hpp
-include/El/number_theory/LegendreSymbol.hpp
-include/El/number_theory/MillerRabin.hpp
-include/El/number_theory/NextProbablePrime.hpp
-include/El/number_theory/PowerDecomp.hpp
-include/El/number_theory/PrimalityTest.hpp
-include/El/number_theory/PrimitiveRoot.hpp
-include/El/number_theory/SqrtModPrime.hpp
-include/El/number_theory/TrialDivision.hpp
-include/El/number_theory/dlog/PollardRho.hpp
-include/El/number_theory/factor/PollardPMinusOne.hpp
-include/El/number_theory/factor/PollardRho.hpp
-include/El/number_theory/lattice.h
-include/El/number_theory/lattice.hpp
-include/El/number_theory/lattice/BKZ.hpp
-include/El/number_theory/lattice/CReflect.hpp
-include/El/number_theory/lattice/Enrich.hpp
-include/El/number_theory/lattice/Enumerate.hpp
-include/El/number_theory/lattice/LLL.hpp
-include/El/number_theory/lattice/LLL/Left.hpp
-include/El/number_theory/lattice/NearestPlane.hpp
-include/El/optimization.h
-include/El/optimization.hpp
-include/El/optimization/CReflect.hpp
-include/El/optimization/models.h
-include/El/optimization/models.hpp
-include/El/optimization/prox.h
-include/El/optimization/prox.hpp
-include/El/optimization/solvers.h
-include/El/optimization/solvers.hpp
-include/El/optimization/util.h
-include/El/optimization/util.hpp
-include/El/optimization/util/cone.hpp
-include/El/optimization/util/pos_orth.hpp
-include/El/optimization/util/soc.hpp
-include/ElSuiteSparse/amd.h
-include/ElSuiteSparse/amd_internal.h
-include/ElSuiteSparse/config.h
-include/ElSuiteSparse/ldl.hpp
-include/ElSuiteSparse/ldl/impl.hpp
-include/pmrrr.h
-include/pmrrr/counter.h
-include/pmrrr/global.h
-include/pmrrr/plarre.h
-include/pmrrr/plarrv.h
-include/pmrrr/process_task.h
-include/pmrrr/queue.h
-include/pmrrr/rrr.h
-include/pmrrr/structs.h
-include/pmrrr/tasks.h
-lib/cmake/elemental/ElementalConfig.cmake
-lib/cmake/elemental/ElementalConfigVersion.cmake
-lib/cmake/elemental/ElementalTargets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/elemental/ElementalTargets.cmake
-lib/libEl.so
-lib/libEl.so.0
-lib/libEl.so.87
-lib/libElSuiteSparse.so
-lib/libElSuiteSparse.so.0
-lib/libElSuiteSparse.so.87
-lib/libpmrrr.so
-lib/libpmrrr.so.0
-lib/libpmrrr.so.87
-%%DATADIR%%/lapack_like/c-41.mtx
-%%DATADIR%%/lapack_like/memplus.mtx
-%%DATADIR%%/number_theory/SVP80_BKZ49.txt
-%%DATADIR%%/number_theory/SVPChallenge100.txt
-%%DATADIR%%/number_theory/SVPChallenge146.txt
-%%DATADIR%%/number_theory/SVPChallenge40.txt
-%%DATADIR%%/number_theory/SVPChallenge80.txt
+include/hydrogen/Device.hpp
+include/hydrogen/Error.hpp
+include/hydrogen/MultiSync.hpp
+include/hydrogen/SyncInfo.hpp
+include/hydrogen/SyncInfoAllDecl.hpp
+include/hydrogen/SyncInfoBase.hpp
+include/hydrogen/SynchronizeAPI.hpp
+include/hydrogen/blas/BLAS_Common.hpp
+include/hydrogen/blas/GPU_BLAS.hpp
+include/hydrogen/blas/GPU_BLAS_decl.hpp
+include/hydrogen/blas/GPU_BLAS_impl.hpp
+include/hydrogen/blas/gpu/Axpy.hpp
+include/hydrogen/blas/gpu/Copy.hpp
+include/hydrogen/blas/gpu/Fill.hpp
+include/hydrogen/blas/gpu/Hadamard.hpp
+include/hydrogen/blas/gpu/Scale.hpp
+include/hydrogen/blas/gpu/Transpose.hpp
+include/hydrogen/device/GPU.hpp
+include/hydrogen/device/gpu/BasicCopy.hpp
+include/hydrogen/device/gpu/CUB.hpp
+include/hydrogen/device/gpu/CUDA.hpp
+include/hydrogen/device/gpu/GPUError.hpp
+include/hydrogen/device/gpu/ROCm.hpp
+include/hydrogen/device/gpu/SyncInfo.hpp
+include/hydrogen/device/gpu/cuda/CUDACopy.hpp
+include/hydrogen/device/gpu/cuda/CUDAError.hpp
+include/hydrogen/device/gpu/cuda/CUDALaunchKernel.hpp
+include/hydrogen/device/gpu/cuda/CUDAManagement.hpp
+include/hydrogen/device/gpu/cuda/SyncInfo.hpp
+include/hydrogen/device/gpu/cuda/cuBLAS.hpp
+include/hydrogen/device/gpu/cuda/cuBLASError.hpp
+include/hydrogen/device/gpu/cuda/cuBLASManagement.hpp
+include/hydrogen/device/gpu/cuda/cuBLASMeta.hpp
+include/hydrogen/device/gpu/cuda/cuBLASUtil.hpp
+include/hydrogen/device/gpu/cuda/cuBLAS_API.hpp
+include/hydrogen/device/gpu/rocm/ROCmCopy.hpp
+include/hydrogen/device/gpu/rocm/ROCmError.hpp
+include/hydrogen/device/gpu/rocm/ROCmLaunchKernel.hpp
+include/hydrogen/device/gpu/rocm/ROCmManagement.hpp
+include/hydrogen/device/gpu/rocm/SyncInfo.hpp
+include/hydrogen/device/gpu/rocm/rocBLAS.hpp
+include/hydrogen/device/gpu/rocm/rocBLASError.hpp
+include/hydrogen/device/gpu/rocm/rocBLASManagement.hpp
+include/hydrogen/device/gpu/rocm/rocBLASMeta.hpp
+include/hydrogen/device/gpu/rocm/rocBLASUtil.hpp
+include/hydrogen/device/gpu/rocm/rocBLAS_API.hpp
+include/hydrogen/meta/IndexSequence.hpp
+include/hydrogen/meta/MetaUtilities.hpp
+include/hydrogen/meta/TypeList.hpp
+include/hydrogen/meta/TypeTraits.hpp
+include/hydrogen/utils/HalfPrecision.hpp
+include/hydrogen/utils/NumericTypeConversion.hpp
+include/hydrogen/utils/SimpleBuffer.hpp
+lib/cmake/hydrogen/HydrogenConfig.cmake
+lib/cmake/hydrogen/HydrogenConfigVersion.cmake
+lib/cmake/hydrogen/HydrogenTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/hydrogen/HydrogenTargets.cmake
+lib/cmake/hydrogen/modules/FindAndVerifyExtendedPrecision.cmake
+lib/cmake/hydrogen/modules/FindAndVerifyLAPACK.cmake
+lib/cmake/hydrogen/modules/FindAndVerifyMPI.cmake
+lib/cmake/hydrogen/modules/FindAndVerifyOpenMP.cmake
+lib/cmake/hydrogen/modules/FindCUB.cmake
+lib/cmake/hydrogen/modules/FindGMP.cmake
+lib/cmake/hydrogen/modules/FindHALF.cmake
+lib/cmake/hydrogen/modules/FindMPC.cmake
+lib/cmake/hydrogen/modules/FindMPFR.cmake
+lib/cmake/hydrogen/modules/FindNVML.cmake
+lib/cmake/hydrogen/modules/FindNVTX.cmake
+lib/cmake/hydrogen/modules/FindQD.cmake
+lib/cmake/hydrogen/modules/FindQuadmath.cmake
+lib/cmake/hydrogen/modules/FindROCBLAS.cmake
+lib/cmake/hydrogen/modules/FindVTUNE.cmake
+lib/cmake/hydrogen/modules/FindValgrind.cmake
+lib/cmake/hydrogen/modules/HydrogenETIGeneration.cmake
+lib/cmake/hydrogen/modules/PrintHydrogenSummary.cmake
+lib/libHydrogen_CXX.so