aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-09-04 04:09:28 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-09-04 04:09:28 +0000
commit987847e500b919e7c9efffffd0b0ab697ecf1ab3 (patch)
treed1d4e5e7c871454b47ba85c0bbef81e2f7b4e8f1 /math
parent734777f37e6b365d52237e69b5a24c44e105006b (diff)
downloadports-987847e500b919e7c9efffffd0b0ab697ecf1ab3.tar.gz
ports-987847e500b919e7c9efffffd0b0ab697ecf1ab3.zip
Diffstat (limited to 'math')
-rw-r--r--math/oink/Makefile2
-rw-r--r--math/oink/files/patch-src_lace.h2
2 files changed, 1 insertions, 3 deletions
diff --git a/math/oink/Makefile b/math/oink/Makefile
index 4e366d421d1d..0acc7592419d 100644
--- a/math/oink/Makefile
+++ b/math/oink/Makefile
@@ -12,8 +12,6 @@ COMMENT= Modern parity game solvers written in C++
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_i386= error: use of undeclared identifier 'mfence'
-
LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs
USES= cmake:testing
diff --git a/math/oink/files/patch-src_lace.h b/math/oink/files/patch-src_lace.h
index 86d901ac1df4..f456cff65c0f 100644
--- a/math/oink/files/patch-src_lace.h
+++ b/math/oink/files/patch-src_lace.h
@@ -4,7 +4,7 @@
#endif
#ifndef mfence
-+#ifdef __amd64__
++#if defined(__amd64__) || defined(__i386__)
#define mfence() { asm volatile("mfence" ::: "memory"); }
+#elif defined(__powerpc__)
+#define mfence() { asm volatile("sync" ::: "memory"); }