aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2020-01-06 01:29:47 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2020-01-06 01:29:47 +0000
commita02b63905571da8b35f4ad878819877f727e6b82 (patch)
treee41fa9704b45f2b60a63fec792dd0b2212975b3c /math
parentc7310d73abf26c96bc3229ebc9ed8ad7ca89d911 (diff)
downloadports-a02b63905571da8b35f4ad878819877f727e6b82.tar.gz
ports-a02b63905571da8b35f4ad878819877f727e6b82.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-communications/Makefile31
-rw-r--r--math/octave-forge-communications/distinfo3
-rw-r--r--math/octave-forge-communications/pkg-descr11
4 files changed, 46 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 8d2a804e5172..bbb46df1e895 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -410,6 +410,7 @@
SUBDIR += octave-forge-bsltl
SUBDIR += octave-forge-cgi
SUBDIR += octave-forge-civil-engineering
+ SUBDIR += octave-forge-communications
SUBDIR += octave-forge-control
SUBDIR += octave-forge-data-smoothing
SUBDIR += octave-forge-database
diff --git a/math/octave-forge-communications/Makefile b/math/octave-forge-communications/Makefile
new file mode 100644
index 000000000000..20c7eda5edc9
--- /dev/null
+++ b/math/octave-forge-communications/Makefile
@@ -0,0 +1,31 @@
+# Created by: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+# $FreeBSD$
+
+PORTNAME= octave-forge-communications
+PORTVERSION= 1.2.2
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${DISTNAME}
+
+GNU_CONFIGURE= yes
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
+MAKE_ENV+= MKOCTFILE=mkoctfile
+
+RUN_DEPENDS+= ${TARBALLS_DIR}/signal.tar.gz:math/octave-forge-signal
+
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+post-build:
+ ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-communications/distinfo b/math/octave-forge-communications/distinfo
new file mode 100644
index 000000000000..9789edf5fede
--- /dev/null
+++ b/math/octave-forge-communications/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1578273209
+SHA256 (octave-forge/communications-1.2.2.tar.gz) = 93f9ad5e807d502f58c07688dfe2ce40231da1a81fe3da90926337e5e5165ef5
+SIZE (octave-forge/communications-1.2.2.tar.gz) = 329282
diff --git a/math/octave-forge-communications/pkg-descr b/math/octave-forge-communications/pkg-descr
new file mode 100644
index 000000000000..c5c8bcf46ddd
--- /dev/null
+++ b/math/octave-forge-communications/pkg-descr
@@ -0,0 +1,11 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is communications.
+
+ Digital Communications, Error Correcting Codes (Channel Code),
+Source Code functions, Modulation and Galois Fields
+
+WWW: http://octave.sourceforge.net/