aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2020-09-26 16:29:23 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2020-09-26 16:29:23 +0000
commitf29c12c3182714b0ff4cfd29f573e1e899f31836 (patch)
treedad4499bb73c6cf67fbdba44cae9669ec5d77ea5 /math
parente3ac3feb1669d81d739adfc87d6f63b6723729f1 (diff)
downloadports-f29c12c3182714b0ff4cfd29f573e1e899f31836.tar.gz
ports-f29c12c3182714b0ff4cfd29f573e1e899f31836.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/scilab/Makefile2
-rw-r--r--math/scilab/files/patch-modules_matio_src_cpp_GetSparseVariable.cpp20
2 files changed, 21 insertions, 1 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 19c3ea4a8cfe..49ce2bc358ec 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scilab
PORTVERSION= 6.1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math cad java
MASTER_SITES= https://www.scilab.org/download/${PORTVERSION}/
DISTFILES= ${DISTNAME}-src${EXTRACT_SUFX}
diff --git a/math/scilab/files/patch-modules_matio_src_cpp_GetSparseVariable.cpp b/math/scilab/files/patch-modules_matio_src_cpp_GetSparseVariable.cpp
new file mode 100644
index 000000000000..fd9c297f40e5
--- /dev/null
+++ b/math/scilab/files/patch-modules_matio_src_cpp_GetSparseVariable.cpp
@@ -0,0 +1,20 @@
+--- modules/matio/src/cpp/GetSparseVariable.cpp.orig 2020-02-25 10:00:03 UTC
++++ modules/matio/src/cpp/GetSparseVariable.cpp
+@@ -65,7 +65,7 @@ matvar_t* GetSparseMatVar(types::Sparse* pSparse, cons
+ int* itemsRow = new int[pSparse->getRows()];
+ pSparse->getNbItemByRow(itemsRow);
+
+- int* colIndexes = (int*)MALLOC(sizeof(int) * (pSparse->getRows() + 1));
++ mat_uint32_t* colIndexes = (mat_uint32_t*)MALLOC(sizeof(mat_uint32_t) * (pSparse->getRows() + 1));
+ if (colIndexes == NULL)
+ {
+ FREE(sparseData);
+@@ -82,7 +82,7 @@ matvar_t* GetSparseMatVar(types::Sparse* pSparse, cons
+ colIndexes[K + 1] = colIndexes[K] + itemsRow[K];
+ }
+
+- int* rowIndexes = (int*)MALLOC(sizeof(int) * nonZeros);
++ mat_uint32_t* rowIndexes = (mat_uint32_t*)MALLOC(sizeof(mat_uint32_t) * nonZeros);
+ if (rowIndexes == NULL)
+ {
+ FREE(sparseData);