aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-09-12 15:18:06 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-10-03 17:47:27 +0000
commit07fb2d5e9d001934f1670d01aec1f536f14ebde2 (patch)
treef2f87572cb6aa68955a9057625ca5ed1acbb394a /math
parente8b8483aa7832bea5fdc062db342a76255d6281b (diff)
downloadports-07fb2d5e9d001934f1670d01aec1f536f14ebde2.tar.gz
ports-07fb2d5e9d001934f1670d01aec1f536f14ebde2.zip
Diffstat (limited to 'math')
-rw-r--r--math/hmat-oss/Makefile11
-rw-r--r--math/librsb/Makefile3
-rw-r--r--math/py-theano/Makefile3
-rw-r--r--math/tmv/Makefile4
-rw-r--r--math/viennacl/Makefile4
5 files changed, 11 insertions, 14 deletions
diff --git a/math/hmat-oss/Makefile b/math/hmat-oss/Makefile
index e54cb7d5ed35..cd215947f434 100644
--- a/math/hmat-oss/Makefile
+++ b/math/hmat-oss/Makefile
@@ -1,5 +1,6 @@
PORTNAME= hmat-oss
DISTVERSION= 1.7.1
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -10,7 +11,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
LIB_DEPENDS= libopenblas.so:math/openblas
-USES= cmake compiler:openmp
+USES= cmake
USE_LDCONFIG= yes
USE_GITHUB= yes
@@ -22,12 +23,6 @@ CMAKE_OFF= HMAT_GIT_VERSION
LDFLAGS+= -lexecinfo
-.include <bsd.port.pre.mk>
-
-.if ${CHOSEN_COMPILER_TYPE} == gcc
-USE_GCC= yes
-.endif
-
do-test:
@cd ${BUILD_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_EXAMPLES:BOOL=ON ${CMAKE_SOURCE_PATH} && \
@@ -35,4 +30,4 @@ do-test:
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/librsb/Makefile b/math/librsb/Makefile
index 187ead3b681a..a98c55792372 100644
--- a/math/librsb/Makefile
+++ b/math/librsb/Makefile
@@ -2,6 +2,7 @@
PORTNAME= librsb
PORTVERSION= 1.2.0.10
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= SF/librsb
DISTNAME= ${PORTNAME}-${PORTVERSION:S/r/-rc/}
@@ -15,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= gsed:textproc/gsed \
bash:shells/bash
-USES= fortran compiler:openmp gmake shebangfix libtool
+USES= fortran gmake shebangfix libtool
INSTALL_TARGET= install-strip
TEST_TARGET= qtests
GNU_CONFIGURE= yes
diff --git a/math/py-theano/Makefile b/math/py-theano/Makefile
index 99c7e6c4c77f..85a928551040 100644
--- a/math/py-theano/Makefile
+++ b/math/py-theano/Makefile
@@ -2,6 +2,7 @@
PORTNAME= theano
DISTVERSION= 1.0.5
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,7 +18,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.8.0:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six@${PY_FLAVOR}
-USES= compiler:openmp python:3.6+
+USES= python:3.6+
USE_PYTHON= concurrent distutils autoplist
NO_ARCH= yes
diff --git a/math/tmv/Makefile b/math/tmv/Makefile
index 1783cfc1dd68..9ec06912099c 100644
--- a/math/tmv/Makefile
+++ b/math/tmv/Makefile
@@ -1,7 +1,7 @@
PORTNAME= tmv
DISTVERSIONPREFIX= v
DISTVERSION= 0.75
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -10,7 +10,7 @@ COMMENT= Fast, intuitive linear algebra library for C++
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/TMV_LICENSE
-USES= compiler:openmp gmake blaslapack:netlib localbase
+USES= gmake blaslapack:netlib localbase
USE_GITHUB= yes
GH_ACCOUNT= rmjarvis
USE_LDCONFIG= yes
diff --git a/math/viennacl/Makefile b/math/viennacl/Makefile
index 4eaabd71266d..d10341decf3d 100644
--- a/math/viennacl/Makefile
+++ b/math/viennacl/Makefile
@@ -2,7 +2,7 @@
PORTNAME= viennacl
PORTVERSION= 1.7.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/1.7.x/
DISTNAME= ViennaCL-${PORTVERSION}
@@ -17,6 +17,6 @@ BUILD_DEPENDS= ${LOCALBASE}/include/CL/opencl.h:devel/opencl
LIB_DEPENDS= libOpenCL.so:devel/ocl-icd
RUN_DEPENDS= ${LOCALBASE}/include/CL/opencl.h:devel/opencl
-USES= cmake compiler:openmp localbase
+USES= cmake localbase
.include <bsd.port.mk>