aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2007-04-14 06:58:38 +0000
committerGreg Lewis <glewis@FreeBSD.org>2007-04-14 06:58:38 +0000
commitece78b7a7d5b604a116a859bfbb47ed11d455bf0 (patch)
tree71a2d246257437ef8ae7e4ec874a85d948dbd328 /math
parent4a024ce9064c039a7ef9e70772fc8217dc3fba5c (diff)
downloadports-ece78b7a7d5b604a116a859bfbb47ed11d455bf0.tar.gz
ports-ece78b7a7d5b604a116a859bfbb47ed11d455bf0.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/gnuplot/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 8f6402be63a5..02f9a24b5dbc 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnuplot
PORTVERSION= 4.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,6 +16,7 @@ MAINTAINER= glewis@FreeBSD.org
COMMENT= A command-driven interactive function plotting program
GNU_CONFIGURE= yes
+WANT_WX= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-kpsexpand \
--with-lasergnu \
@@ -28,7 +29,8 @@ BUILD_DEPENDS+=latex:${PORTSDIR}/print/teTeX-base
OPTIONS= GD "Enable GD support" on \
PDF "Enable PDF support" on \
- PLOT "Enable plot support" on
+ PLOT "Enable plot support" on \
+ WX "Enable WX support" off
MAN1= gnuplot.1 lasergnu.1
INFO= gnuplot
@@ -64,6 +66,14 @@ LIB_DEPENDS+= plot.4:${PORTSDIR}/graphics/plotutils
CONFIGURE_ARGS+= --with-plot=${LOCALBASE}
.endif
+.if defined(WITHOUT_WX)
+CONFIGURE_ARGS+= --disable-wxwidgets
+.else
+USE_WX= 2.4+
+WX_COMPS= wx
+CONFIGURE_ARGS+= --with-wx-config=${WXCONFIG}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|)/@PACKAGE@/@PKG_MAJOR@|)|g' ${WRKSRC}/src/Makefile.in