aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-09-04 14:27:56 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-09-04 14:27:56 +0000
commit126bd38b6abcc260ed0bb3f8f94a1f979b047b98 (patch)
treee14ec6281eee4132539f4b23bae4981523ca4aff /math
parentd770dab6c909e450dd60b952d1efbfc5c1208d66 (diff)
downloadports-126bd38b6abcc260ed0bb3f8f94a1f979b047b98.tar.gz
ports-126bd38b6abcc260ed0bb3f8f94a1f979b047b98.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/oleo/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index 65c57d843312..ce23279377e3 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -47,7 +47,13 @@ pre-everything::
.endif
post-patch:
- @${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} \
- ${REINPLACE_CMD} -e "s|<malloc.h>|<stdlib.h>|g"
+ @${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|malloc\.h|stdlib.h|g'
+
+pre-build:
+.for file in src/io-term.c
+ cd ${WRKSRC} && ${MV} ${file} ${file}.pre_iconv \
+ && iconv -c -t ascii ${file}.pre_iconv > ${file} || ${TRUE}
+.endfor
.include <bsd.port.post.mk>