aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-05 10:42:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-05 10:42:51 +0000
commita415342446a42c7ebb6b80682c3cf40ec5b7f2fe (patch)
tree7d690591fb48d06ef2fdeef6c8675147645cc336 /math
parentd10a16a0aed97c9ffefbc1ad4c2bf76aa13fc312 (diff)
downloadports-a415342446a42c7ebb6b80682c3cf40ec5b7f2fe.tar.gz
ports-a415342446a42c7ebb6b80682c3cf40ec5b7f2fe.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-fits/Makefile24
-rw-r--r--math/octave-forge-fits/distinfo2
-rw-r--r--math/octave-forge-fits/pkg-descr12
-rw-r--r--math/octave-forge-fits/pkg-plist1
5 files changed, 40 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 076c0f612722..85739e25684a 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -233,6 +233,7 @@
SUBDIR += octave-forge-es
SUBDIR += octave-forge-fenv
SUBDIR += octave-forge-financial
+ SUBDIR += octave-forge-fits
SUBDIR += octave-forge-fpl
SUBDIR += octave-forge-ga
SUBDIR += octave-forge-general
diff --git a/math/octave-forge-fits/Makefile b/math/octave-forge-fits/Makefile
new file mode 100644
index 000000000000..406f59b5f4ee
--- /dev/null
+++ b/math/octave-forge-fits/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: octave-forge-fits
+# Date created: 13 Janurary 2011
+# Whom: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-fits
+PORTVERSION= 1.0.0
+CATEGORIES= math
+
+MAINTAINER= stephen@missouri.edu
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTAVE_PKGNAME}/src
+
+LIB_DEPENDS+= cfitsio:${PORTSDIR}/astro/cfitsio
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+post-build:
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTAVE_PKGNAME}
+
+.include <bsd.port.post.mk>
diff --git a/math/octave-forge-fits/distinfo b/math/octave-forge-fits/distinfo
new file mode 100644
index 000000000000..10db181dcdc1
--- /dev/null
+++ b/math/octave-forge-fits/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/fits-1.0.0.tar.gz) = 15adbe3a1443730b4613cb9df7ae00202a36a928600e98c9527dace0bf6e76bc
+SIZE (octave-forge/fits-1.0.0.tar.gz) = 10974
diff --git a/math/octave-forge-fits/pkg-descr b/math/octave-forge-fits/pkg-descr
new file mode 100644
index 000000000000..df45281bac41
--- /dev/null
+++ b/math/octave-forge-fits/pkg-descr
@@ -0,0 +1,12 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is fits.
+
+The Octave-FITS package provides functions for reading, and writing FITS
+(Flexible Image Transport System) files. The package supports uses the
+libcfitsio library.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-fits/pkg-plist b/math/octave-forge-fits/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-fits/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty