aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-11 11:46:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-11 11:46:17 +0000
commita5ed7d338516df86c0bb9d954684acf3e3a27626 (patch)
tree3632d1964537cf59948cb5e52b97fa7e8cc03036 /math
parent1efe0abb5e600da2cfaa1f69e174ced81bb0cc81 (diff)
downloadports-a5ed7d338516df86c0bb9d954684acf3e3a27626.tar.gz
ports-a5ed7d338516df86c0bb9d954684acf3e3a27626.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-MPC/Makefile24
-rw-r--r--math/p5-Math-MPC/distinfo3
-rw-r--r--math/p5-Math-MPC/pkg-descr7
-rw-r--r--math/p5-Math-MPC/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 74a27dc259cb..8085103d885f 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -310,6 +310,7 @@
SUBDIR += p5-Math-Intersection-StraightLine
SUBDIR += p5-Math-LinearCombination
SUBDIR += p5-Math-Logic
+ SUBDIR += p5-Math-MPC
SUBDIR += p5-Math-MPFR
SUBDIR += p5-Math-Matrix
SUBDIR += p5-Math-NumberCruncher
diff --git a/math/p5-Math-MPC/Makefile b/math/p5-Math-MPC/Makefile
new file mode 100644
index 000000000000..737180e43afd
--- /dev/null
+++ b/math/p5-Math-MPC/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Math-MPC
+# Date created: 05 April, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-MPC
+PORTVERSION= 0.60
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A perl interface to MPC Library
+
+LIB_DEPENDS= mpc.1:${PORTSDIR}/math/mpc
+
+PERL_CONFIGURE= yes
+MAKE_ENV= INC="-I${LOCALBASE}/include"
+
+MAN3= Math::MPC.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-MPC/distinfo b/math/p5-Math-MPC/distinfo
new file mode 100644
index 000000000000..330e6414f87a
--- /dev/null
+++ b/math/p5-Math-MPC/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-MPC-0.60.tar.gz) = e30b1305cb237c108455ccf9c235e8cf
+SHA256 (Math-MPC-0.60.tar.gz) = 7b4a0b674b4d81bac79103b42b7043b471cb5b2f4e5d03595cf838d3d5d42f85
+SIZE (Math-MPC-0.60.tar.gz) = 38010
diff --git a/math/p5-Math-MPC/pkg-descr b/math/p5-Math-MPC/pkg-descr
new file mode 100644
index 000000000000..ad54c2f073cd
--- /dev/null
+++ b/math/p5-Math-MPC/pkg-descr
@@ -0,0 +1,7 @@
+p5-Math-MPC is a module wraps the MPC library functions.
+
+The MPC library is a C library for multiple-precision complex number
+computations with exact rounding. It is based on the MPFR C library
+which, in turn, is based on the GMP C library.
+
+WWW: http://search.cpan.org/dist/Math-MPC
diff --git a/math/p5-Math-MPC/pkg-plist b/math/p5-Math-MPC/pkg-plist
new file mode 100644
index 000000000000..1c16eab43178
--- /dev/null
+++ b/math/p5-Math-MPC/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/mach/Math/MPC.pm
+%%SITE_PERL%%/mach/auto/Math/MPC/.packlist
+%%SITE_PERL%%/mach/auto/Math/MPC/MPC.bs
+%%SITE_PERL%%/mach/auto/Math/MPC/MPC.so
+@dirrm %%SITE_PERL%%/mach/Math
+@dirrm %%SITE_PERL%%/mach/auto/Math/MPC
+@dirrmtry %%SITE_PERL%%/mach/auto/Math