aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-10-17 16:33:00 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-10-17 16:33:00 +0000
commit0966b81bb56071cfcfd48637407c05d932a48e30 (patch)
tree206b4bff5f5f14f101313e2560ccbcf08700c143 /math
parent506a4ae0636dc9379aa520abaced84f4580a7622 (diff)
downloadports-0966b81bb56071cfcfd48637407c05d932a48e30.tar.gz
ports-0966b81bb56071cfcfd48637407c05d932a48e30.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/scilab-toolbox-swt/Makefile57
-rw-r--r--math/scilab-toolbox-swt/distinfo6
-rw-r--r--math/scilab-toolbox-swt/files/patch-builder.sce17
-rw-r--r--math/scilab-toolbox-swt/files/patch-etc__swt.start18
-rw-r--r--math/scilab-toolbox-swt/pkg-descr3
-rw-r--r--math/scilab-toolbox-swt/pkg-message5
-rw-r--r--math/scilab-toolbox-swt/pkg-plist173
7 files changed, 135 insertions, 144 deletions
diff --git a/math/scilab-toolbox-swt/Makefile b/math/scilab-toolbox-swt/Makefile
index 8c83adab8596..ea97a6ca31fd 100644
--- a/math/scilab-toolbox-swt/Makefile
+++ b/math/scilab-toolbox-swt/Makefile
@@ -6,42 +6,53 @@
#
PORTNAME= swt
-DISTVERSION= 0.1.0rc4
-PORTREVISION= 4
+PORTVERSION= 0.1.11
CATEGORIES= math
-MASTER_SITES= SF/scwt/${PORTNAME}/0.1.0rc4Linux
+MASTER_SITES= http://atoms.scilab.org/toolboxes/swt/${PORTVERSION}/files/
PKGNAMEPREFIX= scilab-toolbox-
-DISTNAME= ${PORTNAME}${DISTVERSION}
+DISTFILES= ${DISTNAME}-1-src${EXTRACT_SUFX}
MAINTAINER= makc@FreeBSD.org
COMMENT= Scilab 1-D and 2-D Wavelet Toolbox
-BUILD_DEPENDS= ${LOCALBASE}/bin/scilab:${PORTSDIR}/math/scilab
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${SCILAB_CMD}:${PORTSDIR}/math/scilab
+RUN_DEPENDS:= ${BUILD_DEPENDS}
-IGNORE= doesn't build with Scilab 5.2
+IGNORE= touches ${LOCALBASE}/share/scilab when building under superuser
-WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
-
-SCILABDIR?= lib/scilab
-CONTRIBDIR?= ${SCILABDIR}/contrib
-TOOLBOXDIR?= ${CONTRIBDIR}/${PORTNAME}
-
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS+=--prefix=${PREFIX}/${TOOLBOXDIR}
-CONFIGURE_ENV+= SCI="${LOCALBASE}/${SCILABDIR}"
-
-PLIST_SUB= TOOLBOXDIR=${TOOLBOXDIR}
+SCILAB_CMD= ${LOCALBASE}/bin/scilab
+CONTRIBDIR?= share/scilab/contrib
+TOOLBOXDIR_REL?= ${CONTRIBDIR}/${PORTNAME}
+TOOLBOXDIR= ${PREFIX}/${TOOLBOXDIR_REL}
+PLIST_SUB= TOOLBOXDIR=${TOOLBOXDIR_REL}
OPTIONS= SIVP "Enable Image and Video support" off
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_SIVP)
RUN_DEPENDS+= ${LOCALBASE}/${CONTRIBDIR}/sivp/loader.sce:${PORTSDIR}/math/scilab-toolbox-sivp
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
+post-patch:
+ ${REINPLACE_CMD} -e "s,SWTDIR+','${TOOLBOXDIR}/demos," \
+ ${WRKSRC}/demos/image.sce
+pre-build:
+ ${FIND} -d ${WRKSRC} \( -name '*.orig' -or -name '*.bak' \) | ${XARGS} ${RM}
+
+do-build:
+ cd ${WRKSRC} && ${SCILAB_CMD} -nogui -f builder.sce
+
+do-install:
+ ${MKDIR} ${TOOLBOXDIR}/sci_gateway/c
+ ${INSTALL_DATA} ${WRKSRC}/loader.sce ${TOOLBOXDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sci_gateway/loader_gateway.sce \
+ ${TOOLBOXDIR}/sci_gateway
+ cd ${WRKSRC}/sci_gateway/c && \
+ ${INSTALL_DATA} loader.sce ${TOOLBOXDIR}/sci_gateway/c && \
+ ${INSTALL_PROGRAM} libswt_c.so ${TOOLBOXDIR}/sci_gateway/c
+.for d in demos etc macros
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${TOOLBOXDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/math/scilab-toolbox-swt/distinfo b/math/scilab-toolbox-swt/distinfo
index d6ab81e881a1..c8049ff31129 100644
--- a/math/scilab-toolbox-swt/distinfo
+++ b/math/scilab-toolbox-swt/distinfo
@@ -1,3 +1,3 @@
-MD5 (swt0.1.0rc4.tar.gz) = f89f7e7adae739a08628a389f1ee2ef6
-SHA256 (swt0.1.0rc4.tar.gz) = c7ab7ef0f216cd2b093921517705636c0188bb0948702586028f3d60ee6f4ca5
-SIZE (swt0.1.0rc4.tar.gz) = 998748
+MD5 (swt-0.1.11-1-src.tar.gz) = 67ffe4a038666a14809488def6f2b6f4
+SHA256 (swt-0.1.11-1-src.tar.gz) = aef26dd3a2c45ba00605bf79ba4bd6e1809eee67ca48cee7573fc7c11d159efc
+SIZE (swt-0.1.11-1-src.tar.gz) = 677437
diff --git a/math/scilab-toolbox-swt/files/patch-builder.sce b/math/scilab-toolbox-swt/files/patch-builder.sce
new file mode 100644
index 000000000000..3461826356e3
--- /dev/null
+++ b/math/scilab-toolbox-swt/files/patch-builder.sce
@@ -0,0 +1,17 @@
+--- ./builder.sce.orig 2010-06-30 18:31:36.000000000 +0400
++++ ./builder.sce 2010-07-10 20:13:24.901709864 +0400
+@@ -33,7 +33,7 @@
+ tbx_builder_macros(toolbox_dir);
+ //tbx_builder_src(toolbox_dir);
+ tbx_builder_gateway(toolbox_dir);
+-tbx_builder_help(toolbox_dir);
++// tbx_builder_help(toolbox_dir);
+ tbx_build_loader(TOOLBOX_NAME, toolbox_dir);
+ tbx_build_cleaner(TOOLBOX_NAME, toolbox_dir);
+
+@@ -41,3 +41,5 @@
+ // =============================================================================
+
+ clear toolbox_dir TOOLBOX_NAME TOOLBOX_TITLE;
++
++quit
diff --git a/math/scilab-toolbox-swt/files/patch-etc__swt.start b/math/scilab-toolbox-swt/files/patch-etc__swt.start
new file mode 100644
index 000000000000..4b9e07f0262d
--- /dev/null
+++ b/math/scilab-toolbox-swt/files/patch-etc__swt.start
@@ -0,0 +1,18 @@
+--- ./etc/swt.start.orig 2010-08-30 12:52:10.000000000 +0400
++++ ./etc/swt.start 2010-10-17 16:02:57.850107854 +0400
+@@ -34,15 +34,6 @@
+
+ // Load and add help chapter
+ // =============================================================================
+-if or(getscilabmode() == ["NW";"STD"]) then
+- mprintf("\tLoad help\n");
+- path_addchapter = pathconvert(root_tlbx+"/jar");
+- if ( isdir(path_addchapter) <> [] ) then
+- add_help_chapter("swt", path_addchapter, %F);
+- clear add_help_chapter;
+- end
+- clear path_addchapter;
+-end
+
+
+ clear root_tlbx;
diff --git a/math/scilab-toolbox-swt/pkg-descr b/math/scilab-toolbox-swt/pkg-descr
index fcd82497e169..0a345fa519b5 100644
--- a/math/scilab-toolbox-swt/pkg-descr
+++ b/math/scilab-toolbox-swt/pkg-descr
@@ -14,4 +14,5 @@ Discrete Fast Wavelet Transform, daubechies wavelets
2-D single level image decomposition and reconstruction
2-D multi-level image decomposition and reconstruction.
-WWW: http://scwt.sourceforge.net
+WWW: http://scwt.sourceforge.net
+WWW: http://atoms.scilab.org/toolboxes/swt
diff --git a/math/scilab-toolbox-swt/pkg-message b/math/scilab-toolbox-swt/pkg-message
deleted file mode 100644
index ce41273491c5..000000000000
--- a/math/scilab-toolbox-swt/pkg-message
+++ /dev/null
@@ -1,5 +0,0 @@
-
-===========================================================
-NOTE: SWT should be recompiled whenever Scilab is upgraded.
-===========================================================
-
diff --git a/math/scilab-toolbox-swt/pkg-plist b/math/scilab-toolbox-swt/pkg-plist
index 1a6bff6c73be..0d8ae7c2331c 100644
--- a/math/scilab-toolbox-swt/pkg-plist
+++ b/math/scilab-toolbox-swt/pkg-plist
@@ -1,118 +1,67 @@
-%%TOOLBOXDIR%%/builder.sce
+%%TOOLBOXDIR%%/demos/cowt1d.sce
+%%TOOLBOXDIR%%/demos/cowt2d.sce
+%%TOOLBOXDIR%%/demos/cwt.sce
+%%TOOLBOXDIR%%/demos/dwtmode.dem.sce
%%TOOLBOXDIR%%/demos/image.sce
-%%TOOLBOXDIR%%/demos/swt.dem
+%%TOOLBOXDIR%%/demos/image/woman.bmp
+%%TOOLBOXDIR%%/demos/rwt.sce
+%%TOOLBOXDIR%%/demos/scale2freq.dem.sce
+%%TOOLBOXDIR%%/demos/swt.dem.gateway.sce
%%TOOLBOXDIR%%/demos/swt1d.sce
%%TOOLBOXDIR%%/demos/swt2d.sce
-%%TOOLBOXDIR%%/image/woman.bmp
-%%TOOLBOXDIR%%/lib/libswt-0.1.0-rc4.so
-%%TOOLBOXDIR%%/lib/libswt-0.1.0-rc4.so.0
-%%TOOLBOXDIR%%/lib/libswt.la
-%%TOOLBOXDIR%%/lib/libswt.so
+%%TOOLBOXDIR%%/demos/swt3d.sce
+%%TOOLBOXDIR%%/demos/swtswt.sce
+%%TOOLBOXDIR%%/demos/wavedec.dem.sce
+%%TOOLBOXDIR%%/demos/wden.dem.sce
+%%TOOLBOXDIR%%/etc/swt.quit
+%%TOOLBOXDIR%%/etc/swt.start
%%TOOLBOXDIR%%/loader.sce
-%%TOOLBOXDIR%%/loader_include.sce
-%%TOOLBOXDIR%%/man/appcoef.htm
-%%TOOLBOXDIR%%/man/appcoef.xml
-%%TOOLBOXDIR%%/man/appcoef2.htm
-%%TOOLBOXDIR%%/man/appcoef2.xml
-%%TOOLBOXDIR%%/man/biorfilt.htm
-%%TOOLBOXDIR%%/man/biorfilt.xml
-%%TOOLBOXDIR%%/man/biorwavf.htm
-%%TOOLBOXDIR%%/man/biorwavf.xml
-%%TOOLBOXDIR%%/man/coifwavf.htm
-%%TOOLBOXDIR%%/man/coifwavf.xml
-%%TOOLBOXDIR%%/man/conv.htm
-%%TOOLBOXDIR%%/man/conv.xml
-%%TOOLBOXDIR%%/man/dbwavf.htm
-%%TOOLBOXDIR%%/man/dbwavf.xml
-%%TOOLBOXDIR%%/man/detcoef.htm
-%%TOOLBOXDIR%%/man/detcoef.xml
-%%TOOLBOXDIR%%/man/detcoef2.htm
-%%TOOLBOXDIR%%/man/detcoef2.xml
-%%TOOLBOXDIR%%/man/dwt.htm
-%%TOOLBOXDIR%%/man/dwt.xml
-%%TOOLBOXDIR%%/man/dwt2.htm
-%%TOOLBOXDIR%%/man/dwt2.xml
-%%TOOLBOXDIR%%/man/dwtmode.htm
-%%TOOLBOXDIR%%/man/dwtmode.xml
-%%TOOLBOXDIR%%/man/dyaddown.htm
-%%TOOLBOXDIR%%/man/dyaddown.xml
-%%TOOLBOXDIR%%/man/dyadup.htm
-%%TOOLBOXDIR%%/man/dyadup.xml
-%%TOOLBOXDIR%%/man/idwt.htm
-%%TOOLBOXDIR%%/man/idwt.xml
-%%TOOLBOXDIR%%/man/idwt2.htm
-%%TOOLBOXDIR%%/man/idwt2.xml
-%%TOOLBOXDIR%%/man/orthfilt.htm
-%%TOOLBOXDIR%%/man/orthfilt.xml
-%%TOOLBOXDIR%%/man/qmf.htm
-%%TOOLBOXDIR%%/man/qmf.xml
-%%TOOLBOXDIR%%/man/symwavf.htm
-%%TOOLBOXDIR%%/man/symwavf.xml
-%%TOOLBOXDIR%%/man/upcoef.htm
-%%TOOLBOXDIR%%/man/upcoef.xml
-%%TOOLBOXDIR%%/man/upcoef2.htm
-%%TOOLBOXDIR%%/man/upcoef2.xml
-%%TOOLBOXDIR%%/man/upwlev.htm
-%%TOOLBOXDIR%%/man/upwlev.xml
-%%TOOLBOXDIR%%/man/upwlev2.htm
-%%TOOLBOXDIR%%/man/upwlev2.xml
-%%TOOLBOXDIR%%/man/wavedec.htm
-%%TOOLBOXDIR%%/man/wavedec.xml
-%%TOOLBOXDIR%%/man/wavedec2.htm
-%%TOOLBOXDIR%%/man/wavedec2.xml
-%%TOOLBOXDIR%%/man/waverec.htm
-%%TOOLBOXDIR%%/man/waverec.xml
-%%TOOLBOXDIR%%/man/waverec2.htm
-%%TOOLBOXDIR%%/man/waverec2.xml
-%%TOOLBOXDIR%%/man/wenergy.htm
-%%TOOLBOXDIR%%/man/wenergy.xml
-%%TOOLBOXDIR%%/man/wenergy2.htm
-%%TOOLBOXDIR%%/man/wenergy2.xml
-%%TOOLBOXDIR%%/man/wextend.htm
-%%TOOLBOXDIR%%/man/wextend.xml
-%%TOOLBOXDIR%%/man/wfilters.htm
-%%TOOLBOXDIR%%/man/wfilters.xml
-%%TOOLBOXDIR%%/man/whatis.htm
-%%TOOLBOXDIR%%/man/wkeep.htm
-%%TOOLBOXDIR%%/man/wkeep.xml
-%%TOOLBOXDIR%%/man/wmaxlev.htm
-%%TOOLBOXDIR%%/man/wmaxlev.xml
-%%TOOLBOXDIR%%/man/wrcoef.htm
-%%TOOLBOXDIR%%/man/wrcoef.xml
-%%TOOLBOXDIR%%/man/wrcoef2.htm
-%%TOOLBOXDIR%%/man/wrcoef2.xml
-%%TOOLBOXDIR%%/man/wrev.htm
-%%TOOLBOXDIR%%/man/wrev.xml
-%%TOOLBOXDIR%%/src/Makefile.am
-%%TOOLBOXDIR%%/src/Makefile.in
-%%TOOLBOXDIR%%/src/bior.c
-%%TOOLBOXDIR%%/src/coiflets.c
-%%TOOLBOXDIR%%/src/daubechies.c
-%%TOOLBOXDIR%%/src/dwt.h
-%%TOOLBOXDIR%%/src/dwt1d.c
-%%TOOLBOXDIR%%/src/dwt1d_int.c
-%%TOOLBOXDIR%%/src/dwt2d.c
-%%TOOLBOXDIR%%/src/dwt2d_int.c
-%%TOOLBOXDIR%%/src/dwt_int.c
-%%TOOLBOXDIR%%/src/dwt_validate.c
-%%TOOLBOXDIR%%/src/haar.c
-%%TOOLBOXDIR%%/src/libswt.c
-%%TOOLBOXDIR%%/src/swt_common.h
-%%TOOLBOXDIR%%/src/symlets.c
-%%TOOLBOXDIR%%/src/utility.c
-%%TOOLBOXDIR%%/src/utility_int.c
-%%TOOLBOXDIR%%/src/utility_validate.c
-%%TOOLBOXDIR%%/src/validate.c
-%%TOOLBOXDIR%%/test/Data.mat
-%%TOOLBOXDIR%%/test/dwt1d_test.sce
-%%TOOLBOXDIR%%/test/dwt2d_test.sce
-%%TOOLBOXDIR%%/test/dwt2d_test2.sce
-%%TOOLBOXDIR%%/test/filter_test.sce
-%%TOOLBOXDIR%%/test/utility_test.sce
-@dirrm %%TOOLBOXDIR%%/test
-@dirrm %%TOOLBOXDIR%%/src
-@dirrm %%TOOLBOXDIR%%/man
-@dirrm %%TOOLBOXDIR%%/lib
-@dirrm %%TOOLBOXDIR%%/image
+%%TOOLBOXDIR%%/macros/ShapeAsRow.bin
+%%TOOLBOXDIR%%/macros/ShapeAsRow.sci
+%%TOOLBOXDIR%%/macros/buildmacros.sce
+%%TOOLBOXDIR%%/macros/centfrq.bin
+%%TOOLBOXDIR%%/macros/centfrq.sci
+%%TOOLBOXDIR%%/macros/cwt_wavelab.bin
+%%TOOLBOXDIR%%/macros/cwt_wavelab.sci
+%%TOOLBOXDIR%%/macros/cwtplot.bin
+%%TOOLBOXDIR%%/macros/cwtplot.sci
+%%TOOLBOXDIR%%/macros/ddencmp.bin
+%%TOOLBOXDIR%%/macros/ddencmp.sci
+%%TOOLBOXDIR%%/macros/lib
+%%TOOLBOXDIR%%/macros/lshift.bin
+%%TOOLBOXDIR%%/macros/lshift.sci
+%%TOOLBOXDIR%%/macros/mm_rwt.bin
+%%TOOLBOXDIR%%/macros/mm_rwt.sci
+%%TOOLBOXDIR%%/macros/names
+%%TOOLBOXDIR%%/macros/rshift.bin
+%%TOOLBOXDIR%%/macros/rshift.sci
+%%TOOLBOXDIR%%/macros/rwt.bin
+%%TOOLBOXDIR%%/macros/rwt.sci
+%%TOOLBOXDIR%%/macros/scal2frq.bin
+%%TOOLBOXDIR%%/macros/scal2frq.sci
+%%TOOLBOXDIR%%/macros/thselect.bin
+%%TOOLBOXDIR%%/macros/thselect.sci
+%%TOOLBOXDIR%%/macros/wavedecplot.bin
+%%TOOLBOXDIR%%/macros/wavedecplot.sci
+%%TOOLBOXDIR%%/macros/wden.bin
+%%TOOLBOXDIR%%/macros/wden.sci
+%%TOOLBOXDIR%%/macros/wentropy.bin
+%%TOOLBOXDIR%%/macros/wentropy.sci
+%%TOOLBOXDIR%%/macros/wnoise.bin
+%%TOOLBOXDIR%%/macros/wnoise.sci
+%%TOOLBOXDIR%%/macros/wnoisest.bin
+%%TOOLBOXDIR%%/macros/wnoisest.sci
+%%TOOLBOXDIR%%/macros/wthresh.bin
+%%TOOLBOXDIR%%/macros/wthresh.sci
+%%TOOLBOXDIR%%/macros/wtmm.bin
+%%TOOLBOXDIR%%/macros/wtmm.sci
+%%TOOLBOXDIR%%/sci_gateway/c/libswt_c.so
+%%TOOLBOXDIR%%/sci_gateway/c/loader.sce
+%%TOOLBOXDIR%%/sci_gateway/loader_gateway.sce
+@dirrm %%TOOLBOXDIR%%/sci_gateway/c
+@dirrm %%TOOLBOXDIR%%/sci_gateway
+@dirrm %%TOOLBOXDIR%%/macros
+@dirrm %%TOOLBOXDIR%%/etc
+@dirrm %%TOOLBOXDIR%%/demos/image
@dirrm %%TOOLBOXDIR%%/demos
@dirrm %%TOOLBOXDIR%%