aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2004-02-01 06:55:14 +0000
committerMaho Nakata <maho@FreeBSD.org>2004-02-01 06:55:14 +0000
commitc70d1984b9eff3cc148a0f262874f5efb0bbbd15 (patch)
treed482a89eeb05e2a4f6a6ade0073dbf99a6d047bc /math
parenta46465c6067845d06b1f0fccc124e07dba3ba996 (diff)
downloadports-c70d1984b9eff3cc148a0f262874f5efb0bbbd15.tar.gz
ports-c70d1984b9eff3cc148a0f262874f5efb0bbbd15.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/atlas-devel/Makefile31
-rw-r--r--math/atlas-devel/files/answer10
2 files changed, 19 insertions, 22 deletions
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index 166dfaab5ba1..80a0be633dba 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -13,6 +13,7 @@ PORTVERSION= 3.6.0
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= math-atlas
+PKGNAMESUFFIX= -devel
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= maho@FreeBSD.org
@@ -22,7 +23,6 @@ USE_BZIP2= yes
WRKSRC= ${WRKDIR}/ATLAS
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-PKGNAMESUFFIX= -devel
NO_PACKAGE= runtime performance heavily depends on building environment
.include <bsd.port.pre.mk>
@@ -59,20 +59,27 @@ PICFLAG=-fpic
.endif
.endif
+ANSWER_i386?= ${PRINTF} "\n\n\n\n\n\n\n\n\n\n"
+ANSWER_ia64?= ${PRINTF} "\n\n\n2\n\n\n\n\nf77\n-O2 -static\n\n"
+
+.if !defined(ANSWER_${ARCH})
+ANSWER= ${ANSWER_i386}
+.else
+ANSWER= ${ANSWER_${ARCH}}
+.endif
+
do-configure:
- @(cd ${WRKSRC}; ${MAKE_ENV} ${MAKE} xconfig ; \
- ./xconfig -N 1 -c ${CC} -f ${FC} -a NON_THREADED < ${FILESDIR}/answer)
- @(cd ${WRKSRC}; ${MAKE_ENV} ${MAKE} xconfig ; \
- ./xconfig -N 1 -c ${CC} -f ${FC} -a NON_THREADED_PIC \
+ @(cd ${WRKSRC}; ${MAKE_ENV} ${MAKE} xconfig && \
+ ${ANSWER} | ./xconfig -N 1 -c ${CC} -f ${FC} -a NON_THREADED && \
+ ${ANSWER} | ./xconfig -N 1 -c ${CC} -f ${FC} -a NON_THREADED_PIC \
-F c '${PICFLAG} -DPIC' -F f '${PICFLAG} -DPIC' \
- -F m '${PICFLAG} -DPIC' -F x '${PICFLAG} -DPIC' < ${FILESDIR}/answer)
- @(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/thread-patch)
- @(cd ${WRKSRC}; ${MAKE_ENV} ${MAKE} xconfig ; \
- ./xconfig -c ${CC} -f ${FC} -a THREADED < ${FILESDIR}/answer)
- @(cd ${WRKSRC}; ${MAKE_ENV} ${MAKE} xconfig ; \
- ./xconfig -c ${CC} -f ${FC} -a THREADED_PIC \
+ -F m '${PICFLAG} -DPIC' -F x '${PICFLAG} -DPIC')
+ @(cd ${WRKSRC}; ${PATCH} < ${FILESDIR}/thread-patch && \
+ ${MAKE_ENV} ${MAKE} xconfig && \
+ ${ANSWER} | ./xconfig -c ${CC} -f ${FC} -a THREADED && \
+ ${ANSWER} | ./xconfig -c ${CC} -f ${FC} -a THREADED_PIC \
-F c '${PICFLAG} -DPIC' -F f '${PICFLAG} -DPIC' \
- -F m '${PICFLAG} -DPIC' -F x '${PICFLAG} -DPIC' < ${FILESDIR}/answer)
+ -F m '${PICFLAG} -DPIC' -F x '${PICFLAG} -DPIC' )
ATLAS_LIBS1=libalapack libatlas libcblas libf77blas libtstatlas
ATLAS_LIBS2=libptcblas libptf77blas
diff --git a/math/atlas-devel/files/answer b/math/atlas-devel/files/answer
deleted file mode 100644
index 584ba8795fb2..000000000000
--- a/math/atlas-devel/files/answer
+++ /dev/null
@@ -1,10 +0,0 @@
-
-
-
-
-
-
-
-
-
-