aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-10-19 15:57:27 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-10-19 15:57:27 +0000
commit0ea52f99b465b681e2a4bf7c44a8f7093f40fc68 (patch)
tree7d99a8b7b1226b2da14c7c6d04800d30a417873e /math
parent24055ead515d6e00a9aaf5c651358eb4e8f56300 (diff)
Notes
Diffstat (limited to 'math')
-rw-r--r--math/analitza/Makefile3
-rw-r--r--math/analitza/distinfo4
-rw-r--r--math/analitza/pkg-plist13
-rw-r--r--math/cantor/Makefile14
-rw-r--r--math/cantor/distinfo4
-rw-r--r--math/cantor/pkg-plist16
-rw-r--r--math/kalgebra/Makefile3
-rw-r--r--math/kalgebra/distinfo4
-rw-r--r--math/kalgebra/pkg-plist5
-rw-r--r--math/kbruch/Makefile3
-rw-r--r--math/kbruch/distinfo4
-rw-r--r--math/kbruch/pkg-plist4
-rw-r--r--math/kcalc/Makefile3
-rw-r--r--math/kcalc/distinfo4
-rw-r--r--math/kcalc/pkg-plist2
-rw-r--r--math/kig/Makefile14
-rw-r--r--math/kig/distinfo4
-rw-r--r--math/kig/pkg-plist17
-rw-r--r--math/kmplot/Makefile3
-rw-r--r--math/kmplot/distinfo4
-rw-r--r--math/kmplot/pkg-descr8
-rw-r--r--math/kmplot/pkg-plist3
-rw-r--r--math/rocs/Makefile3
-rw-r--r--math/rocs/distinfo4
-rw-r--r--math/rocs/pkg-plist25
25 files changed, 59 insertions, 112 deletions
diff --git a/math/analitza/Makefile b/math/analitza/Makefile
index 7987e20336dd..f7d5cf723dc6 100644
--- a/math/analitza/Makefile
+++ b/math/analitza/Makefile
@@ -2,7 +2,6 @@
PORTNAME= analitza
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
CATEGORIES= math kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -10,7 +9,7 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Library from KDE Education project
-USE_KDE4= kdehier kdelibs kdeprefix automoc4
+USE_KDE4= kdelibs kdeprefix automoc4
USES= cmake:outsource tar:xz
USE_QT4= corelib gui opengl svg xml \
moc_build qmake_build rcc_build uic_build
diff --git a/math/analitza/distinfo b/math/analitza/distinfo
index 063d51d58654..4e82869d0a4e 100644
--- a/math/analitza/distinfo
+++ b/math/analitza/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.12.5/analitza-4.12.5.tar.xz) = ae9dc37187293c35abd193315069ed8242e589bd862e8a05b24cc4c4a36f864c
-SIZE (KDE/4.12.5/analitza-4.12.5.tar.xz) = 179856
+SHA256 (KDE/4.14.2/analitza-4.14.2.tar.xz) = 55f411ecb0bc0f31e4246e77a33c64b7fcff89db183e50cb348079bd209f432d
+SIZE (KDE/4.14.2/analitza-4.14.2.tar.xz) = 199960
diff --git a/math/analitza/pkg-plist b/math/analitza/pkg-plist
index 24a0bace4df5..1e43512a7fe6 100644
--- a/math/analitza/pkg-plist
+++ b/math/analitza/pkg-plist
@@ -1,13 +1,19 @@
bin/calgebra
+include/analitza/abstractexpressionvisitor.h
include/analitza/abstractlexer.h
include/analitza/analitzaexport.h
include/analitza/analitzautils.h
include/analitza/analyzer.h
+include/analitza/apply.h
include/analitza/builtinmethods.h
+include/analitza/container.h
+include/analitza/customobject.h
include/analitza/expression.h
include/analitza/expressionstream.h
include/analitza/expressiontype.h
include/analitza/importqobjectmetatype.h
+include/analitza/list.h
+include/analitza/matrix.h
include/analitza/object.h
include/analitza/operations.h
include/analitza/operator.h
@@ -50,10 +56,3 @@ share/apps/libanalitza/plots/3Ds.plots
share/apps/libanalitza/plots/basic_curves.plots
share/apps/libanalitza/plots/conics.plots
share/apps/libanalitza/plots/polar.plots
-@dirrm share/apps/libanalitza/plots
-@dirrm share/apps/libanalitza
-@dirrm lib/cmake/analitza
-@dirrmtry lib/cmake
-@dirrm include/analitzaplot
-@dirrm include/analitzagui
-@dirrm include/analitza
diff --git a/math/cantor/Makefile b/math/cantor/Makefile
index 009c9cdfe95f..82994c1c7230 100644
--- a/math/cantor/Makefile
+++ b/math/cantor/Makefile
@@ -2,7 +2,6 @@
PORTNAME= cantor
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
CATEGORIES= math kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -14,14 +13,17 @@ LIB_DEPENDS= libspectre.so:${PORTSDIR}/print/libspectre \
libqalculate.so:${PORTSDIR}/math/libqalculate \
libanalitza.so:${PORTSDIR}/math/analitza
-USE_KDE4= kdehier kdelibs kdeprefix automoc4
+USE_KDE4= kdelibs kdeprefix automoc4
USES= cmake:outsource pkgconfig python:2 tar:xz
USE_QT4= corelib qtestlib_build xml xmlpatterns \
moc_build qmake_build rcc_build uic_build
USE_LDCONFIG= yes
-OPTIONS_DEFINE= MAXIMA OCTAVE R SAGE SCILAB
-OPTIONS_SUB= yes # R
+OPTIONS_DEFINE= LUAJIT MAXIMA OCTAVE R SAGE SCILAB
+OPTIONS_SUB= yes # R LUAJIT
+
+LUAJIT_DESC= Build LuaJIT backend and install LuaJIT
+LUAJIT_LIB_DEPENDS= libluajit-5.1.so:${PORTSDIR}/lang/luajit
MAXIMA_DESC= Install Maxima
MAXIMA_RUN_DEPENDS= maxima:${PORTSDIR}/math/maxima
@@ -42,4 +44,8 @@ SAGE_RUN_DEPENDS= sage:${PORTSDIR}/math/sage
SCILAB_DESC= Install Scilab
SCILAB_RUN_DEPENDS= scilab:${PORTSDIR}/math/scilab
+post-patch:
+ ${REINPLACE_CMD} -e '/FIND_PROGRAM(_GFORTRAN_EXECUTABLE/s,gfortran,${FC},' \
+ ${WRKSRC}/cmake/FindR.cmake
+
.include <bsd.port.mk>
diff --git a/math/cantor/distinfo b/math/cantor/distinfo
index 43fe50832694..9f96a850f933 100644
--- a/math/cantor/distinfo
+++ b/math/cantor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.12.5/cantor-4.12.5.tar.xz) = 6110cf7b17d394f2543b810f0c98b528c91a651c284c427fa9536f797404f85b
-SIZE (KDE/4.12.5/cantor-4.12.5.tar.xz) = 331412
+SHA256 (KDE/4.14.2/cantor-4.14.2.tar.xz) = 885f4c0c884f59c36087349fe41fdb525cf857aab90da5a2fb71f44f13d84915
+SIZE (KDE/4.14.2/cantor-4.14.2.tar.xz) = 341724
diff --git a/math/cantor/pkg-plist b/math/cantor/pkg-plist
index 459a340d1875..3fe8527409ba 100644
--- a/math/cantor/pkg-plist
+++ b/math/cantor/pkg-plist
@@ -27,6 +27,7 @@ lib/kde4/cantor_importpackageassistant.so
lib/kde4/cantor_integrateassistant.so
lib/kde4/cantor_invertmatrixassistant.so
lib/kde4/cantor_kalgebrabackend.so
+%%LUAJIT%%lib/kde4/cantor_luabackend.so
lib/kde4/cantor_maximabackend.so
lib/kde4/cantor_nullbackend.so
lib/kde4/cantor_octavebackend.so
@@ -46,6 +47,7 @@ lib/libcantor_config.so
lib/libcantorlibs.so
lib/libcantorlibs.so.0.0.4
lib/libcantorlibs.so.1
+share/appdata/cantor.appdata.xml
share/applications/kde4/cantor.desktop
share/apps/cantor/cantor_advancedplot_assistant.rc
share/apps/cantor/cantor_create_matrix_assistant.rc
@@ -74,6 +76,8 @@ share/apps/cantor/sagebackend/keywords.xml
share/apps/cantor/xslt/latex.xsl
share/config.kcfg/cantor.kcfg
share/config.kcfg/cantor_libs.kcfg
+share/config.kcfg/kalgebrabackend.kcfg
+%%LUAJIT%%share/config.kcfg/luabackend.kcfg
share/config.kcfg/maximabackend.kcfg
share/config.kcfg/octavebackend.kcfg
share/config.kcfg/python2backend.kcfg
@@ -84,6 +88,7 @@ share/config.kcfg/scilabbackend.kcfg
share/config/cantor.knsrc
share/config/cantor_kalgebra.knsrc
share/config/cantor_maxima.knsrc
+share/config/cantor_python2.knsrc
%%R%%share/config/cantor_r.knsrc
share/config/cantor_sage.knsrc
share/doc/HTML/en/cantor/common
@@ -94,6 +99,7 @@ share/doc/HTML/en/cantor/screenshot.png
share/icons/hicolor/16x16/apps/cantor.png
share/icons/hicolor/32x32/apps/cantor.png
share/icons/hicolor/48x48/apps/cantor.png
+share/icons/hicolor/48x48/apps/luabackend.png
share/icons/hicolor/48x48/apps/maximabackend.png
share/icons/hicolor/48x48/apps/octavebackend.png
share/icons/hicolor/48x48/apps/pythonbackend.png
@@ -112,6 +118,7 @@ share/kde4/services/cantor/importpackageassistant.desktop
share/kde4/services/cantor/integrateassistant.desktop
share/kde4/services/cantor/invertmatrixassistant.desktop
share/kde4/services/cantor/kalgebrabackend.desktop
+%%LUAJIT%%share/kde4/services/cantor/luabackend.desktop
share/kde4/services/cantor/maximabackend.desktop
share/kde4/services/cantor/nullbackend.desktop
share/kde4/services/cantor/octavebackend.desktop
@@ -129,12 +136,3 @@ share/kde4/services/cantor/variablemanagerplugin.desktop
share/kde4/servicetypes/cantor_assistant.desktop
share/kde4/servicetypes/cantor_backend.desktop
share/kde4/servicetypes/cantor_panelplugin.desktop
-@dirrm share/kde4/services/cantor
-@dirrm share/doc/HTML/en/cantor
-@dirrm share/apps/cantor/xslt
-@dirrm share/apps/cantor/sagebackend
-@dirrm share/apps/cantor/python2backend
-@dirrm share/apps/cantor/octavebackend
-@dirrm share/apps/cantor/maximabackend
-@dirrm share/apps/cantor
-@dirrm include/cantor
diff --git a/math/kalgebra/Makefile b/math/kalgebra/Makefile
index 344d8835dc02..85b1a8f65131 100644
--- a/math/kalgebra/Makefile
+++ b/math/kalgebra/Makefile
@@ -2,7 +2,6 @@
PORTNAME= kalgebra
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
CATEGORIES= math kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -14,7 +13,7 @@ LIB_DEPENDS= libanalitza.so:${PORTSDIR}/math/analitza
CMAKE_ARGS= -DBUILD_mobile:BOOL=FALSE
USE_GL= glu
-USE_KDE4= kdehier kdelibs kdeprefix libkdeedu automoc4
+USE_KDE4= kdelibs kdeprefix libkdeedu automoc4
USES= cmake:outsource tar:xz
USE_QT4= corelib declarative gui opengl \
moc_build qmake_build rcc_build uic_build
diff --git a/math/kalgebra/distinfo b/math/kalgebra/distinfo
index f28d9536bbac..9ef0b52c67c6 100644
--- a/math/kalgebra/distinfo
+++ b/math/kalgebra/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.12.5/kalgebra-4.12.5.tar.xz) = c81df077ded8e7dc539287125ede08ef0c081e8d627a88020e8ce7459e9aba42
-SIZE (KDE/4.12.5/kalgebra-4.12.5.tar.xz) = 271276
+SHA256 (KDE/4.14.2/kalgebra-4.14.2.tar.xz) = 58671fd0cf365cd75d303c87e7c88a4a2eeebbb43442e90f3c3e55829e318390
+SIZE (KDE/4.14.2/kalgebra-4.14.2.tar.xz) = 274600
diff --git a/math/kalgebra/pkg-plist b/math/kalgebra/pkg-plist
index 81b8c500e873..018619de4961 100644
--- a/math/kalgebra/pkg-plist
+++ b/math/kalgebra/pkg-plist
@@ -1,5 +1,6 @@
bin/kalgebra
lib/kde4/plasma_applet_kalgebra.so
+share/appdata/kalgebra.appdata.xml
share/applications/kde4/kalgebra.desktop
share/apps/katepart/syntax/kalgebra.xml
share/apps/plasma/plasmoids/org.kde.graphsplasmoid/contents/ui/config.ui
@@ -23,7 +24,3 @@ share/icons/hicolor/64x64/apps/kalgebra.png
share/icons/hicolor/scalable/apps/kalgebra.svgz
share/kde4/services/graphsplasmoid.desktop
share/kde4/services/kalgebraplasmoid.desktop
-@dirrm share/doc/HTML/en/kalgebra
-@dirrm share/apps/plasma/plasmoids/org.kde.graphsplasmoid/contents/ui
-@dirrm share/apps/plasma/plasmoids/org.kde.graphsplasmoid/contents
-@dirrm share/apps/plasma/plasmoids/org.kde.graphsplasmoid
diff --git a/math/kbruch/Makefile b/math/kbruch/Makefile
index 2d924c4f6b41..6c7500fd033b 100644
--- a/math/kbruch/Makefile
+++ b/math/kbruch/Makefile
@@ -2,7 +2,6 @@
PORTNAME= kbruch
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
CATEGORIES= math kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -10,7 +9,7 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 application to exercise fractions
-USE_KDE4= kdehier kdelibs kdeprefix automoc4
+USE_KDE4= kdelibs kdeprefix automoc4
USES= cmake:outsource tar:xz
USE_QT4= moc_build qmake_build rcc_build uic_build
diff --git a/math/kbruch/distinfo b/math/kbruch/distinfo
index ae315d2eb6c8..bd09cc87882c 100644
--- a/math/kbruch/distinfo
+++ b/math/kbruch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.12.5/kbruch-4.12.5.tar.xz) = 8075bb74a162f24ea5e30b0cdb9b98cb235f8034cfe5f8d0642d0c2cf035dce7
-SIZE (KDE/4.12.5/kbruch-4.12.5.tar.xz) = 897872
+SHA256 (KDE/4.14.2/kbruch-4.14.2.tar.xz) = d7e8136f44a031348ea23df008c09a3ea94eb715b7b9126542790598c438ec63
+SIZE (KDE/4.14.2/kbruch-4.14.2.tar.xz) = 902884
diff --git a/math/kbruch/pkg-plist b/math/kbruch/pkg-plist
index 5ed7c8abc6ce..a031dd421bb3 100644
--- a/math/kbruch/pkg-plist
+++ b/math/kbruch/pkg-plist
@@ -1,5 +1,6 @@
bin/kbruch
man/man1/kbruch.1.gz
+share/appdata/kbruch.appdata.xml
share/applications/kde4/kbruch.desktop
share/apps/kbruch/AppMenuWidgetui.rc
share/apps/kbruch/FractionRingWidgetui.rc
@@ -41,6 +42,3 @@ share/icons/hicolor/32x32/apps/kbruch.png
share/icons/hicolor/48x48/apps/kbruch.png
share/icons/hicolor/64x64/apps/kbruch.png
share/icons/hicolor/scalable/apps/kbruch.svgz
-@dirrm share/doc/HTML/en/kbruch
-@dirrm share/apps/kbruch/pics
-@dirrm share/apps/kbruch
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index e2d1110be8b2..b1522abf098b 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -2,7 +2,6 @@
PORTNAME= kcalc
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
CATEGORIES= math kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -13,7 +12,7 @@ COMMENT= Scientific calculator for KDE
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
libmpfr.so:${PORTSDIR}/math/mpfr
-USE_KDE4= kdeprefix kdehier automoc4 kdelibs
+USE_KDE4= kdeprefix automoc4 kdelibs
USES= cmake:outsource tar:xz
USE_QT4= xml qmake_build moc_build rcc_build uic_build
diff --git a/math/kcalc/distinfo b/math/kcalc/distinfo
index 1cf02e163066..417edd4c6215 100644
--- a/math/kcalc/distinfo
+++ b/math/kcalc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.12.5/kcalc-4.12.5.tar.xz) = 2c11745cdc904214f56376dc71cfdea1d78a75393c30963268272edf290b502e
-SIZE (KDE/4.12.5/kcalc-4.12.5.tar.xz) = 80592
+SHA256 (KDE/4.14.2/kcalc-4.14.2.tar.xz) = f72bd196f596cc1d4f3cea93d6ca8e9519f237b24fad18616c590099a42a55db
+SIZE (KDE/4.14.2/kcalc-4.14.2.tar.xz) = 81384
diff --git a/math/kcalc/pkg-plist b/math/kcalc/pkg-plist
index 9dd6b0c7b7cd..70febbb1786c 100644
--- a/math/kcalc/pkg-plist
+++ b/math/kcalc/pkg-plist
@@ -9,5 +9,3 @@ share/doc/HTML/en/kcalc/commands.docbook
share/doc/HTML/en/kcalc/common
share/doc/HTML/en/kcalc/index.cache.bz2
share/doc/HTML/en/kcalc/index.docbook
-@dirrm share/doc/HTML/en/kcalc
-@dirrm share/apps/kcalc
diff --git a/math/kig/Makefile b/math/kig/Makefile
index cc13cd51e2ec..a354ae82f9d4 100644
--- a/math/kig/Makefile
+++ b/math/kig/Makefile
@@ -2,7 +2,6 @@
PORTNAME= kig
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
CATEGORIES= math kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -10,15 +9,10 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 interactive geometry application
-USE_KDE4= kdehier kdelibs kdeprefix automoc4
-USES= cmake:outsource tar:xz
-USE_QT4= gui xml moc_build qmake_build rcc_build uic_build
-
-OPTIONS_DEFINE= PYTHON
-OPTIONS_DEFAULT= PYTHON
-OPTIONS_SUB= yes
+LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
-PYTHON_DESC= Support for Python scripting (requires Boost)
-PYTHON_LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
+USE_KDE4= kdelibs kdeprefix automoc4
+USES= cmake:outsource compiler:c++11-lib tar:xz
+USE_QT4= gui xml moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/math/kig/distinfo b/math/kig/distinfo
index 46a0c8e43ff8..144470a1a791 100644
--- a/math/kig/distinfo
+++ b/math/kig/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.12.5/kig-4.12.5.tar.xz) = cf78a966d4c569b2e2a77c60798b80fac14f495b79c8e750fc3c3fae582c9db4
-SIZE (KDE/4.12.5/kig-4.12.5.tar.xz) = 1502908
+SHA256 (KDE/4.14.2/kig-4.14.2.tar.xz) = b5332f60aba33fdbedc6dd980bd8f07d503ce1a5aa2c832263e39f75872005f2
+SIZE (KDE/4.14.2/kig-4.14.2.tar.xz) = 1506456
diff --git a/math/kig/pkg-plist b/math/kig/pkg-plist
index fcee4f22ec6e..606efabf73a1 100644
--- a/math/kig/pkg-plist
+++ b/math/kig/pkg-plist
@@ -2,14 +2,14 @@ bin/kig
bin/pykig.py
lib/kde4/kigpart.so
man/man1/kig.1.gz
+share/appdata/kig.appdata.xml
share/applications/kde4/kig.desktop
-%%PYTHON%%share/apps/katepart/syntax/python-kig.xml
+share/apps/katepart/syntax/python-kig.xml
share/apps/kig/builtin-macros/circle_by_center_and_line.kigt
share/apps/kig/builtin-macros/circle_by_point_and_diameter.kigt
share/apps/kig/builtin-macros/equitriangle.kigt
share/apps/kig/builtin-macros/evolute.kigt
share/apps/kig/builtin-macros/osculating_circle.kigt
-share/apps/kig/builtin-macros/segment_axis.kigt
share/apps/kig/builtin-macros/square.kigt
share/apps/kig/builtin-macros/vector_difference.kigt
share/apps/kig/icons/hicolor/16x16/actions/kig_xfig.png
@@ -324,16 +324,3 @@ share/icons/hicolor/64x64/mimetypes/application-x-kig.png
share/icons/hicolor/scalable/apps/kig.svgz
share/icons/hicolor/scalable/mimetypes/application-x-kig.svgz
share/kde4/services/kig_part.desktop
-@dirrm share/doc/HTML/en/kig
-@dirrm share/apps/kig/icons/hicolor/scalable/actions
-@dirrm share/apps/kig/icons/hicolor/scalable
-@dirrm share/apps/kig/icons/hicolor/32x32/actions
-@dirrm share/apps/kig/icons/hicolor/32x32
-@dirrm share/apps/kig/icons/hicolor/22x22/actions
-@dirrm share/apps/kig/icons/hicolor/22x22
-@dirrm share/apps/kig/icons/hicolor/16x16/actions
-@dirrm share/apps/kig/icons/hicolor/16x16
-@dirrm share/apps/kig/icons/hicolor
-@dirrm share/apps/kig/icons
-@dirrm share/apps/kig/builtin-macros
-@dirrm share/apps/kig
diff --git a/math/kmplot/Makefile b/math/kmplot/Makefile
index c44133072e85..499afc91798a 100644
--- a/math/kmplot/Makefile
+++ b/math/kmplot/Makefile
@@ -2,7 +2,6 @@
PORTNAME= kmplot
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
CATEGORIES= math kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -10,7 +9,7 @@ DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Mathematical function plotter for KDE 4
-USE_KDE4= kdehier kdelibs kdeprefix automoc4
+USE_KDE4= kdelibs kdeprefix automoc4
USES= cmake:outsource tar:xz
USE_QT4= xml moc_build qmake_build rcc_build uic_build
diff --git a/math/kmplot/distinfo b/math/kmplot/distinfo
index 51fc62464399..fe659d914367 100644
--- a/math/kmplot/distinfo
+++ b/math/kmplot/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.12.5/kmplot-4.12.5.tar.xz) = 3ba614e22bf88989fd0647bd9d1759bbdc2ea6c405d881a7ac0a932233d5d5f3
-SIZE (KDE/4.12.5/kmplot-4.12.5.tar.xz) = 654816
+SHA256 (KDE/4.14.2/kmplot-4.14.2.tar.xz) = b36d9479c15f429504d302112eb6ae65bf1ad194864553fcaa35257e08c51c86
+SIZE (KDE/4.14.2/kmplot-4.14.2.tar.xz) = 659964
diff --git a/math/kmplot/pkg-descr b/math/kmplot/pkg-descr
index c7a6a9395324..a41ca4b628a0 100644
--- a/math/kmplot/pkg-descr
+++ b/math/kmplot/pkg-descr
@@ -3,7 +3,7 @@ supports different systems of coordinates like the cartesian or the
polar coordinate system. The graphs can be colorized and the view is
scalable, so that you are able to zoom to the level you need.
-FEATURES
+Features:
- Powerful mathematical parser.
- Precise metric printing.
- Different plot types: cartesian, parametric, polar, implicit,
@@ -18,8 +18,8 @@ FEATURES
- Ability to draw the 1st and 2nd derivative and the integral of a
plot function.
- Supports user defined constants and parameter values.
-- Various tools for plot functions.
-- Find minimum/maximum point.
-- Get y-value and draw the area between the function and the y-axis.
+- Various tools for plot functions:
+ - Find minimum/maximum point.
+ - Get y-value and draw the area between the function and the y-axis.
WWW: http://www.kde.org/applications/education/kmplot
diff --git a/math/kmplot/pkg-plist b/math/kmplot/pkg-plist
index 7a662c7ef98b..bfd246cd3fbb 100644
--- a/math/kmplot/pkg-plist
+++ b/math/kmplot/pkg-plist
@@ -1,6 +1,7 @@
bin/kmplot
lib/kde4/libkmplotpart.so
man/man1/kmplot.1.gz
+share/appdata/kmplot.appdata.xml
share/applications/kde4/kmplot.desktop
share/apps/kmplot/kmplot_part.rc
share/apps/kmplot/kmplot_part_readonly.rc
@@ -46,5 +47,3 @@ share/icons/hicolor/48x48/apps/kmplot.png
share/icons/hicolor/64x64/apps/kmplot.png
share/icons/hicolor/scalable/apps/kmplot.svgz
share/kde4/services/kmplot_part.desktop
-@dirrm share/doc/HTML/en/kmplot
-@dirrm share/apps/kmplot
diff --git a/math/rocs/Makefile b/math/rocs/Makefile
index beb18f9bdbfe..6e1cdd96251d 100644
--- a/math/rocs/Makefile
+++ b/math/rocs/Makefile
@@ -2,7 +2,6 @@
PORTNAME= rocs
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 2
CATEGORIES= math kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -13,7 +12,7 @@ COMMENT= KDE Graph theory IDE
LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libgrantlee_gui.so:${PORTSDIR}/devel/grantlee
-USE_KDE4= kdehier kdelibs kdeprefix automoc4
+USE_KDE4= kdelibs kdeprefix automoc4
USES= cmake:outsource tar:xz
USE_QT4= gui qtestlib script scripttools webkit xml \
moc_build qmake_build rcc_build uic_build
diff --git a/math/rocs/distinfo b/math/rocs/distinfo
index 543dd2c4c05a..328c2913c695 100644
--- a/math/rocs/distinfo
+++ b/math/rocs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.12.5/rocs-4.12.5.tar.xz) = 4875f7108d5f417e8e19f2ae6b16ea1e533ff270cbe665a6e6b50ecf4d06f5b8
-SIZE (KDE/4.12.5/rocs-4.12.5.tar.xz) = 1143184
+SHA256 (KDE/4.14.2/rocs-4.14.2.tar.xz) = fe177a0084b41e687a8db382817362808765419d346b07efce648cb0b93f2f76
+SIZE (KDE/4.14.2/rocs-4.14.2.tar.xz) = 1146388
diff --git a/math/rocs/pkg-plist b/math/rocs/pkg-plist
index 1b944ab09f7c..a26454f248e9 100644
--- a/math/rocs/pkg-plist
+++ b/math/rocs/pkg-plist
@@ -31,6 +31,7 @@ lib/librocscore.so.%%KDE4_GENERIC_LIB_VERSION%%
lib/librocsvisualeditor.so
lib/librocsvisualeditor.so.4
lib/librocsvisualeditor.so.%%KDE4_GENERIC_LIB_VERSION%%
+share/appdata/rocs.appdata.xml
share/applications/kde4/rocs.desktop
share/apps/rocs/engineapi/Console.xml
share/apps/rocs/engineapi/Data.xml
@@ -173,27 +174,3 @@ share/kde4/services/rocs_transformedgesplugin.desktop
share/kde4/servicetypes/RocsDataStructurePlugin.desktop
share/kde4/servicetypes/RocsGraphFilePlugin.desktop
share/kde4/servicetypes/RocsToolsPlugin.desktop
-@dirrm share/doc/HTML/en/rocs
-@dirrm share/apps/rocs_rootedtree
-@dirrm share/apps/rocs/schemes
-@dirrm share/apps/rocs/plugin/apidoc
-@dirrm share/apps/rocs/plugin
-@dirrm share/apps/rocs/icons/hicolor/scalable/actions
-@dirrm share/apps/rocs/icons/hicolor/scalable
-@dirrm share/apps/rocs/icons/hicolor/64x64/actions
-@dirrm share/apps/rocs/icons/hicolor/64x64
-@dirrm share/apps/rocs/icons/hicolor/48x48/actions
-@dirrm share/apps/rocs/icons/hicolor/48x48
-@dirrm share/apps/rocs/icons/hicolor/32x32/actions
-@dirrm share/apps/rocs/icons/hicolor/32x32
-@dirrm share/apps/rocs/icons/hicolor/22x22/actions
-@dirrm share/apps/rocs/icons/hicolor/22x22
-@dirrm share/apps/rocs/icons/hicolor/16x16/actions
-@dirrm share/apps/rocs/icons/hicolor/16x16
-@dirrm share/apps/rocs/icons/hicolor
-@dirrm share/apps/rocs/icons
-@dirrm share/apps/rocs/iconpacks
-@dirrm share/apps/rocs/examples
-@dirrm share/apps/rocs/engineapi
-@dirrm share/apps/rocs
-@dirrm include/rocs