aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-01-12 20:37:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-01-12 20:37:24 +0000
commit338161958384cbdb221973b01a11d82931076f0c (patch)
tree9ad64d1ef4f015567812cf7538b084e6df860f1d /math
parent5b5364a3685860b6cb82a872a7e838bc9dc7c044 (diff)
downloadports-338161958384cbdb221973b01a11d82931076f0c.tar.gz
ports-338161958384cbdb221973b01a11d82931076f0c.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/PDL/Makefile4
-rw-r--r--math/asymptote/Makefile4
-rw-r--r--math/freefem++/Makefile4
-rw-r--r--math/labplot/Makefile3
-rw-r--r--math/octave-forge-gsl/Makefile3
-rw-r--r--math/orpie/Makefile3
-rw-r--r--math/p5-Math-GSL/Makefile3
-rw-r--r--math/py-gsl/Makefile3
-rw-r--r--math/qtiplot/Makefile3
-rw-r--r--math/ruby-gsl/Makefile3
-rw-r--r--math/yacas/Makefile4
11 files changed, 22 insertions, 15 deletions
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index d5010d6d0aed..3704ecfe3a42 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -8,7 +8,7 @@
PORTNAME= PDL
PORTVERSION= 2.4.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:S/$/:cpan/} \
${MASTER_SITE_SOURCEFORGE:S/$/:sf/}
@@ -28,7 +28,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
${SITE_PERL}/Term/ReadLine/readline.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
LIB_DEPENDS= plplotd.11:${PORTSDIR}/math/plplot \
fftw.2:${PORTSDIR}/math/fftw \
- gsl.12:${PORTSDIR}/math/gsl
+ gsl.13:${PORTSDIR}/math/gsl
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GL= yes
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 5b9f6fdac0c8..d5e8a982c74f 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asymptote
PORTVERSION= 1.44
-#PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -50,7 +50,7 @@ ALL_TARGET= asy
INSTALL_TARGET= install-asy
.if defined(WITH_GSL)
-LIB_DEPENDS+= gsl.12:${PORTSDIR}/math/gsl
+LIB_DEPENDS+= gsl.13:${PORTSDIR}/math/gsl
.endif
# Documentation
diff --git a/math/freefem++/Makefile b/math/freefem++/Makefile
index 4e29a0dae3ed..77a9fe231112 100644
--- a/math/freefem++/Makefile
+++ b/math/freefem++/Makefile
@@ -7,7 +7,7 @@
PORTNAME= freefem++
DISTVERSION= 2.24-2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math science
MASTER_SITES= http://www.freefem.org/ff++/ftp/
@@ -18,7 +18,7 @@ LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk-threads \
fftw3.4:${PORTSDIR}/math/fftw3 \
umfpack.1:${PORTSDIR}/math/suitesparse \
arpack.1:${PORTSDIR}/math/arpack \
- gsl.12:${PORTSDIR}/math/gsl
+ gsl.13:${PORTSDIR}/math/gsl
BUILD_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
dvips:${PORTSDIR}/print/dvipsk-tetex \
pdflatex:${PORTSDIR}/print/teTeX-base
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index bcd581b9dd2c..13eb805e9b6a 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= LabPlot
PORTVERSION= 1.6.0.2
+PORTREVISION= 1
CATEGORIES= math kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=labplot
@@ -17,7 +18,7 @@ COMMENT= LabPlot : Data analysis and visualisation
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
jasper.4:${PORTSDIR}/graphics/jasper \
MagickWand.1:${PORTSDIR}/graphics/ImageMagick \
- gsl.12:${PORTSDIR}/math/gsl \
+ gsl.13:${PORTSDIR}/math/gsl \
fftw3.4:${PORTSDIR}/math/fftw3 \
qwtplot3d.0:${PORTSDIR}/math/qwtplot3d \
origin.0:${PORTSDIR}/math/liborigin
diff --git a/math/octave-forge-gsl/Makefile b/math/octave-forge-gsl/Makefile
index 4c78dcca7847..a9e8dbfd43ba 100644
--- a/math/octave-forge-gsl/Makefile
+++ b/math/octave-forge-gsl/Makefile
@@ -7,12 +7,13 @@
PORTNAME= octave-forge-gsl
PORTVERSION= 1.0.7
+PORTREVISION= 1
CATEGORIES= math
MAINTAINER= stephen@math.missouri.edu
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl
post-patch:
@${REINPLACE_CMD} s+/bin/bash+/usr/local/bin/bash+g ${WRKSRC}/src/config*
diff --git a/math/orpie/Makefile b/math/orpie/Makefile
index fb14b9abf820..8d88ba0c6aa0 100644
--- a/math/orpie/Makefile
+++ b/math/orpie/Makefile
@@ -7,6 +7,7 @@
PORTNAME= orpie
PORTVERSION= 1.5.1
+PORTREVISION= 1
CATEGORIES+= math
MASTER_SITES= http://pessimization.com/software/orpie/
@@ -14,7 +15,7 @@ MAINTAINER= dylan@dylex.net
COMMENT= A fullscreen RPN calculator for the console
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/math/p5-Math-GSL/Makefile b/math/p5-Math-GSL/Makefile
index 1e0bf5b988c0..052a55e43374 100644
--- a/math/p5-Math-GSL/Makefile
+++ b/math/p5-Math-GSL/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Math-GSL
PORTVERSION= 0.16
+PORTREVISION= 1
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -17,7 +18,7 @@ COMMENT= A perl interface to GNU Scientific Library
BUILD_DEPENDS= ${SITE_PERL}/ExtUtils/PkgConfig.pm:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
${SITE_PERL}/Test/Class.pm:${PORTSDIR}/devel/p5-Test-Class
-LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl
ONLY_FOR_ARCHS= i386
diff --git a/math/py-gsl/Makefile b/math/py-gsl/Makefile
index 07ec78bb7607..af6aae4506f1 100644
--- a/math/py-gsl/Makefile
+++ b/math/py-gsl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gsl
PORTVERSION= 0.9.4
+PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= SF
MASTER_SITE_SUBDIR= pygsl
@@ -19,7 +20,7 @@ COMMENT= Python interface to GNU Scientific Library
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/include/numpy/arrayobject.h:${PORTSDIR}/math/py-numpy
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/__init__.py:${PORTSDIR}/math/py-numpy
-LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g}
USE_PYTHON= yes
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 486c5e012d4c..e62ec585f6d9 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qtiplot
DISTVERSION= 0.9.7.2
+PORTREVISION= 1
CATEGORIES= math science
MASTER_SITES= BERLIOS http://soft.proindependent.com/src/
@@ -15,7 +16,7 @@ COMMENT= An Origin clone for data analysis and scientific plotting
BUILD_DEPENDS= ${LOCALBASE}/lib/libmuparser.a:${PORTSDIR}/math/muparser \
${LOCALBASE}/lib/libboost_date_time.a:${PORTSDIR}/devel/boost
-LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl \
+LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl \
qwtplot3d-qt4:${PORTSDIR}/math/qwtplot3d-qt4 \
qwt.5:${PORTSDIR}/x11-toolkits/qwt5
diff --git a/math/ruby-gsl/Makefile b/math/ruby-gsl/Makefile
index 93aa478c4a4d..a61844787869 100644
--- a/math/ruby-gsl/Makefile
+++ b/math/ruby-gsl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gsl
PORTVERSION= 1.10.3
+PORTREVISION= 1
CATEGORIES= math ruby
MASTER_SITES= RF
MASTER_SITE_SUBDIR= rb-${PORTNAME}
@@ -17,7 +18,7 @@ DIST_SUBDIR= ruby
MAINTAINER= clsung@FreeBSD.org
COMMENT= A Ruby extension library for GSL (GNU Scientific Library)
-LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl
USE_RUBY= yes
USE_RUBY_SETUP= yes
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index 76b10dfa51a5..8838ef23fa8f 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -8,14 +8,14 @@
PORTNAME= yacas
PORTVERSION= 1.0.61
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= http://yacas.sourceforge.net/backups/
MAINTAINER= shaun@FreeBSD.org
COMMENT= Yet Another Computer Algebra System
-LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl
USE_AUTOTOOLS= libtool:15
USE_PERL5_BUILD= yes