aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2014-05-15 13:41:18 +0000
committerDiane Bruce <db@FreeBSD.org>2014-05-15 13:41:18 +0000
commit54d5c6006b847add4259f654e2ee180be8f45724 (patch)
tree5eefa763cbd08074e15234b48f129a494171ba70 /math
parent74320b1dbf42de981d6ae6c24c322f5e93382038 (diff)
downloadports-54d5c6006b847add4259f654e2ee180be8f45724.tar.gz
ports-54d5c6006b847add4259f654e2ee180be8f45724.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/py-numpy/Makefile2
-rw-r--r--math/py-numpy/files/patch-numpy-f2py-f2py2e.py6
2 files changed, 4 insertions, 4 deletions
diff --git a/math/py-numpy/Makefile b/math/py-numpy/Makefile
index 984ebbe4afe6..ac3608ffff16 100644
--- a/math/py-numpy/Makefile
+++ b/math/py-numpy/Makefile
@@ -3,7 +3,7 @@
PORTNAME= numpy
PORTVERSION= 1.8.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= math python
MASTER_SITES= http://docs.scipy.org/doc/${DISTNAME:C/\..$/.0/}/:doc \
diff --git a/math/py-numpy/files/patch-numpy-f2py-f2py2e.py b/math/py-numpy/files/patch-numpy-f2py-f2py2e.py
index babaadb0779b..edaa9241330e 100644
--- a/math/py-numpy/files/patch-numpy-f2py-f2py2e.py
+++ b/math/py-numpy/files/patch-numpy-f2py-f2py2e.py
@@ -1,10 +1,10 @@
---- numpy/f2py/f2py2e.py.orig 2012-01-25 06:59:14.651304791 -0600
-+++ numpy/f2py/f2py2e.py 2012-01-25 07:00:58.475075133 -0600
+--- numpy/f2py/f2py2e.py.orig 2013-10-30 13:31:41.000000000 -0500
++++ numpy/f2py/f2py2e.py 2014-04-09 10:23:49.000000000 -0500
@@ -520,6 +520,7 @@
include_dirs, sources = filter_files('-I', '', sources, remove_prefix=1)
library_dirs, sources = filter_files('-L', '', sources, remove_prefix=1)
libraries, sources = filter_files('-l', '', sources, remove_prefix=1)
-+ extra_link_args, sources = filter_files('-Wl,','',sources,remove_prefix=0)
++ extra_link_args, sources = filter_files('-Wl,|-B','',sources,remove_prefix=0)
undef_macros, sources = filter_files('-U', '', sources, remove_prefix=1)
define_macros, sources = filter_files('-D', '', sources, remove_prefix=1)
using_numarray = 0