aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-03-15 20:05:38 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-03-15 20:05:38 +0000
commit59eb42e57befebdce93b5a0555f96a5e5fd5f248 (patch)
tree24c969990d91af5c43f0b461d9f860c70359bb8e /math
parent1dad567b3203731cdf6c3ed1efa09aae7f0cfbb1 (diff)
downloadports-59eb42e57befebdce93b5a0555f96a5e5fd5f248.tar.gz
ports-59eb42e57befebdce93b5a0555f96a5e5fd5f248.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/dune-spgrid/Makefile40
-rw-r--r--math/dune-spgrid/distinfo3
-rw-r--r--math/dune-spgrid/files/patch-CMakeLists.txt12
-rw-r--r--math/dune-spgrid/pkg-descr6
-rw-r--r--math/dune-spgrid/pkg-plist57
6 files changed, 119 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 8c3fb2213203..dfab1c67c106 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -221,6 +221,7 @@
SUBDIR += dune-istl
SUBDIR += dune-localfunctions
SUBDIR += dune-pdelab
+ SUBDIR += dune-spgrid
SUBDIR += dune-typetree
SUBDIR += dune-uggrid
SUBDIR += e
diff --git a/math/dune-spgrid/Makefile b/math/dune-spgrid/Makefile
new file mode 100644
index 000000000000..9febd761789f
--- /dev/null
+++ b/math/dune-spgrid/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= dune-spgrid
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.6.0rc1.20200105
+CATEGORIES= math
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= DUNE framework: A structured, parallel DUNE grid implementation
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+DUNE_DEPENDS= dune-common>0:math/dune-common \
+ dune-grid>0:math/dune-grid \
+ dune-geometry>0:math/dune-geometry
+BUILD_DEPENDS= ${DUNE_DEPENDS} \
+ openmpi>0:net/openmpi \
+ vc>0:devel/vc
+RUN_DEPENDS= ${DUNE_DEPENDS}
+
+USES= cmake compiler:c++17-lang fortran pkgconfig
+USE_GITLAB= yes
+
+GL_SITE= https://gitlab.dune-project.org
+GL_ACCOUNT= extensions
+GL_COMMIT= 3977013bee93d1b113b155cc5b881d28d3ee37f5
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_SUB= yes
+
+DOCS_CMAKE_BOOL= FREEBSD_INSTALL_DOCS
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
+ sphinx-build:textproc/py-sphinx
+
+PORTDOCS= *
+
+.include <bsd.port.mk>
diff --git a/math/dune-spgrid/distinfo b/math/dune-spgrid/distinfo
new file mode 100644
index 000000000000..3727572c819b
--- /dev/null
+++ b/math/dune-spgrid/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1584301518
+SHA256 (extensions-dune-spgrid-3977013bee93d1b113b155cc5b881d28d3ee37f5_GL0.tar.gz) = c978bbde9ae064865d87d7eb49e8c2030400ffd166463932cb3047998e775fc0
+SIZE (extensions-dune-spgrid-3977013bee93d1b113b155cc5b881d28d3ee37f5_GL0.tar.gz) = 71924
diff --git a/math/dune-spgrid/files/patch-CMakeLists.txt b/math/dune-spgrid/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..e5fb4034b247
--- /dev/null
+++ b/math/dune-spgrid/files/patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- CMakeLists.txt.orig 2020-03-15 19:45:36 UTC
++++ CMakeLists.txt
+@@ -9,7 +9,9 @@ include(DuneMacros)
+ dune_project()
+
+ add_subdirectory(cmake/modules)
++if (FREEBSD_INSTALL_DOCS)
+ add_subdirectory(doc)
++endif()
+ add_subdirectory(dune)
+
+ if(dune-python_FOUND)
diff --git a/math/dune-spgrid/pkg-descr b/math/dune-spgrid/pkg-descr
new file mode 100644
index 000000000000..a4440612ca6b
--- /dev/null
+++ b/math/dune-spgrid/pkg-descr
@@ -0,0 +1,6 @@
+dune-spgrid is a module of the DUNE Numerics framework for solving partial
+differential equations (PDEs) with grid-based methods.
+
+dune-spgrid module provides a structured, parallel grid: SPGrid.
+
+WWW: https://www.dune-project.org/
diff --git a/math/dune-spgrid/pkg-plist b/math/dune-spgrid/pkg-plist
new file mode 100644
index 000000000000..98d12988ebe7
--- /dev/null
+++ b/math/dune-spgrid/pkg-plist
@@ -0,0 +1,57 @@
+include/dune/common/iostream.hh
+include/dune/grid/extensions/superentityiterator.hh
+include/dune/grid/spgrid.hh
+include/dune/grid/spgrid/backuprestore.hh
+include/dune/grid/spgrid/boundarysegmentiterator.hh
+include/dune/grid/spgrid/cachedpartitionlist.hh
+include/dune/grid/spgrid/capabilities.hh
+include/dune/grid/spgrid/communication.hh
+include/dune/grid/spgrid/cube.hh
+include/dune/grid/spgrid/declaration.hh
+include/dune/grid/spgrid/decomposition.hh
+include/dune/grid/spgrid/dgfparser.hh
+include/dune/grid/spgrid/direction.hh
+include/dune/grid/spgrid/domain.hh
+include/dune/grid/spgrid/entity.hh
+include/dune/grid/spgrid/entityinfo.hh
+include/dune/grid/spgrid/entityseed.hh
+include/dune/grid/spgrid/fileio.hh
+include/dune/grid/spgrid/geometricgridlevel.hh
+include/dune/grid/spgrid/geometry.hh
+include/dune/grid/spgrid/geometrycache.hh
+include/dune/grid/spgrid/grid.hh
+include/dune/grid/spgrid/gridlevel.hh
+include/dune/grid/spgrid/gridview.hh
+include/dune/grid/spgrid/hierarchiciterator.hh
+include/dune/grid/spgrid/hierarchicsearch.hh
+include/dune/grid/spgrid/hindexset.hh
+include/dune/grid/spgrid/idset.hh
+include/dune/grid/spgrid/indexset.hh
+include/dune/grid/spgrid/intersection.hh
+include/dune/grid/spgrid/intersectioniterator.hh
+include/dune/grid/spgrid/iterator.hh
+include/dune/grid/spgrid/linkage.hh
+include/dune/grid/spgrid/mesh.hh
+include/dune/grid/spgrid/messagebuffer.hh
+include/dune/grid/spgrid/misc.hh
+include/dune/grid/spgrid/multiindex.hh
+include/dune/grid/spgrid/normal.hh
+include/dune/grid/spgrid/partition.hh
+include/dune/grid/spgrid/partitionlist.hh
+include/dune/grid/spgrid/partitionpool.hh
+include/dune/grid/spgrid/persistentcontainer.hh
+include/dune/grid/spgrid/referencecube.hh
+include/dune/grid/spgrid/refinement.hh
+include/dune/grid/spgrid/superentityiterator.hh
+include/dune/grid/spgrid/topology.hh
+include/dune/grid/spgrid/tree.hh
+include/dune/grid/test/checkbndsegiterator.hh
+include/dune/grid/test/checkidcommunication.hh
+include/dune/grid/test/checkseiterator.hh
+include/dune/grid/test/checktree.hh
+lib/cmake/dune-spgrid/dune-spgrid-config-version.cmake
+lib/cmake/dune-spgrid/dune-spgrid-config.cmake
+lib/dunecontrol/dune-spgrid/dune.module
+libdata/pkgconfig/dune-spgrid.pc
+%%DATADIR%%/config.h.cmake
+share/dune/cmake/modules/DuneSpgridMacros.cmake