aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2014-02-18 16:06:46 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2014-02-18 16:06:46 +0000
commit6a03534489abe644042fad21d7b7828943acd3e4 (patch)
treea778cc5efad8712cce9faddebbe31d8133fcf54b /math
parentc729cef42cfbe5dc1a11df66af3ccb6176a4682a (diff)
downloadports-6a03534489abe644042fad21d7b7828943acd3e4.tar.gz
ports-6a03534489abe644042fad21d7b7828943acd3e4.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Fleximal/Makefile21
-rw-r--r--math/p5-Math-Fleximal/distinfo2
-rw-r--r--math/p5-Math-Fleximal/pkg-descr13
-rw-r--r--math/p5-Math-Fleximal/pkg-plist6
5 files changed, 43 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index cec2719dc770..eb7016ec16c9 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -416,6 +416,7 @@
SUBDIR += p5-Math-Expr
SUBDIR += p5-Math-FFT
SUBDIR += p5-Math-FixedPrecision
+ SUBDIR += p5-Math-Fleximal
SUBDIR += p5-Math-GMP
SUBDIR += p5-Math-GMPf
SUBDIR += p5-Math-GMPq
diff --git a/math/p5-Math-Fleximal/Makefile b/math/p5-Math-Fleximal/Makefile
new file mode 100644
index 000000000000..9d910456cb0b
--- /dev/null
+++ b/math/p5-Math-Fleximal/Makefile
@@ -0,0 +1,21 @@
+# Created by: Matthew Seaman <matthew@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Math-Fleximal
+PORTVERSION= 0.06
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= Integers with flexible representations
+
+NO_ARCH= yes
+
+USES= perl5
+USE_PERL5= configure
+
+regression-test: build
+ @cd ${WRKSRC} && ${MAKE} test
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Fleximal/distinfo b/math/p5-Math-Fleximal/distinfo
new file mode 100644
index 000000000000..c7bc6d135a56
--- /dev/null
+++ b/math/p5-Math-Fleximal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Math-Fleximal-0.06.tar.gz) = f642606b58d823bef931db6a0301c22813d4f761e5fcc346e2a77836fcb981dc
+SIZE (Math-Fleximal-0.06.tar.gz) = 6807
diff --git a/math/p5-Math-Fleximal/pkg-descr b/math/p5-Math-Fleximal/pkg-descr
new file mode 100644
index 000000000000..b9e2afcd5868
--- /dev/null
+++ b/math/p5-Math-Fleximal/pkg-descr
@@ -0,0 +1,13 @@
+This is a package for doing integer arithmetic while using a different
+base representation than normal. In base n arithmetic you have n
+symbols which have a representation. I was going to call them
+"glyphs", but being text strings they are not really. On Tye McQueen's
+whimsical suggestion I settled on the name Math::Fleximal, the set of
+text representations is called a "flex", and the representation of
+individual digits are the "flecks". These names are somewhat
+unofficial...
+
+This allows you to do basic arithmetic using whatever digits you want,
+and to convert from one to another.
+
+WWW: http://search.cpan.org/dist/Math-Fleximal/
diff --git a/math/p5-Math-Fleximal/pkg-plist b/math/p5-Math-Fleximal/pkg-plist
new file mode 100644
index 000000000000..53bc6209b469
--- /dev/null
+++ b/math/p5-Math-Fleximal/pkg-plist
@@ -0,0 +1,6 @@
+%%PERL5_MAN3%%/Math::Fleximal.3.gz
+%%SITE_PERL%%/Math/Fleximal.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Fleximal/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Fleximal
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math