aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-12-01 20:33:45 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-12-01 20:33:45 +0000
commit7cb3294da78ddd596f197b8f599a9bc3f3c83eac (patch)
tree1c72184bc6e535e324c3903ec7138b0daceaed97 /math
parent8b1dce6212c686a1fbedd71ad7127d0dfc2cb54e (diff)
downloadports-7cb3294da78ddd596f197b8f599a9bc3f3c83eac.tar.gz
ports-7cb3294da78ddd596f197b8f599a9bc3f3c83eac.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/PDL/Makefile4
-rw-r--r--math/asymptote/Makefile4
-rw-r--r--math/dieharder/Makefile1
-rw-r--r--math/labplot/Makefile4
-rw-r--r--math/labplot/files/patch-src__constants.h10
-rw-r--r--math/octave-forge-bim/Makefile2
-rw-r--r--math/octave-forge-gsl/Makefile4
-rw-r--r--math/octave-forge-msh/Makefile2
-rw-r--r--math/orpie/Makefile4
-rw-r--r--math/p5-Math-GSL/Makefile4
-rw-r--r--math/pspp/Makefile1
-rw-r--r--math/py-gsl/Makefile4
-rw-r--r--math/py-gsl/files/patch-src__const_cgs_array.c23
-rw-r--r--math/py-gsl/files/patch-src__const_cgsm_array.c10
-rw-r--r--math/qtiplot/Makefile4
-rw-r--r--math/ruby-gsl/Makefile4
-rw-r--r--math/ruby-gsl/files/patch-ext__const.c10
-rw-r--r--math/yacas/Makefile4
18 files changed, 77 insertions, 22 deletions
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index 25cd3f4f6715..981eae7845f7 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -8,7 +8,7 @@
PORTNAME= PDL
PORTVERSION= 2.4.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math perl5
MASTER_SITES= CPAN/${PORTNAME}:cpan \
SF/pdl/PDL/${PORTVERSION}:sf
@@ -26,7 +26,7 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/PGPLOT.pm:${PORTSDIR}/graphics/pgperl \
${SITE_PERL}/Term/ReadLine/readline.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
LIB_DEPENDS= plplotd.11:${PORTSDIR}/math/plplot \
fftw.2:${PORTSDIR}/math/fftw \
- gsl.13:${PORTSDIR}/math/gsl
+ gsl.14:${PORTSDIR}/math/gsl
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_GL= yes
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 3d55395672ff..b31c87789f0a 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -7,7 +7,7 @@
PORTNAME= asymptote
PORTVERSION= 1.75
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/old/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -17,7 +17,7 @@ MAINTAINER= nivit@FreeBSD.org
COMMENT= A powerful script-based vector graphics language
.if defined(WITH_GSL)
-LIB_DEPENDS+= gsl.13:${PORTSDIR}/math/gsl
+LIB_DEPENDS+= gsl.14:${PORTSDIR}/math/gsl
.endif
.if defined(WITH_FFTW)
LIB_DEPENDS= fftw3.5:${PORTSDIR}/math/fftw3
diff --git a/math/dieharder/Makefile b/math/dieharder/Makefile
index 16d77356537b..2d0fa0246ed5 100644
--- a/math/dieharder/Makefile
+++ b/math/dieharder/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dieharder
PORTVERSION= 2.28.1
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= http://www.phy.duke.edu/~rgb/General/dieharder/
EXTRACT_SUFX= .tgz
diff --git a/math/labplot/Makefile b/math/labplot/Makefile
index bf3b04dd025d..3b77201ab078 100644
--- a/math/labplot/Makefile
+++ b/math/labplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= LabPlot
PORTVERSION= 1.6.0.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= math kde
MASTER_SITES= SF
@@ -17,7 +17,7 @@ COMMENT= LabPlot : Data analysis and visualisation
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
jasper.4:${PORTSDIR}/graphics/jasper \
MagickWand.2:${PORTSDIR}/graphics/ImageMagick \
- gsl.13:${PORTSDIR}/math/gsl \
+ gsl.14:${PORTSDIR}/math/gsl \
fftw3.5:${PORTSDIR}/math/fftw3 \
qwtplot3d.0:${PORTSDIR}/math/qwtplot3d \
origin.0:${PORTSDIR}/math/liborigin
diff --git a/math/labplot/files/patch-src__constants.h b/math/labplot/files/patch-src__constants.h
new file mode 100644
index 000000000000..6def48bd5ea9
--- /dev/null
+++ b/math/labplot/files/patch-src__constants.h
@@ -0,0 +1,10 @@
+--- ./src/constants.h.orig 2009-11-28 14:12:55.000000000 +0300
++++ ./src/constants.h 2009-11-28 23:00:49.000000000 +0300
+@@ -220,7 +220,6 @@
+ {"stokes_cgs",GSL_CONST_CGSM_STOKES},
+ {"f_cgs",GSL_CONST_CGSM_FARADAY},
+ {"e_cgs",GSL_CONST_CGSM_ELECTRON_CHARGE},
+- {"gauss_cgs",GSL_CONST_CGSM_GAUSS},
+ {"stilb_cgs",GSL_CONST_CGSM_STILB},
+ {"lumen_cgs",GSL_CONST_CGSM_LUMEN},
+ {"lux_cgs",GSL_CONST_CGSM_LUX},
diff --git a/math/octave-forge-bim/Makefile b/math/octave-forge-bim/Makefile
index dbdf4230d965..7eff9d3c9c06 100644
--- a/math/octave-forge-bim/Makefile
+++ b/math/octave-forge-bim/Makefile
@@ -7,7 +7,7 @@
PORTNAME= octave-forge-bim
PORTVERSION= 0.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= stephen@missouri.edu
diff --git a/math/octave-forge-gsl/Makefile b/math/octave-forge-gsl/Makefile
index 607afe81a71a..79eaa28430f1 100644
--- a/math/octave-forge-gsl/Makefile
+++ b/math/octave-forge-gsl/Makefile
@@ -7,13 +7,13 @@
PORTNAME= octave-forge-gsl
PORTVERSION= 1.0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= stephen@missouri.edu
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.14:${PORTSDIR}/math/gsl
post-patch:
@${REINPLACE_CMD} s+/bin/bash+/usr/local/bin/bash+g ${WRKSRC}/src/config*
diff --git a/math/octave-forge-msh/Makefile b/math/octave-forge-msh/Makefile
index f45140a50c69..1625dd274b88 100644
--- a/math/octave-forge-msh/Makefile
+++ b/math/octave-forge-msh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= octave-forge-msh
PORTVERSION= 0.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= stephen@missouri.edu
diff --git a/math/orpie/Makefile b/math/orpie/Makefile
index 6d2aef6ad476..2019e9a64375 100644
--- a/math/orpie/Makefile
+++ b/math/orpie/Makefile
@@ -7,7 +7,7 @@
PORTNAME= orpie
PORTVERSION= 1.5.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= math
MASTER_SITES= http://pessimization.com/software/orpie/
@@ -15,7 +15,7 @@ MAINTAINER= dylan@dylex.net
COMMENT= A fullscreen RPN calculator for the console
BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml
-LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.14:${PORTSDIR}/math/gsl
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/math/p5-Math-GSL/Makefile b/math/p5-Math-GSL/Makefile
index 517efbfbce7d..d24e1ddd1a35 100644
--- a/math/p5-Math-GSL/Makefile
+++ b/math/p5-Math-GSL/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Math-GSL
PORTVERSION= 0.20
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -18,7 +18,7 @@ COMMENT= A perl interface to GNU Scientific Library
BUILD_DEPENDS= ${SITE_PERL}/ExtUtils/PkgConfig.pm:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
${SITE_PERL}/Test/Class.pm:${PORTSDIR}/devel/p5-Test-Class
-LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.14:${PORTSDIR}/math/gsl
PERL_CONFIGURE= yes
PERL_MODBUILD= yes
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index 8f9c8351433e..1943ad3acbe9 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pspp
PORTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= GNU
diff --git a/math/py-gsl/Makefile b/math/py-gsl/Makefile
index 98cb50868b96..7bc07ae5025c 100644
--- a/math/py-gsl/Makefile
+++ b/math/py-gsl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gsl
PORTVERSION= 0.9.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math python
MASTER_SITES= SF/py${PORTNAME}/py${PORTNAME}/py${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,7 +19,7 @@ COMMENT= Python interface to GNU Scientific Library
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/core/include/numpy/arrayobject.h:${PORTSDIR}/math/py-numpy
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy/__init__.py:${PORTSDIR}/math/py-numpy
-LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.14:${PORTSDIR}/math/gsl
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g}
USE_PYTHON= yes
diff --git a/math/py-gsl/files/patch-src__const_cgs_array.c b/math/py-gsl/files/patch-src__const_cgs_array.c
new file mode 100644
index 000000000000..cd102349341e
--- /dev/null
+++ b/math/py-gsl/files/patch-src__const_cgs_array.c
@@ -0,0 +1,23 @@
+--- ./src/const_cgs_array.c.orig 2005-04-27 11:53:37.000000000 +0400
++++ ./src/const_cgs_array.c 2009-11-28 23:12:12.000000000 +0300
+@@ -14,10 +14,6 @@
+ {"mass_neutron",GSL_CONST_CGS_MASS_NEUTRON,"g"},
+ {"rydberg",GSL_CONST_CGS_RYDBERG,"g cm^2 / s^2"},
+ {"boltzmann",GSL_CONST_CGS_BOLTZMANN,"g cm^2 / K s^2"},
+-{"bohr_magneton",GSL_CONST_CGS_BOHR_MAGNETON,"A cm^2"},
+-{"nuclear_magneton",GSL_CONST_CGS_NUCLEAR_MAGNETON,"A cm^2"},
+-{"electron_magnetic_moment",GSL_CONST_CGS_ELECTRON_MAGNETIC_MOMENT,"A cm^2"},
+-{"proton_magnetic_moment",GSL_CONST_CGS_PROTON_MAGNETIC_MOMENT,"A cm^2"},
+ {"molar_gas",GSL_CONST_CGS_MOLAR_GAS,"g cm^2 / K mol s^2"},
+ {"standard_gas_volume",GSL_CONST_CGS_STANDARD_GAS_VOLUME,"cm^3 / mol"},
+ {"minute",GSL_CONST_CGS_MINUTE,"s"},
+@@ -76,9 +72,6 @@
+ {"psi",GSL_CONST_CGS_PSI,"g / cm s^2"},
+ {"poise",GSL_CONST_CGS_POISE,"g / cm s"},
+ {"stokes",GSL_CONST_CGS_STOKES,"cm^2 / s"},
+-{"faraday",GSL_CONST_CGS_FARADAY,"A s / mol"},
+-{"electron_charge",GSL_CONST_CGS_ELECTRON_CHARGE,"A s"},
+-{"gauss",GSL_CONST_CGS_GAUSS,"g / A s^2"},
+ {"stilb",GSL_CONST_CGS_STILB,"cd / cm^2"},
+ {"lumen",GSL_CONST_CGS_LUMEN,"cd sr"},
+ {"lux",GSL_CONST_CGS_LUX,"cd sr / cm^2"},
diff --git a/math/py-gsl/files/patch-src__const_cgsm_array.c b/math/py-gsl/files/patch-src__const_cgsm_array.c
new file mode 100644
index 000000000000..1c86846b5ce2
--- /dev/null
+++ b/math/py-gsl/files/patch-src__const_cgsm_array.c
@@ -0,0 +1,10 @@
+--- ./src/const_cgsm_array.c.orig 2006-12-21 15:20:15.000000000 +0300
++++ ./src/const_cgsm_array.c 2009-11-28 23:12:26.000000000 +0300
+@@ -77,7 +77,6 @@
+ {"stokes",GSL_CONST_CGSM_STOKES,"cm^2 / s"},
+ {"faraday",GSL_CONST_CGSM_FARADAY,"abamp s / mol"},
+ {"electron_charge",GSL_CONST_CGSM_ELECTRON_CHARGE,"abamp s"},
+-{"gauss",GSL_CONST_CGSM_GAUSS,"g / abamp s^2"},
+ {"stilb",GSL_CONST_CGSM_STILB,"cd / cm^2"},
+ {"lumen",GSL_CONST_CGSM_LUMEN,"cd sr"},
+ {"lux",GSL_CONST_CGSM_LUX,"cd sr / cm^2"},
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index 0631ee89faf2..0772cfeb2d3d 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= qtiplot
DISTVERSION= 0.9.7.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math science
MASTER_SITES= BERLIOS http://soft.proindependent.com/src/
@@ -15,7 +15,7 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= An Origin clone for data analysis and scientific plotting
BUILD_DEPENDS= ${LOCALBASE}/lib/libmuparser.a:${PORTSDIR}/math/muparser
-LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl \
+LIB_DEPENDS= gsl.14:${PORTSDIR}/math/gsl \
qwt.5:${PORTSDIR}/x11-toolkits/qwt5 \
boost_date_time:${PORTSDIR}/devel/boost-libs
diff --git a/math/ruby-gsl/Makefile b/math/ruby-gsl/Makefile
index a61844787869..c23f8e3d0f73 100644
--- a/math/ruby-gsl/Makefile
+++ b/math/ruby-gsl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gsl
PORTVERSION= 1.10.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math ruby
MASTER_SITES= RF
MASTER_SITE_SUBDIR= rb-${PORTNAME}
@@ -18,7 +18,7 @@ DIST_SUBDIR= ruby
MAINTAINER= clsung@FreeBSD.org
COMMENT= A Ruby extension library for GSL (GNU Scientific Library)
-LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.14:${PORTSDIR}/math/gsl
USE_RUBY= yes
USE_RUBY_SETUP= yes
diff --git a/math/ruby-gsl/files/patch-ext__const.c b/math/ruby-gsl/files/patch-ext__const.c
new file mode 100644
index 000000000000..d0e4e16c5bd5
--- /dev/null
+++ b/math/ruby-gsl/files/patch-ext__const.c
@@ -0,0 +1,10 @@
+--- ./ext/const.c.orig 2007-12-08 17:45:32.000000000 +0300
++++ ./ext/const.c 2009-11-28 23:21:00.000000000 +0300
+@@ -599,7 +599,6 @@
+ rb_float_new(GSL_CONST_CGSM_ELECTRON_CHARGE));
+ rb_define_const(module, "ELECTRON_CHARGE_ESU",
+ rb_float_new(GSL_CONST_CGSM_ELECTRON_CHARGE*GSL_CONST_CGSM_SPEED_OF_LIGHT));
+- rb_define_const(module, "GAUSS", rb_float_new(GSL_CONST_CGSM_GAUSS));
+ rb_define_const(module, "STILB", rb_float_new(GSL_CONST_CGSM_STILB));
+ rb_define_const(module, "LUMEN", rb_float_new(GSL_CONST_CGSM_LUMEN));
+ rb_define_const(module, "LUX", rb_float_new(GSL_CONST_CGSM_LUX));
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index f8f48be08fd5..a9cd822850d8 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -8,14 +8,14 @@
PORTNAME= yacas
PORTVERSION= 1.0.61
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MASTER_SITES= http://yacas.sourceforge.net/backups/
MAINTAINER= ports@FreeBSD.org
COMMENT= Yet Another Computer Algebra System
-LIB_DEPENDS= gsl.13:${PORTSDIR}/math/gsl
+LIB_DEPENDS= gsl.14:${PORTSDIR}/math/gsl
USE_AUTOTOOLS= libtool:22
USE_PERL5_BUILD= yes