aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2014-02-08 05:18:19 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2014-02-08 05:18:19 +0000
commit8453a00a4dd506392e0742e73a7db0f8d341a4e4 (patch)
tree8ea97f1055cfc6abfef0dd7f9a388f8f69e0ca7f /math
parentbf8a09d2af3c56e9c2e56b21c6913a68e528f527 (diff)
Notes
Diffstat (limited to 'math')
-rw-r--r--math/sage/Makefile28
-rw-r--r--math/sage/distinfo4
-rw-r--r--math/sage/files/patch-build_pkgs_readline_fbsd-patch-src_support_shlib-install15
-rw-r--r--math/sage/files/patch-build_pkgs_readline_patches_shobj-conf.patch11
-rw-r--r--math/sage/files/patch-build_pkgs_scons_fbsd-patch-src_engine_SCons_compat__scons_subprocess.py34
5 files changed, 80 insertions, 12 deletions
diff --git a/math/sage/Makefile b/math/sage/Makefile
index 686301a182de..4062af610f68 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= sage
-PORTVERSION= 6.1
+PORTVERSION= 6.1.1
CATEGORIES= math
MASTER_SITES= http://boxen.math.washington.edu/home/sagemath/sage-mirror/src/ \
http://mirrors.xmission.com/sage/src/ \
http://www-ftp.lip6.fr/pub/math/sagemath/src/ \
http://www.sagemath.org/src-old/
-EXTRACT_SUFX= .tar
MAINTAINER= stephen@FreeBSD.org
COMMENT= Open source Mathematics software
@@ -153,4 +152,29 @@ FPM_FLAG=
MAKE_ENV+= MAKE="${MAKE} -j${MAKE_JOBS_NUMBER}"
+.ifdef MAINTAINER_MODE
+test-fbsd-patches: patch
+ rm -rf ${WRKSRC}/build/pkgs/*/src; \
+ for d in ${WRKSRC}/build/pkgs/*; do \
+ if ls $$d/fbsd-patch-* > /dev/null 2>&1; then \
+ echo Testing patches in $${d##*/}; \
+ b=$${d##*/}-`cat $$d/package-version.txt | sed 's/\.p.*//'`; \
+ c=${WRKSRC}/upstream/$$b.tar.bz2 ; \
+ if [ ! -e $$c ]; then \
+ echo Couldn\'t find $$c; \
+ exit 1; \
+ fi; \
+ if ! (cd $$d && tar xf $$c && mv $$b src); then \
+ echo Unable to unarchive $$c; \
+ exit 1; \
+ fi; \
+ if ! (cd $$d && cat fbsd-patch-* | patch); then \
+ echo Patches in $${d##*/} failed; \
+ exit 1; \
+ fi; \
+ fi; \
+ done; \
+ rm -rf ${WRKSRC}/build/pkgs/*/src
+.endif
+
.include <bsd.port.post.mk>
diff --git a/math/sage/distinfo b/math/sage/distinfo
index ae9685ec8221..9b394742d3fb 100644
--- a/math/sage/distinfo
+++ b/math/sage/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sage-6.1.tar) = 13c3ec386176ed48a612fe47fa909ee461bd3f6c6c62fb0b3e4528c3c5602a42
-SIZE (sage-6.1.tar) = 399881018
+SHA256 (sage-6.1.1.tar.gz) = bee00adf232fbd4b256fae1aae5e9b52cb5c050b2d2337b624c31f9c28d07f4d
+SIZE (sage-6.1.1.tar.gz) = 398548682
diff --git a/math/sage/files/patch-build_pkgs_readline_fbsd-patch-src_support_shlib-install b/math/sage/files/patch-build_pkgs_readline_fbsd-patch-src_support_shlib-install
index bbe7584b06a3..c5f7f2d0390b 100644
--- a/math/sage/files/patch-build_pkgs_readline_fbsd-patch-src_support_shlib-install
+++ b/math/sage/files/patch-build_pkgs_readline_fbsd-patch-src_support_shlib-install
@@ -1,15 +1,14 @@
---- /dev/null 2014-02-04 16:10:34.000000000 -0600
-+++ build/pkgs/readline/fbsd-patch-src_support_shlib-install 2014-02-04 16:14:11.000000000 -0600
-@@ -0,0 +1,12 @@
-+--- src/support/shlib-install-orig 2014-02-04 16:09:16.000000000 -0600
-++++ src/support/shlib-install 2014-02-04 16:10:32.000000000 -0600
-+@@ -177,7 +177,8 @@
+--- /dev/null 2014-02-05 02:11:00.000000000 +0000
++++ build/pkgs/readline/fbsd-patch-src_support_shlib-install 2014-02-05 02:11:23.000000000 +0000
+@@ -0,0 +1,11 @@
++--- src/support/shlib-install.orig 2009-10-28 13:30:18.000000000 +0000
+++++ src/support/shlib-install 2014-02-05 02:08:59.000000000 +0000
++@@ -177,7 +177,7 @@
+ fi
+ ;;
+
+-freebsd[4-9]*|freebsdelf*|dragonfly*)
-++# FreeBSD less than 4 no longer supported. So freebsd[4-9]* to freebsd*.
-++freebsd*|freebsdelf*|dragonfly*)
+++freebsd[4-9].*|freebsd1[0-9].*|freebsdelf*|dragonfly*)
+ # libname.so -> libname.so.M
+ ${echo} ${RM} ${INSTALLDIR}/$LINK1
+ if [ -z "$uninstall" ]; then
diff --git a/math/sage/files/patch-build_pkgs_readline_patches_shobj-conf.patch b/math/sage/files/patch-build_pkgs_readline_patches_shobj-conf.patch
new file mode 100644
index 000000000000..d7b64f229abd
--- /dev/null
+++ b/math/sage/files/patch-build_pkgs_readline_patches_shobj-conf.patch
@@ -0,0 +1,11 @@
+--- build/pkgs/readline/patches/shobj-conf.patch-orig 2014-02-04 21:08:30.000000000 -0600
++++ build/pkgs/readline/patches/shobj-conf.patch 2014-02-04 21:09:48.000000000 -0600
+@@ -43,7 +43,7 @@
+ - SHLIB_XLDFLAGS='-Wl,-rpath,$(libdir)'
+ -
+ - SHLIB_LIBVERSION='$(SHLIB_LIBSUFF).$(SHLIB_MAJOR)'
+-+freebsdelf*|dragonfly*)
+++freebsd[4-9].*|freebsd1[0-9].*|freebsdelf*|dragonfly*)
+ + SHOBJ_CFLAGS=-fPIC
+ + SHOBJ_LD='${CC}'
+ + SHOBJ_LDFLAGS='-shared -Wl,-soname,$@'
diff --git a/math/sage/files/patch-build_pkgs_scons_fbsd-patch-src_engine_SCons_compat__scons_subprocess.py b/math/sage/files/patch-build_pkgs_scons_fbsd-patch-src_engine_SCons_compat__scons_subprocess.py
new file mode 100644
index 000000000000..b77076540080
--- /dev/null
+++ b/math/sage/files/patch-build_pkgs_scons_fbsd-patch-src_engine_SCons_compat__scons_subprocess.py
@@ -0,0 +1,34 @@
+--- /dev/null 2014-02-05 05:15:00.000000000 +0000
++++ build/pkgs/scons/fbsd-patch-src_engine_SCons_compat__scons_subprocess.py 2014-02-05 05:16:45.000000000 +0000
+@@ -0,0 +1,31 @@
++--- src/engine/SCons/compat/_scons_subprocess.py.orig 2008-12-21 06:59:59.000000000 +0000
+++++ src/engine/SCons/compat/_scons_subprocess.py 2014-02-05 05:11:11.000000000 +0000
++@@ -585,13 +585,19 @@
++ class object:
++ pass
++
+++import thread
+++lock = thread.allocate_lock()
+++
++ class Popen(object):
++ def __init__(self, args, bufsize=0, executable=None,
++ stdin=None, stdout=None, stderr=None,
++ preexec_fn=None, close_fds=False, shell=False,
++ cwd=None, env=None, universal_newlines=False,
++ startupinfo=None, creationflags=0):
++- """Create new Popen instance."""
+++ """Create new Popen instance.
+++ Popen is not thread-safe and is therefore protected with a lock.
+++ """
+++ lock.acquire()
++ _cleanup()
++
++ self._child_created = False
++@@ -659,6 +665,7 @@
++ self.stderr = os.fdopen(errread, 'rU', bufsize)
++ else:
++ self.stderr = os.fdopen(errread, 'rb', bufsize)
+++ lock.release()
++
++
++ def _translate_newlines(self, data):