aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-15 16:58:42 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-15 16:58:42 +0000
commitce00b8d7d883bf382182da027976a7f01661a59c (patch)
treeb1e54c1309907d3ae32fe8faf2f848857c5d09f5 /math
parent18c1025e7c012016c5a1126a4dc057dfac591a95 (diff)
downloadports-ce00b8d7d883bf382182da027976a7f01661a59c.tar.gz
ports-ce00b8d7d883bf382182da027976a7f01661a59c.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-SymbolicX-Error/Makefile33
-rw-r--r--math/p5-Math-SymbolicX-Error/distinfo3
-rw-r--r--math/p5-Math-SymbolicX-Error/pkg-descr9
-rw-r--r--math/p5-Math-SymbolicX-Error/pkg-plist7
5 files changed, 53 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 5ef513c39bae..f2c53539c19c 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -199,6 +199,7 @@
SUBDIR += p5-Math-Symbolic-Custom-Transformation
SUBDIR += p5-Math-SymbolicX-BigNum
SUBDIR += p5-Math-SymbolicX-Complex
+ SUBDIR += p5-Math-SymbolicX-Error
SUBDIR += p5-Math-SymbolicX-Inline
SUBDIR += p5-Math-SymbolicX-NoSimplification
SUBDIR += p5-Math-SymbolicX-ParserExtensionFactory
diff --git a/math/p5-Math-SymbolicX-Error/Makefile b/math/p5-Math-SymbolicX-Error/Makefile
new file mode 100644
index 000000000000..c33a82b26545
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Error/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Math-SymbolicX-Error
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-SymbolicX-Error
+PORTVERSION= 0.02
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Parser extension for dealing with numeric errors
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
+ ${SITE_PERL}/Math/SymbolicX/ParserExtensionFactory.pm:${PORTSDIR}/math/p5-Math-SymbolicX-ParserExtensionFactory \
+ ${SITE_PERL}/Number/WithError.pm:${PORTSDIR}/math/p5-Number-WithError
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::SymbolicX::Error.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-SymbolicX-Error/distinfo b/math/p5-Math-SymbolicX-Error/distinfo
new file mode 100644
index 000000000000..479085aaf47d
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Error/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-SymbolicX-Error-0.02.tar.gz) = 16e459755856cb549210ec789caae285
+SHA256 (Math-SymbolicX-Error-0.02.tar.gz) = 04b369acdb4372c28d073a2c425a28bdd261d81994ab8a9edd28a66dbc832393
+SIZE (Math-SymbolicX-Error-0.02.tar.gz) = 4425
diff --git a/math/p5-Math-SymbolicX-Error/pkg-descr b/math/p5-Math-SymbolicX-Error/pkg-descr
new file mode 100644
index 000000000000..5296b540dfde
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Error/pkg-descr
@@ -0,0 +1,9 @@
+This module adds numeric error (or uncertainty) support to the
+Math::Symbolic parser. It does so by extending the parser grammar of the
+Math::Symbolic module (that is, the one stored in $Math::Symbolic::Parser)
+with certain special functions that create constants as Number::WithError
+objects. (Math::Symbolic::Variable objects have been able to contain
+objects since the very beginning.)
+
+WWW: http://search.cpan.org/dist/Math-SymbolicX-Error
+Author: Steffen Mueller <symbolic-module@steffen-mueller.net>
diff --git a/math/p5-Math-SymbolicX-Error/pkg-plist b/math/p5-Math-SymbolicX-Error/pkg-plist
new file mode 100644
index 000000000000..a11e662cd1f8
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Error/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Math/SymbolicX/Error.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX/Error/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX/Error
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math/SymbolicX
+@dirrmtry %%SITE_PERL%%/Math