aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-03-07 07:07:18 +0000
committerWen Heping <wen@FreeBSD.org>2011-03-07 07:07:18 +0000
commitcf5d814d5e7e227ceae57854245ac8d9558ac6ee (patch)
tree67ffbf69aed537df07c5c03050ae8e7af84fca7c /math
parent6fa9734e75f85d83b2a109008a2182857fc4374f (diff)
downloadports-cf5d814d5e7e227ceae57854245ac8d9558ac6ee.tar.gz
ports-cf5d814d5e7e227ceae57854245ac8d9558ac6ee.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Statistics-R/Makefile25
-rw-r--r--math/p5-Statistics-R/distinfo2
-rw-r--r--math/p5-Statistics-R/pkg-descr4
-rw-r--r--math/p5-Statistics-R/pkg-plist8
5 files changed, 40 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 39b0d43fa718..f29888c436ea 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -422,6 +422,7 @@
SUBDIR += p5-Statistics-LineFit
SUBDIR += p5-Statistics-Lite
SUBDIR += p5-Statistics-OLS
+ SUBDIR += p5-Statistics-R
SUBDIR += p5-Statistics-Regression
SUBDIR += p5-Statistics-TTest
SUBDIR += p5-Task-Math-Symbolic
diff --git a/math/p5-Statistics-R/Makefile b/math/p5-Statistics-R/Makefile
new file mode 100644
index 000000000000..00485423f7fc
--- /dev/null
+++ b/math/p5-Statistics-R/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: math/p5-Statistics-R
+# Date created: March 7, 2011
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Statistics-R
+PORTVERSION= 0.08
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:BRICAS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Controls the R interpreter through Perl
+
+RUN_DEPENDS= ${LOCALBASE}/bin/R:${PORTSDIR}/math/R
+
+PERL_CONFIGURE= yes
+
+MAN3= Statistics::R::Bridge.3 \
+ Statistics::R.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Statistics-R/distinfo b/math/p5-Statistics-R/distinfo
new file mode 100644
index 000000000000..319ebee1ee72
--- /dev/null
+++ b/math/p5-Statistics-R/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Statistics-R-0.08.tar.gz) = 2ca4731748046d340abd141ee8f30f4bcfc30bd6bf18d295b97fc0d7ac88e1fe
+SIZE (Statistics-R-0.08.tar.gz) = 9646
diff --git a/math/p5-Statistics-R/pkg-descr b/math/p5-Statistics-R/pkg-descr
new file mode 100644
index 000000000000..84da1fe5076f
--- /dev/null
+++ b/math/p5-Statistics-R/pkg-descr
@@ -0,0 +1,4 @@
+Statistics::R will permit the control of the the R (R-project) interpreter
+through Perl in different architectures and OS.
+
+WWW: http://search.cpan.org/dist/Statistics-R/
diff --git a/math/p5-Statistics-R/pkg-plist b/math/p5-Statistics-R/pkg-plist
new file mode 100644
index 000000000000..113632ac5fbb
--- /dev/null
+++ b/math/p5-Statistics-R/pkg-plist
@@ -0,0 +1,8 @@
+bin/statistics-r.pl
+%%SITE_PERL%%/Statistics/R/Bridge.pm
+%%SITE_PERL%%/Statistics/R.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/R/.packlist
+@dirrmtry %%SITE_PERL%%/Statistics/R
+@dirrmtry %%SITE_PERL%%/Statistics
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/R
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics