aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-07-29 07:36:57 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-07-29 07:36:57 +0000
commite0194e9ed64f4f16fe3d27e4ad8f4795ce8a76e3 (patch)
treee0ebd0b75f4cbb9da5b2b23d44838fa478358c2b /math
parent614036f8dad630e498ddf3f4eacf21b1a625c058 (diff)
downloadports-e0194e9ed64f4f16fe3d27e4ad8f4795ce8a76e3.tar.gz
ports-e0194e9ed64f4f16fe3d27e4ad8f4795ce8a76e3.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/gnumeric/Makefile3
-rw-r--r--math/gnumeric/distinfo6
-rw-r--r--math/gnumeric/files/patch-configure55
-rw-r--r--math/gnumeric/pkg-plist10
4 files changed, 62 insertions, 12 deletions
diff --git a/math/gnumeric/Makefile b/math/gnumeric/Makefile
index d8aa47468924..93bba68015b5 100644
--- a/math/gnumeric/Makefile
+++ b/math/gnumeric/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= gnumeric
-PORTVERSION= 1.7.10
-PORTREVISION= 1
+PORTVERSION= 1.7.11
CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
diff --git a/math/gnumeric/distinfo b/math/gnumeric/distinfo
index 7504b5537ddd..c0253ed48044 100644
--- a/math/gnumeric/distinfo
+++ b/math/gnumeric/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnumeric-1.7.10.tar.bz2) = ad9e8b3b9ec899b069e93511b48a3e01
-SHA256 (gnome2/gnumeric-1.7.10.tar.bz2) = 8520b71ae163bfb846aa363f2ab992a7768bc62b532afbec7a8381a67d87e50d
-SIZE (gnome2/gnumeric-1.7.10.tar.bz2) = 13373300
+MD5 (gnome2/gnumeric-1.7.11.tar.bz2) = 75e8c36afa8322c601a14cb5a35a8793
+SHA256 (gnome2/gnumeric-1.7.11.tar.bz2) = ee60415d849d8c4a48a16013a8925e70fcee16f934659677667cabd97e7b2516
+SIZE (gnome2/gnumeric-1.7.11.tar.bz2) = 13077190
diff --git a/math/gnumeric/files/patch-configure b/math/gnumeric/files/patch-configure
new file mode 100644
index 000000000000..71ecb2bff5da
--- /dev/null
+++ b/math/gnumeric/files/patch-configure
@@ -0,0 +1,55 @@
+--- configure.orig 2007-07-29 02:46:18.000000000 -0400
++++ configure 2007-07-29 02:48:14.000000000 -0400
+@@ -23472,12 +23472,12 @@ if test -n "$PKG_CONFIG"; then
+ pkg_cv_GB_CFLAGS="$GB_CFLAGS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libgb == 1.17\"") >&5
+- ($PKG_CONFIG --exists --print-errors "libgb == 1.17") 2>&5
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libgb = 1.17\"") >&5
++ ($PKG_CONFIG --exists --print-errors "libgb = 1.17") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_GB_CFLAGS=`$PKG_CONFIG --cflags "libgb == 1.17" 2>/dev/null`
++ pkg_cv_GB_CFLAGS=`$PKG_CONFIG --cflags "libgb = 1.17" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -23490,12 +23490,12 @@ if test -n "$PKG_CONFIG"; then
+ pkg_cv_GB_LIBS="$GB_LIBS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libgb == 1.17\"") >&5
+- ($PKG_CONFIG --exists --print-errors "libgb == 1.17") 2>&5
++ { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libgb = 1.17\"") >&5
++ ($PKG_CONFIG --exists --print-errors "libgb = 1.17") 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+- pkg_cv_GB_LIBS=`$PKG_CONFIG --libs "libgb == 1.17" 2>/dev/null`
++ pkg_cv_GB_LIBS=`$PKG_CONFIG --libs "libgb = 1.17" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -23514,9 +23514,9 @@ else
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- GB_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "libgb == 1.17"`
++ GB_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "libgb = 1.17"`
+ else
+- GB_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "libgb == 1.17"`
++ GB_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "libgb = 1.17"`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$GB_PKG_ERRORS" >&5
+@@ -27943,7 +27943,7 @@ echo $ECHO_N "checking
+ ======== for python = 2.x... $ECHO_C" >&6; }
+ PY_VERSION=`$PYTHON -c 'import sys ; sys.stdout.write(sys.version[0:3])'`
+ major_ver=`$PYTHON -c 'import sys ; sys.stdout.write(sys.version[0:1])'`
+- if test "x$major_ver" == "x2"; then
++ if test "x$major_ver" = "x2"; then
+ { echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6; }
+ else
diff --git a/math/gnumeric/pkg-plist b/math/gnumeric/pkg-plist
index 868ab6992310..63a8cfa74683 100644
--- a/math/gnumeric/pkg-plist
+++ b/math/gnumeric/pkg-plist
@@ -29,14 +29,14 @@ include/libspreadsheet-1-7/func.h
include/libspreadsheet-1-7/gnm-datetime.h
include/libspreadsheet-1-7/gnm-format.h
include/libspreadsheet-1-7/gnm-graph-window.h
+include/libspreadsheet-1-7/gnm-pane-impl.h
+include/libspreadsheet-1-7/gnm-pane.h
include/libspreadsheet-1-7/gnm-plugin.h
include/libspreadsheet-1-7/gnm-so-filled.h
include/libspreadsheet-1-7/gnm-so-line.h
include/libspreadsheet-1-7/gnm-so-polygon.h
include/libspreadsheet-1-7/gnm-style-impl.h
-include/libspreadsheet-1-7/gnumeric-canvas.h
include/libspreadsheet-1-7/gnumeric-gconf.h
-include/libspreadsheet-1-7/gnumeric-pane.h
include/libspreadsheet-1-7/gnumeric-simple-canvas.h
include/libspreadsheet-1-7/gnumeric.h
include/libspreadsheet-1-7/graph.h
@@ -249,9 +249,6 @@ lib/gnumeric/%%VERSION%%/plugins/uihello/plugin.xml
lib/gnumeric/%%VERSION%%/plugins/xbase/plugin.xml
lib/gnumeric/%%VERSION%%/plugins/xbase/xbase.la
lib/gnumeric/%%VERSION%%/plugins/xbase/xbase.so
-lib/goffice/0.4.1/plugins/gnumeric/gnumeric.la
-lib/goffice/0.4.1/plugins/gnumeric/gnumeric.so
-lib/goffice/0.4.1/plugins/gnumeric/plugin.xml
lib/libspreadsheet-%%VERSION%%.so
lib/libspreadsheet.la
lib/libspreadsheet.so
@@ -259,7 +256,6 @@ libdata/pkgconfig/libspreadsheet-1.7.pc
@exec update-desktop-database > /dev/null || /usr/bin/true
share/gnome/applications/gnumeric.desktop
share/gnome/gnumeric/%%VERSION%%/GNOME_Gnumeric-gtk.xml
-share/gnome/gnumeric/%%VERSION%%/Gnumeric-embed.xml
share/gnome/gnumeric/%%VERSION%%/autoformat-templates/3D/.category
share/gnome/gnumeric/%%VERSION%%/autoformat-templates/3D/autoformat.3D.button.xml
share/gnome/gnumeric/%%VERSION%%/autoformat-templates/3D/autoformat.3D.list.xml
@@ -384,6 +380,7 @@ share/gnome/help/gnumeric/C/data-delete.xml
share/gnome/help/gnumeric/C/data-entry-advanced.xml
share/gnome/help/gnumeric/C/data-entry-external.xml
share/gnome/help/gnumeric/C/data-entry.xml
+share/gnome/help/gnumeric/C/data-filter.xml
share/gnome/help/gnumeric/C/data-format.xml
share/gnome/help/gnumeric/C/data-generate.xml
share/gnome/help/gnumeric/C/data-insert.xml
@@ -941,7 +938,6 @@ share/locale/zh_TW/LC_MESSAGES/gnumeric.mo
@dirrm lib/gnumeric/%%VERSION%%/plugins
@dirrm lib/gnumeric/%%VERSION%%
@dirrm lib/gnumeric
-@dirrm lib/goffice/0.4.1/plugins/gnumeric
@dirrm include/libspreadsheet-1-7
@unexec update-desktop-database > /dev/null || /usr/bin/true
@dirrmtry share/locale/te/LC_MESSAGES