aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-03-26 01:05:20 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-03-26 01:05:20 +0000
commit487d872a5fe2b6f0f2e12aa78c38832b608187c0 (patch)
tree86d7f3e9c34b0b598c5618dde812ddac8ba3e431 /math
parentc3776ede08c5fb3e7188b0cf577002adab39c303 (diff)
downloadports-487d872a5fe2b6f0f2e12aa78c38832b608187c0.tar.gz
ports-487d872a5fe2b6f0f2e12aa78c38832b608187c0.zip
math/ceres-solver: update to 1.14.0
Notes
Notes: svn path=/head/; revision=465555
Diffstat (limited to 'math')
-rw-r--r--math/ceres-solver/Makefile15
-rw-r--r--math/ceres-solver/distinfo8
-rw-r--r--math/ceres-solver/pkg-plist5
3 files changed, 16 insertions, 12 deletions
diff --git a/math/ceres-solver/Makefile b/math/ceres-solver/Makefile
index c6496db0631c..3098944e14a4 100644
--- a/math/ceres-solver/Makefile
+++ b/math/ceres-solver/Makefile
@@ -1,13 +1,9 @@
# $FreeBSD$
PORTNAME= ceres-solver
-DISTVERSION= 1.13.0
-PORTREVISION= 4
+DISTVERSION= 1.14.0
CATEGORIES= math
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES= f58eacf082dd.patch:-p1
-
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Nonlinear least squares minimizer
@@ -23,6 +19,7 @@ USE_LDCONFIG= yes
SHEBANG_FILES= examples/slam/pose_graph_*/plot_results.py \
scripts/make_docs.py
CMAKE_ON= CXX11 BUILD_SHARED_LIBS
+CMAKE_OFF= BUILD_BENCHMARKS
LDFLAGS+= -Wl,--as-needed # -lccolamd -lcholmod -lrt from suitesparse
PLIST_SUB= VERSION=${DISTVERSION:C/rc.*//}
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME:S/-solver//}
@@ -32,8 +29,9 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= CUSTOM_BLAS EXAMPLES DOCS GFLAGS LAPACK OPENMP SCHUR TEST
OPTIONS_DEFAULT=CUSTOM_BLAS CXSPARSE OPENBLAS OPENMP SCHUR SUITESPARSE
-OPTIONS_RADIO= LAPACK
+OPTIONS_RADIO= LAPACK THREADS
OPTIONS_RADIO_LAPACK= ATLAS GOTOBLAS NETLIB OPENBLAS
+OPTIONS_RADIO_THREADS= OPENMP TBB
OPTIONS_GROUP= SPARSE
OPTIONS_GROUP_SPARSE= CXSPARSE EIGENSPARSE SUITESPARSE
@@ -59,6 +57,10 @@ OPENMP_VARS= OPENMP=gcc-
SCHUR_DESC= Fixed-size schur specializations
SCHUR_CMAKE_BOOL= SCHUR_SPECIALIZATIONS
+TBB_DESC= Intel threading building blocks
+TBB_LIB_DEPENDS= libtbb.so:devel/tbb
+TBB_CMAKE_BOOL= TBB
+
# XXX Unbundle googletest/googlemock
TEST_CMAKE_BOOL= BUILD_TESTING
TEST_TEST_TARGET= test ARGS="-V"
@@ -94,7 +96,6 @@ EIGENSPARSE_VARS= LICENSE+=LGPL21+ LICENSE_COMB=multi \
SUITESPARSE_DESC= SuiteSparse support
SUITESPARSE_LIB_DEPENDS=libspqr.so:math/suitesparse
SUITESPARSE_CMAKE_BOOL= SUITESPARSE
-SUITESPARSE_IMPLIES= LAPACK
post-patch-DOCS-on:
@${REINPLACE_CMD} -e 's,python,${PYTHON_CMD:T},' \
diff --git a/math/ceres-solver/distinfo b/math/ceres-solver/distinfo
index b94e5b4a92c4..414c93783849 100644
--- a/math/ceres-solver/distinfo
+++ b/math/ceres-solver/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1501744176
-SHA256 (ceres-solver-ceres-solver-1.13.0_GH0.tar.gz) = 51ccb201b61ac71501fb6ccef158f078a750bc796ee6a271cd535cfe338202e5
-SIZE (ceres-solver-ceres-solver-1.13.0_GH0.tar.gz) = 3586772
-SHA256 (f58eacf082dd.patch) = c372934476fae4a11e3a62f0037feeb65d01c27f05b95257b05335f4dfe999a6
-SIZE (f58eacf082dd.patch) = 2495
+TIMESTAMP = 1521691214
+SHA256 (ceres-solver-ceres-solver-1.14.0_GH0.tar.gz) = 1296330fcf1e09e6c2f926301916f64d4a4c5c0ff12d460a9bc5d4c48411518f
+SIZE (ceres-solver-ceres-solver-1.14.0_GH0.tar.gz) = 3654161
diff --git a/math/ceres-solver/pkg-plist b/math/ceres-solver/pkg-plist
index 3bb04fd0bed0..ed66052a2db3 100644
--- a/math/ceres-solver/pkg-plist
+++ b/math/ceres-solver/pkg-plist
@@ -3,6 +3,7 @@ include/ceres/autodiff_local_parameterization.h
include/ceres/c_api.h
include/ceres/ceres.h
include/ceres/conditioned_cost_function.h
+include/ceres/context.h
include/ceres/cost_function.h
include/ceres/cost_function_to_functor.h
include/ceres/covariance.h
@@ -12,6 +13,7 @@ include/ceres/dynamic_autodiff_cost_function.h
include/ceres/dynamic_cost_function.h
include/ceres/dynamic_cost_function_to_functor.h
include/ceres/dynamic_numeric_diff_cost_function.h
+include/ceres/evaluation_callback.h
include/ceres/fpclassify.h
include/ceres/gradient_checker.h
include/ceres/gradient_problem.h
@@ -40,6 +42,9 @@ include/ceres/problem.h
include/ceres/rotation.h
include/ceres/sized_cost_function.h
include/ceres/solver.h
+include/ceres/tiny_solver.h
+include/ceres/tiny_solver_autodiff_function.h
+include/ceres/tiny_solver_cost_function_adapter.h
include/ceres/types.h
include/ceres/version.h
lib/cmake/Ceres/CeresConfig.cmake