aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-04-04 07:13:35 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-04-04 07:13:35 +0000
commit107ad6127b980a1d3ff1d84102af874b342d898a (patch)
tree12969688baffe373555a318dd0ef76673732f41c /math
parent437f2150d6d94ed831245b42aa81fae1fa0fbe3e (diff)
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile2
-rw-r--r--math/mkl-dnn/distinfo3
-rw-r--r--math/onednn/Makefile (renamed from math/mkl-dnn/Makefile)18
-rw-r--r--math/onednn/distinfo5
-rw-r--r--math/onednn/files/patch-CMakeLists.txt (renamed from math/mkl-dnn/files/patch-CMakeLists.txt)12
-rw-r--r--math/onednn/files/patch-cmake_platform.cmake (renamed from math/mkl-dnn/files/patch-cmake_platform.cmake)15
-rw-r--r--math/onednn/pkg-descr (renamed from math/mkl-dnn/pkg-descr)0
-rw-r--r--math/onednn/pkg-plist (renamed from math/mkl-dnn/pkg-plist)4
8 files changed, 33 insertions, 26 deletions
diff --git a/math/Makefile b/math/Makefile
index eecdedf61173..d4b9769e7448 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -394,7 +394,6 @@
SUBDIR += mingw32-libgmp
SUBDIR += minisat
SUBDIR += miracl
- SUBDIR += mkl-dnn
SUBDIR += mlpack
SUBDIR += moab
SUBDIR += moo
@@ -511,6 +510,7 @@
SUBDIR += octave-forge-zeromq
SUBDIR += octomap
SUBDIR += oleo
+ SUBDIR += onednn
SUBDIR += openblas
SUBDIR += openfst
SUBDIR += openlibm
diff --git a/math/mkl-dnn/distinfo b/math/mkl-dnn/distinfo
deleted file mode 100644
index fa6067e2c852..000000000000
--- a/math/mkl-dnn/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1584687013
-SHA256 (intel-mkl-dnn-v1.2.2-f32e21b_GH0.tar.gz) = afc2bbbd89fcfbc713537ed6ee1d66ea5cefb1c2e6ab4ca9c76f5ea36fd797cd
-SIZE (intel-mkl-dnn-v1.2.2-f32e21b_GH0.tar.gz) = 4558242
diff --git a/math/mkl-dnn/Makefile b/math/onednn/Makefile
index 91b0c9e060db..8d772bfcf7af 100644
--- a/math/mkl-dnn/Makefile
+++ b/math/onednn/Makefile
@@ -1,10 +1,13 @@
# $FreeBSD$
-PORTNAME= mkl-dnn
+PORTNAME= onednn
DISTVERSIONPREFIX= v
-DISTVERSION= 1.2.2
+DISTVERSION= 1.3
CATEGORIES= math # machine-learning
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES= 1efd9ec1eaf351d6fa4ef614db1ef09742c85e39.patch:-p1
+
MAINTAINER= yuri@FreeBSD.org
COMMENT= Intel(R) Math Kernel Library for Deep Neural Networks
@@ -13,12 +16,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_i386= error: shift count >= width of type (and other errors), see https://github.com/intel/mkl-dnn/issues/315
-TEST_DEPENDS= bash:shells/bash
+TEST_DEPENDS= bash:shells/bash \
+ libsysinfo>0:devel/libsysinfo
-USES= cmake compiler:c++11-lang
+USES= cmake compiler:c++11-lang localbase:ldflags
USE_GITHUB= yes
-GH_ACCOUNT= intel
-GH_TAGNAME= f32e21b
+GH_ACCOUNT= oneapi-src
+GH_PROJECT= oneDNN
USE_LDCONFIG= yes
OPTIONS_DEFINE= OPENMP
@@ -33,7 +37,7 @@ CXXFLAGS_i386= -msse4.1
post-install:
@${RM} -r ${STAGEDIR}${PREFIX}/share/doc
-do-test: # some tests are known to fail: https://github.com/intel/mkl-dnn/issues/350
+do-test: # some tests are known to fail: https://github.com/intel/mkl-dnn/issues/350 (the upstream failed to reproduce it and closed the report)
@${REINPLACE_CMD} 's| /bin/bash | ${LOCALBASE}/bin/bash |' ${WRKSRC}/tests/CMakeLists.txt
@cd ${BUILD_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DBUILD_TESTS=ON ${CMAKE_SOURCE_PATH} && \
diff --git a/math/onednn/distinfo b/math/onednn/distinfo
new file mode 100644
index 000000000000..dc63c0d6ca62
--- /dev/null
+++ b/math/onednn/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1585981063
+SHA256 (oneapi-src-oneDNN-v1.3_GH0.tar.gz) = b87c23b40a93ef5e479c81028db71c4847225b1a170f82af5e79f1cda826d3bf
+SIZE (oneapi-src-oneDNN-v1.3_GH0.tar.gz) = 5173993
+SHA256 (1efd9ec1eaf351d6fa4ef614db1ef09742c85e39.patch) = 14edbf9910d1ce42fec30b4305f66123812f8bacdef26e9766c055286db0e856
+SIZE (1efd9ec1eaf351d6fa4ef614db1ef09742c85e39.patch) = 855
diff --git a/math/mkl-dnn/files/patch-CMakeLists.txt b/math/onednn/files/patch-CMakeLists.txt
index 7ba872462d5e..1c0e6c8163ed 100644
--- a/math/mkl-dnn/files/patch-CMakeLists.txt
+++ b/math/onednn/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2019-05-18 21:55:29 UTC
+--- CMakeLists.txt.orig 2020-03-31 16:33:27 UTC
+++ CMakeLists.txt
-@@ -73,7 +73,9 @@ include(CMakePackageConfigHelpers)
+@@ -92,7 +92,9 @@ include("cmake/mkldnn_compat.cmake")
include("cmake/utils.cmake")
include("cmake/options.cmake")
@@ -9,10 +9,10 @@
+ include("cmake/OpenMP.cmake")
+endif()
include("cmake/TBB.cmake")
+ include("cmake/OpenCL.cmake")
include("cmake/platform.cmake")
- include("cmake/SDL.cmake")
-@@ -87,8 +89,12 @@ enable_testing()
- include_directories(include)
+@@ -133,8 +135,12 @@ include(GNUInstallDirs)
+ include(CMakePackageConfigHelpers)
add_subdirectory(src)
-add_subdirectory(examples)
@@ -24,5 +24,5 @@
+ add_subdirectory(tests)
+endif()
- if(MKLDNN_INSTALL_MODE STREQUAL "BUNDLE")
+ if(DNNL_INSTALL_MODE STREQUAL "BUNDLE")
install(FILES LICENSE DESTINATION ${CMAKE_INSTALL_PREFIX})
diff --git a/math/mkl-dnn/files/patch-cmake_platform.cmake b/math/onednn/files/patch-cmake_platform.cmake
index 2fcd1d010dc4..23affea8113d 100644
--- a/math/mkl-dnn/files/patch-cmake_platform.cmake
+++ b/math/onednn/files/patch-cmake_platform.cmake
@@ -1,6 +1,6 @@
---- cmake/platform.cmake.orig 2019-12-24 01:47:09 UTC
+--- cmake/platform.cmake.orig 2020-03-31 16:33:27 UTC
+++ cmake/platform.cmake
-@@ -89,7 +89,6 @@ elseif(UNIX OR MINGW)
+@@ -95,7 +95,6 @@ elseif(UNIX OR MINGW)
append(CMAKE_CCXX_NOEXCEPT_FLAGS "-fno-exceptions")
# compiler specific settings
if(CMAKE_CXX_COMPILER_ID MATCHES "Clang")
@@ -8,11 +8,12 @@
# Clang cannot vectorize some loops with #pragma omp simd and gets
# very upset. Tell it that it's okay and that we love it
# unconditionally.
-@@ -133,7 +132,6 @@ elseif(UNIX OR MINGW)
- append(CMAKE_CCXX_SANITIZER_FLAGS "-g -fno-omit-frame-pointer")
+@@ -144,7 +143,7 @@ elseif(UNIX OR MINGW)
+ set(DNNL_ENABLE_JIT_PROFILING CACHE BOOL "OFF" FORCE)
+ message(WARNING "AArch64 build, DNNL_ENABLE_JIT_PROFILING is OFF")
+ else()
+- set(DEF_ARCH_OPT_FLAGS "-msse4.1")
++ #set(DEF_ARCH_OPT_FLAGS "-msse4.1")
endif()
- elseif("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
-- set(DEF_ARCH_OPT_FLAGS "-msse4.1")
# suppress warning on assumptions made regarding overflow (#146)
append(CMAKE_CCXX_NOWARN_FLAGS "-Wno-strict-overflow")
- elseif(CMAKE_CXX_COMPILER_ID STREQUAL "Intel")
diff --git a/math/mkl-dnn/pkg-descr b/math/onednn/pkg-descr
index 6c6103fa5207..6c6103fa5207 100644
--- a/math/mkl-dnn/pkg-descr
+++ b/math/onednn/pkg-descr
diff --git a/math/mkl-dnn/pkg-plist b/math/onednn/pkg-plist
index 0e59c5bbebed..37e6d19ae58e 100644
--- a/math/mkl-dnn/pkg-plist
+++ b/math/onednn/pkg-plist
@@ -17,7 +17,7 @@ lib/cmake/dnnl/dnnl-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/dnnl/dnnl-targets.cmake
lib/libdnnl.so
lib/libdnnl.so.1
-lib/libdnnl.so.1.1
+lib/libdnnl.so.1.3
lib/libmkldnn.so
lib/libmkldnn.so.1
-lib/libmkldnn.so.1.1
+lib/libmkldnn.so.1.3