aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-04-24 19:47:52 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-04-24 19:47:52 +0000
commit662486c37e9e3dadb782b011ee4f12bce66f5a34 (patch)
tree5e688c4622e02247c507e935980b3059df4d817e /math
parentd3f1f4d41271509ffa43b7e5d34fc2e4855b1047 (diff)
downloadports-662486c37e9e3dadb782b011ee4f12bce66f5a34.tar.gz
ports-662486c37e9e3dadb782b011ee4f12bce66f5a34.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/elmer-umfpack/Makefile38
-rw-r--r--math/elmer-umfpack/distinfo3
-rw-r--r--math/elmer-umfpack/pkg-descr8
-rw-r--r--math/elmer-umfpack/pkg-plist5
5 files changed, 55 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 6c2e909db004..f420d6da3d04 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -45,6 +45,7 @@
SUBDIR += drgeo
SUBDIR += e
SUBDIR += eispack
+ SUBDIR += elmer-umfpack
SUBDIR += emacs-calc
SUBDIR += emc2
SUBDIR += entropy
diff --git a/math/elmer-umfpack/Makefile b/math/elmer-umfpack/Makefile
new file mode 100644
index 000000000000..ede2e594dca5
--- /dev/null
+++ b/math/elmer-umfpack/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: elmer-umfpack
+# Date created: 5 Jan 2006
+# Whom: Pedro Giffuni <giffunip@asme.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= umfpack
+PORTVERSION= 4.4a
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.funet.fi/pub/sci/physics/elmer/
+PKGNAMEPREFIX= elmer-
+
+MAINTAINER= giffunip@asme.org
+COMMENT= UMFPACK library used by ELMER FEM package
+
+BUILD_DEPENDS= ${FC}:${PORTSDIR}/lang/gfortran
+
+CONFLICTS= umfpack-[0-9].[0-9]*
+
+USE_GCC= 4.1+
+WITH_FORTRAN= yes
+FC= ${LOCALBASE}/bin/gfortran41
+F77= ${FC}
+CONFIGURE_ENV+= FC=${FC} F77=${FC}
+GNU_CONFIGURE= yes
+ALL_TARGET=
+
+# This should be looked up by autoconf
+CFLAGS+= -DGETRUSAGE
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/elmer-umfpack/distinfo b/math/elmer-umfpack/distinfo
new file mode 100644
index 000000000000..8a5fb1e83a83
--- /dev/null
+++ b/math/elmer-umfpack/distinfo
@@ -0,0 +1,3 @@
+MD5 (umfpack-4.4a.tar.gz) = 489121be619bf35d83f5cf2e83143ea1
+SHA256 (umfpack-4.4a.tar.gz) = 02ae96af5548aa867d7b025d51aebffb86116a6f6d2fbd9f33a1a40436e22dee
+SIZE (umfpack-4.4a.tar.gz) = 439842
diff --git a/math/elmer-umfpack/pkg-descr b/math/elmer-umfpack/pkg-descr
new file mode 100644
index 000000000000..1db1cc2e0618
--- /dev/null
+++ b/math/elmer-umfpack/pkg-descr
@@ -0,0 +1,8 @@
+This is a slightly modified version of umfpack for use with the Elmer FEM
+package.
+
+Among other small changes, Elmer calls umfpack routines from f90 using
+umf4_f77wrapper.c from umfpacks demo directory. The elmer-umfpack build
+compiles this and includes it in the libumfpack.a.
+
+WWW: http://www.csc.fi/elmer/
diff --git a/math/elmer-umfpack/pkg-plist b/math/elmer-umfpack/pkg-plist
new file mode 100644
index 000000000000..8203578a7668
--- /dev/null
+++ b/math/elmer-umfpack/pkg-plist
@@ -0,0 +1,5 @@
+include/amd.h
+include/umfpack.h
+lib/libamd.a
+lib/libamdf77.a
+lib/libumfpack.a