aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-28 02:53:51 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-28 02:53:51 +0000
commit7b49da83b63e8aa9dd9e42cac32d4511374afef5 (patch)
treee2b3e8d42fa3e204167395f4b4a54abbbc86da9a /math
parentc2595f452cc95ef57883a9ca501dfb587ad756cd (diff)
downloadports-7b49da83b63e8aa9dd9e42cac32d4511374afef5.tar.gz
ports-7b49da83b63e8aa9dd9e42cac32d4511374afef5.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/scilab-toolbox-sivp/Makefile39
-rw-r--r--math/scilab-toolbox-sivp/distinfo3
-rw-r--r--math/scilab-toolbox-sivp/files/patch-configure11
-rw-r--r--math/scilab-toolbox-sivp/pkg-descr6
-rw-r--r--math/scilab-toolbox-sivp/pkg-plist108
6 files changed, 168 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 4be648b2d366..baf3cbd43e1d 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -342,6 +342,7 @@
SUBDIR += scalapack
SUBDIR += scigraphica
SUBDIR += scilab
+ SUBDIR += scilab-toolbox-sivp
SUBDIR += scilab-toolbox-swt
SUBDIR += sdpa
SUBDIR += sdpara
diff --git a/math/scilab-toolbox-sivp/Makefile b/math/scilab-toolbox-sivp/Makefile
new file mode 100644
index 000000000000..6997b21f699f
--- /dev/null
+++ b/math/scilab-toolbox-sivp/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: sivp
+# Date created: 2007-09-15
+# Whom: Max Brazhnikov <makc@issp.ac.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sivp
+DISTVERSION= 0.4.3
+CATEGORIES= math graphics multimedia
+MASTER_SITES= SF
+PKGNAMEPREFIX= scilab-toolbox-
+
+MAINTAINER= makc@issp.ac.ru
+COMMENT= Scilab Image and Video Processing Toolbox
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/scilab:${PORTSDIR}/math/scilab \
+ ${LOCALBASE}/bin/xsltproc:${PORTSDIR}/textproc/libxslt
+LIB_DEPENDS= cv.1:${PORTSDIR}/graphics/opencv
+RUN_DEPENDS= ${LOCALBASE}/bin/scilab:${PORTSDIR}/math/scilab
+
+SCILABDIR?= lib/scilab
+CONTRIBDIR?= ${SCILABDIR}/contrib
+TOOLBOXDIR?= ${CONTRIBDIR}/${PORTNAME}
+
+USE_LDCONFIG= ${TOOLBOXDIR}
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+=--prefix=${PREFIX}/${TOOLBOXDIR}
+CONFIGURE_ENV+= SCI="${LOCALBASE}/${SCILABDIR}"
+
+PLIST_SUB= TOOLBOXDIR=${TOOLBOXDIR}
+
+pre-everything::
+ @${ECHO_CMD}
+ @${ECHO_CMD} "If you want video support, OpenCV should be compiled with ffmpeg!"
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/math/scilab-toolbox-sivp/distinfo b/math/scilab-toolbox-sivp/distinfo
new file mode 100644
index 000000000000..47c83d522310
--- /dev/null
+++ b/math/scilab-toolbox-sivp/distinfo
@@ -0,0 +1,3 @@
+MD5 (sivp-0.4.3.tar.gz) = d49d4d6503a1026867145428c6374183
+SHA256 (sivp-0.4.3.tar.gz) = 2d0e4129daf2ccd2631040a602247fe5083e973a9569cb869b024ee4cbef578a
+SIZE (sivp-0.4.3.tar.gz) = 2551217
diff --git a/math/scilab-toolbox-sivp/files/patch-configure b/math/scilab-toolbox-sivp/files/patch-configure
new file mode 100644
index 000000000000..ee696c7800f3
--- /dev/null
+++ b/math/scilab-toolbox-sivp/files/patch-configure
@@ -0,0 +1,11 @@
+--- ./configure.orig 2007-05-19 13:29:59.000000000 +0400
++++ ./configure 2007-09-15 17:49:25.000000000 +0400
+@@ -19741,8 +19741,6 @@
+
+ if test "x$prefix" = xNONE; then
+ prefix="${SCIDIR}/contrib/${PACKAGE_NAME}-${PACKAGE_VERSION}"
+-else
+- prefix="${prefix}/${PACKAGE_NAME}-${PACKAGE_VERSION}"
+ fi
+
+ TOOLBOXDIR=$prefix
diff --git a/math/scilab-toolbox-sivp/pkg-descr b/math/scilab-toolbox-sivp/pkg-descr
new file mode 100644
index 000000000000..1a4b365d81e6
--- /dev/null
+++ b/math/scilab-toolbox-sivp/pkg-descr
@@ -0,0 +1,6 @@
+SIVP stands for Scilab Image and Video Processing toolbox. SIVP
+intends to do image processing and video processing tasks. SIVP is
+meant to be a useful, efficient, and free image and video processing
+toolbox for Scilab.
+
+WWW: http://sivp.sourceforge.net/
diff --git a/math/scilab-toolbox-sivp/pkg-plist b/math/scilab-toolbox-sivp/pkg-plist
new file mode 100644
index 000000000000..8914a257c98b
--- /dev/null
+++ b/math/scilab-toolbox-sivp/pkg-plist
@@ -0,0 +1,108 @@
+%%TOOLBOXDIR%%/builder.sce
+%%TOOLBOXDIR%%/demos/camera.sce
+%%TOOLBOXDIR%%/demos/canny.sce
+%%TOOLBOXDIR%%/demos/image.sce
+%%TOOLBOXDIR%%/demos/noise.sce
+%%TOOLBOXDIR%%/demos/sivp.dem
+%%TOOLBOXDIR%%/demos/video.sce
+%%TOOLBOXDIR%%/images/baboon.png
+%%TOOLBOXDIR%%/images/lena.png
+%%TOOLBOXDIR%%/images/peppers.png
+%%TOOLBOXDIR%%/images/video.avi
+%%TOOLBOXDIR%%/lib/libsivp-0.4.3.so
+%%TOOLBOXDIR%%/lib/libsivp-0.4.3.so.0
+%%TOOLBOXDIR%%/lib/libsivp.la
+%%TOOLBOXDIR%%/lib/libsivp.so
+%%TOOLBOXDIR%%/loader.sce
+%%TOOLBOXDIR%%/macros/corr2.bin
+%%TOOLBOXDIR%%/macros/edge.bin
+%%TOOLBOXDIR%%/macros/fspecial.bin
+%%TOOLBOXDIR%%/macros/genlib
+%%TOOLBOXDIR%%/macros/hsv2rgb.bin
+%%TOOLBOXDIR%%/macros/im2bw.bin
+%%TOOLBOXDIR%%/macros/im2double.bin
+%%TOOLBOXDIR%%/macros/im2int16.bin
+%%TOOLBOXDIR%%/macros/im2int32.bin
+%%TOOLBOXDIR%%/macros/im2int8.bin
+%%TOOLBOXDIR%%/macros/im2uint16.bin
+%%TOOLBOXDIR%%/macros/im2uint8.bin
+%%TOOLBOXDIR%%/macros/imabsdiff.bin
+%%TOOLBOXDIR%%/macros/imadd.bin
+%%TOOLBOXDIR%%/macros/imcomplement.bin
+%%TOOLBOXDIR%%/macros/imcrop.bin
+%%TOOLBOXDIR%%/macros/imdivide.bin
+%%TOOLBOXDIR%%/macros/imhist.bin
+%%TOOLBOXDIR%%/macros/imlincomb.bin
+%%TOOLBOXDIR%%/macros/immultiply.bin
+%%TOOLBOXDIR%%/macros/imnoise.bin
+%%TOOLBOXDIR%%/macros/imresize.bin
+%%TOOLBOXDIR%%/macros/imshow.bin
+%%TOOLBOXDIR%%/macros/imshow.tcl
+%%TOOLBOXDIR%%/macros/imsubtract.bin
+%%TOOLBOXDIR%%/macros/imwrite.bin
+%%TOOLBOXDIR%%/macros/lib
+%%TOOLBOXDIR%%/macros/mat2gray.bin
+%%TOOLBOXDIR%%/macros/mean2.bin
+%%TOOLBOXDIR%%/macros/names
+%%TOOLBOXDIR%%/macros/ntsc2rgb.bin
+%%TOOLBOXDIR%%/macros/rgb2gray.bin
+%%TOOLBOXDIR%%/macros/rgb2hsv.bin
+%%TOOLBOXDIR%%/macros/rgb2ntsc.bin
+%%TOOLBOXDIR%%/macros/rgb2ycbcr.bin
+%%TOOLBOXDIR%%/macros/std2.bin
+%%TOOLBOXDIR%%/macros/xs2im.bin
+%%TOOLBOXDIR%%/macros/ycbcr2rgb.bin
+%%TOOLBOXDIR%%/man/addframe.htm
+%%TOOLBOXDIR%%/man/aviclose.htm
+%%TOOLBOXDIR%%/man/avicloseall.htm
+%%TOOLBOXDIR%%/man/avifile.htm
+%%TOOLBOXDIR%%/man/aviinfo.htm
+%%TOOLBOXDIR%%/man/avilistopened.htm
+%%TOOLBOXDIR%%/man/aviopen.htm
+%%TOOLBOXDIR%%/man/avireadframe.htm
+%%TOOLBOXDIR%%/man/camopen.htm
+%%TOOLBOXDIR%%/man/corr2.htm
+%%TOOLBOXDIR%%/man/edge.htm
+%%TOOLBOXDIR%%/man/filter2.htm
+%%TOOLBOXDIR%%/man/fspecial.htm
+%%TOOLBOXDIR%%/man/hsv2rgb.htm
+%%TOOLBOXDIR%%/man/im2bw.htm
+%%TOOLBOXDIR%%/man/im2double.htm
+%%TOOLBOXDIR%%/man/im2int16.htm
+%%TOOLBOXDIR%%/man/im2int32.htm
+%%TOOLBOXDIR%%/man/im2int8.htm
+%%TOOLBOXDIR%%/man/im2uint16.htm
+%%TOOLBOXDIR%%/man/im2uint8.htm
+%%TOOLBOXDIR%%/man/imabsdiff.htm
+%%TOOLBOXDIR%%/man/imadd.htm
+%%TOOLBOXDIR%%/man/imcomplement.htm
+%%TOOLBOXDIR%%/man/imcrop.htm
+%%TOOLBOXDIR%%/man/imdivide.htm
+%%TOOLBOXDIR%%/man/imfilter.htm
+%%TOOLBOXDIR%%/man/imfinfo.htm
+%%TOOLBOXDIR%%/man/imhist.htm
+%%TOOLBOXDIR%%/man/imlincomb.htm
+%%TOOLBOXDIR%%/man/immultiply.htm
+%%TOOLBOXDIR%%/man/imnoise.htm
+%%TOOLBOXDIR%%/man/imread.htm
+%%TOOLBOXDIR%%/man/imresize.htm
+%%TOOLBOXDIR%%/man/imshow.htm
+%%TOOLBOXDIR%%/man/imsubtract.htm
+%%TOOLBOXDIR%%/man/imwrite.htm
+%%TOOLBOXDIR%%/man/mat2gray.htm
+%%TOOLBOXDIR%%/man/mean2.htm
+%%TOOLBOXDIR%%/man/ntsc2rgb.htm
+%%TOOLBOXDIR%%/man/rgb2gray.htm
+%%TOOLBOXDIR%%/man/rgb2hsv.htm
+%%TOOLBOXDIR%%/man/rgb2ntsc.htm
+%%TOOLBOXDIR%%/man/rgb2ycbcr.htm
+%%TOOLBOXDIR%%/man/std2.htm
+%%TOOLBOXDIR%%/man/whatis.htm
+%%TOOLBOXDIR%%/man/xs2im.htm
+%%TOOLBOXDIR%%/man/ycbcr2rgb.htm
+@dirrm %%TOOLBOXDIR%%/man
+@dirrm %%TOOLBOXDIR%%/macros
+@dirrm %%TOOLBOXDIR%%/lib
+@dirrm %%TOOLBOXDIR%%/images
+@dirrm %%TOOLBOXDIR%%/demos
+@dirrm %%TOOLBOXDIR%%