aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-08-05 12:58:54 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-08-05 12:58:54 +0000
commit7adc632e52833fcbf02eb12cb7b4a09f34cb8688 (patch)
tree152451a3c23d4f96bc0518ba0d7ad9547ed6d999 /math
parenta9ff518a2a1b27a599f18bf4a55b0c4235186c34 (diff)
downloadports-7adc632e52833fcbf02eb12cb7b4a09f34cb8688.tar.gz
ports-7adc632e52833fcbf02eb12cb7b4a09f34cb8688.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/py-basemap/Makefile38
1 files changed, 10 insertions, 28 deletions
diff --git a/math/py-basemap/Makefile b/math/py-basemap/Makefile
index 7fe6a1c3dcbf..8bf3473aca9d 100644
--- a/math/py-basemap/Makefile
+++ b/math/py-basemap/Makefile
@@ -9,47 +9,29 @@ MASTER_SITES= SF/matplotlib/matplotlib-toolkits/${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Plots data on map projections (with continental and political boundaries)
+COMMENT= Plots data on map projections with continental and political boundaries
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/matplotlib/:${PORTSDIR}/math/py-matplotlib
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
DATADIR= ${PREFIX}/share/py-${PORTNAME}-data
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
MAKE_ENV= BASEMAP_DATA_PATH=${DATADIR}
-PLISTDIR= ${PYTHON_SITELIBDIR}/matplotlib/toolkits/basemap \
- ${PYTHON_SITELIBDIR}/shapelib \
- ${PYTHON_SITELIBDIR}/dbflib \
- ${PYTHON_SITELIBDIR}/dbflibc.so \
- ${PYTHON_SITELIBDIR}/shptree.so \
- ${PYTHON_SITELIBDIR}/shapelibc.so \
- ${PYTHON_SITELIBDIR}/pyproj.so \
- ${DATADIR}
-.if !defined(NOPORTDOCS)
-PLISTDIR+= ${EXAMPLESDIR}
-.endif
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= EXAMPLES
+
+PORTEXAMPLES= *
+
post-patch:
@${GREP} -lR "share/basemap" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
-e "s,share/basemap,share/py-basemap-data,g"
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
-.endif
-.for dir in ${PLISTDIR}
- @${FIND} ${dir} ! -type d | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${dir} -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.endfor
- @${ECHO} "@unexec rmdir %D/${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}/matplotlib/toolkits 2> /dev/null || true" >> ${TMPPLIST}
-
-.include <bsd.port.post.mk>
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>