aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2019-09-20 07:19:07 +0000
committerThierry Thomas <thierry@FreeBSD.org>2019-09-20 07:19:07 +0000
commit3d27d6fc3eef4ba25ac91cf3cee1f68657cf95a6 (patch)
tree6ed2b2c76381fdfa743a38887964d9ee97e59d41 /math
parent421cc3859fc840d1725eb4b8b20289b3ec5ac809 (diff)
downloadports-3d27d6fc3eef4ba25ac91cf3cee1f68657cf95a6.tar.gz
ports-3d27d6fc3eef4ba25ac91cf3cee1f68657cf95a6.zip
Re-enable parallel build.
Submitted by: jkim
Notes
Notes: svn path=/head/; revision=512393
Diffstat (limited to 'math')
-rw-r--r--math/suitesparse/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index 15c41de55eef..c63b299eee0d 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -45,6 +45,7 @@ CHOLMOD_CONFIG=
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${WRKSRC}/lib # prevent linking with shared libs from the preinstalled older versions
+MAKE_ARGS+= JOBS="${MAKE_JOBS_NUMBER}"
MAKE_ARGS+= MY_METIS_LIB="-L${LOCALBASE}/lib -lmetis $(LDFLAGS)"
pre-configure:
@@ -76,9 +77,9 @@ do-configure:
do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} PICFLAG= \
- LD_LIBRARY_PATH=${WRKDIR}/SuiteSparse/lib ${MAKE_CMD} ${_MAKE_JOBS} ${MAKE_ARGS}
+ LD_LIBRARY_PATH=${WRKDIR}/SuiteSparse/lib ${MAKE_CMD} ${MAKE_ARGS}
cd ${WRKSRC_SHARED} && ${SETENV} ${MAKE_ENV} PICFLAG=${PICFLAG} \
- LD_LIBRARY_PATH=${WRKDIR}/SuiteSparse/lib ${MAKE_CMD} ${_MAKE_JOBS} ${MAKE_ARGS}
+ LD_LIBRARY_PATH=${WRKDIR}/SuiteSparse/lib ${MAKE_CMD} ${MAKE_ARGS}
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/include/suitesparse