aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2006-08-07 01:27:36 +0000
committerMaho Nakata <maho@FreeBSD.org>2006-08-07 01:27:36 +0000
commit3fe1acd7095da1e7798c61b109b4f40cfeeca95f (patch)
tree9b21da720d7a4ce00f26f64f34da119bd4c88267 /math
parent5a72cec32adf16e89687483a420869146cfe6d75 (diff)
downloadports-3fe1acd7095da1e7798c61b109b4f40cfeeca95f.tar.gz
ports-3fe1acd7095da1e7798c61b109b4f40cfeeca95f.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/suitesparse/Makefile13
-rw-r--r--math/ufsparse/Makefile13
2 files changed, 20 insertions, 6 deletions
diff --git a/math/suitesparse/Makefile b/math/suitesparse/Makefile
index 11d6657abc78..813d6962c56b 100644
--- a/math/suitesparse/Makefile
+++ b/math/suitesparse/Makefile
@@ -16,12 +16,19 @@ COMMENT= UFspace is a set of packages for sparse matrices calculation
BUILD_DEPENDS= ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis
+.if defined(WITH_BLAS)
+LIB_DEPENDS+= blas.1:${PORTSDIR}/math/blas
+BLAS= -L${LOCALBASE}/lib -lblas
+LAPACK= -L${LOCALBASE}/lib -llapack
+.else
+LIB_DEPENDS+= atlas.1:${PORTSDIR}/math/atlas
+BLAS= -L${LOCALBASE}/lib -lf77blas -latlas -lg2c
+LAPACK= -L${LOCALBASE}/lib -lalapack -lcblas
+.endif
+
USE_GMAKE= yes
ALL_TARGET=
-BLAS= -L${LOCALBASE}/lib -lf77blas -latlas -lg2c
-LAPACK= -L${LOCALBASE}/lib -lalapack -lcblas
-
post-patch:
@${REINPLACE_CMD} -e 's,%%CC%%,${CC},g' \
-e 's,%%CFLAGS%%,${CFLAGS},g' \
diff --git a/math/ufsparse/Makefile b/math/ufsparse/Makefile
index 11d6657abc78..813d6962c56b 100644
--- a/math/ufsparse/Makefile
+++ b/math/ufsparse/Makefile
@@ -16,12 +16,19 @@ COMMENT= UFspace is a set of packages for sparse matrices calculation
BUILD_DEPENDS= ${LOCALBASE}/lib/libmetis.a:${PORTSDIR}/math/metis
+.if defined(WITH_BLAS)
+LIB_DEPENDS+= blas.1:${PORTSDIR}/math/blas
+BLAS= -L${LOCALBASE}/lib -lblas
+LAPACK= -L${LOCALBASE}/lib -llapack
+.else
+LIB_DEPENDS+= atlas.1:${PORTSDIR}/math/atlas
+BLAS= -L${LOCALBASE}/lib -lf77blas -latlas -lg2c
+LAPACK= -L${LOCALBASE}/lib -lalapack -lcblas
+.endif
+
USE_GMAKE= yes
ALL_TARGET=
-BLAS= -L${LOCALBASE}/lib -lf77blas -latlas -lg2c
-LAPACK= -L${LOCALBASE}/lib -lalapack -lcblas
-
post-patch:
@${REINPLACE_CMD} -e 's,%%CC%%,${CC},g' \
-e 's,%%CFLAGS%%,${CFLAGS},g' \