aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-05-02 17:33:29 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-05-02 17:33:29 +0000
commit91418758d4d9ff8c1c8a7190784899ca52fc4dee (patch)
tree4720d2c342c42b6bb246e443f2a8a177524e562c /math
parent4af759d858682d44ad146cc6d1c843279611b950 (diff)
downloadports-91418758d4d9ff8c1c8a7190784899ca52fc4dee.tar.gz
ports-91418758d4d9ff8c1c8a7190784899ca52fc4dee.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/R-cran-car/Makefile21
-rw-r--r--math/R-cran-car/distinfo3
-rw-r--r--math/R-cran-car/pkg-descr10
-rw-r--r--math/R-cran-car/pkg-plist304
5 files changed, 339 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 1a648a8be6dd..0db8c7979283 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -8,6 +8,7 @@
SUBDIR += R
SUBDIR += R-cran-RSvgDevice
SUBDIR += R-cran-Zelig
+ SUBDIR += R-cran-car
SUBDIR += R-cran-gpclib
SUBDIR += R-cran-sm
SUBDIR += R-sp
diff --git a/math/R-cran-car/Makefile b/math/R-cran-car/Makefile
new file mode 100644
index 000000000000..ae0878e872f5
--- /dev/null
+++ b/math/R-cran-car/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: car
+# Date created: 13 April 2009
+# Whom: David Naylor <dragonsa@highveldmail.co.za>
+#
+# $FreeBSD$
+#
+
+PORTNAME= car
+PORTVERSION= 1.2.13
+CATEGORIES= math
+PKGNAMEPREFIX= R-cran-
+DISTNAME= ${PORTNAME}_1.2-13
+
+MAINTAINER= dragonsa@highveldmail.co.za
+COMMENT= Companion to Applied Regression for R
+
+R_MOD= yes
+
+.include "${.CURDIR}/../../math/R-cran-sm/files/bsd.cran.mk"
+
+.include <bsd.port.mk>
diff --git a/math/R-cran-car/distinfo b/math/R-cran-car/distinfo
new file mode 100644
index 000000000000..b55a4c96024a
--- /dev/null
+++ b/math/R-cran-car/distinfo
@@ -0,0 +1,3 @@
+MD5 (car_1.2-13.tar.gz) = 627e36581b99cfb0660d263e3e7ccb31
+SHA256 (car_1.2-13.tar.gz) = e4d62b4fa7c0c80a3f6323cc2004d1b01d6b4cdb61f63695203d5788df0f0c78
+SIZE (car_1.2-13.tar.gz) = 222129
diff --git a/math/R-cran-car/pkg-descr b/math/R-cran-car/pkg-descr
new file mode 100644
index 000000000000..9d7a0f185386
--- /dev/null
+++ b/math/R-cran-car/pkg-descr
@@ -0,0 +1,10 @@
+This package accompanies J. Fox, An R and S-PLUS Companion to Applied
+Regression, Sage, 2002. The package contains mostly functions for applied
+regression, linear models, and generalized linear models, with an emphasis on
+regression diagnostics, particularly graphical diagnostic methods. There are
+also some utility functions. With some exceptions, I have tried not to duplicate
+capabilities in the basic distribution of R, nor in widely used packages. Where
+relevant, the functions in car are consistent with na.action = na.omit or
+na.exclude.
+
+WWW: http://cran.r-project.org/web/packages/car/index.html
diff --git a/math/R-cran-car/pkg-plist b/math/R-cran-car/pkg-plist
new file mode 100644
index 000000000000..e6d404209814
--- /dev/null
+++ b/math/R-cran-car/pkg-plist
@@ -0,0 +1,304 @@
+%%R_MOD_DIR%%/CHANGES
+%%R_MOD_DIR%%/CONTENTS
+%%R_MOD_DIR%%/DESCRIPTION
+%%R_MOD_DIR%%/INDEX
+%%R_MOD_DIR%%/Meta/Rd.rds
+%%R_MOD_DIR%%/Meta/data.rds
+%%R_MOD_DIR%%/Meta/hsearch.rds
+%%R_MOD_DIR%%/Meta/nsInfo.rds
+%%R_MOD_DIR%%/Meta/package.rds
+%%R_MOD_DIR%%/NAMESPACE
+%%R_MOD_DIR%%/R-ex/Anova.R
+%%R_MOD_DIR%%/R-ex/Ask.R
+%%R_MOD_DIR%%/R-ex/Contrasts.R
+%%R_MOD_DIR%%/R-ex/Ellipses.R
+%%R_MOD_DIR%%/R-ex/OBrienKaiser.R
+%%R_MOD_DIR%%/R-ex/Pottery.R
+%%R_MOD_DIR%%/R-ex/Soils.R
+%%R_MOD_DIR%%/R-ex/Transformation.Axes.R
+%%R_MOD_DIR%%/R-ex/Var.R
+%%R_MOD_DIR%%/R-ex/av.plots.R
+%%R_MOD_DIR%%/R-ex/box.cox.R
+%%R_MOD_DIR%%/R-ex/box.cox.powers.R
+%%R_MOD_DIR%%/R-ex/box.cox.var.R
+%%R_MOD_DIR%%/R-ex/box.tidwell.R
+%%R_MOD_DIR%%/R-ex/ceres.plots.R
+%%R_MOD_DIR%%/R-ex/cookd.R
+%%R_MOD_DIR%%/R-ex/cr.plots.R
+%%R_MOD_DIR%%/R-ex/durbin.watson.R
+%%R_MOD_DIR%%/R-ex/hccm.R
+%%R_MOD_DIR%%/R-ex/influencePlot.R
+%%R_MOD_DIR%%/R-ex/levene.test.R
+%%R_MOD_DIR%%/R-ex/leverage.plots.R
+%%R_MOD_DIR%%/R-ex/linear.hypothesis.R
+%%R_MOD_DIR%%/R-ex/logit.R
+%%R_MOD_DIR%%/R-ex/n.bins.R
+%%R_MOD_DIR%%/R-ex/ncv.test.R
+%%R_MOD_DIR%%/R-ex/outlier.test.R
+%%R_MOD_DIR%%/R-ex/panel.car.R
+%%R_MOD_DIR%%/R-ex/qq.plot.R
+%%R_MOD_DIR%%/R-ex/recode.R
+%%R_MOD_DIR%%/R-ex/reg.line.R
+%%R_MOD_DIR%%/R-ex/scatterplot.R
+%%R_MOD_DIR%%/R-ex/scatterplot.matrix.R
+%%R_MOD_DIR%%/R-ex/some.R
+%%R_MOD_DIR%%/R-ex/spread.level.plot.R
+%%R_MOD_DIR%%/R-ex/subsets.R
+%%R_MOD_DIR%%/R-ex/symbox.R
+%%R_MOD_DIR%%/R-ex/vif.R
+%%R_MOD_DIR%%/R-ex/which.names.R
+%%R_MOD_DIR%%/R/car
+%%R_MOD_DIR%%/R/car.rdb
+%%R_MOD_DIR%%/R/car.rdx
+%%R_MOD_DIR%%/data/Rdata.rdb
+%%R_MOD_DIR%%/data/Rdata.rds
+%%R_MOD_DIR%%/data/Rdata.rdx
+%%R_MOD_DIR%%/help/Adler
+%%R_MOD_DIR%%/help/AnIndex
+%%R_MOD_DIR%%/help/Angell
+%%R_MOD_DIR%%/help/Anova
+%%R_MOD_DIR%%/help/Anscombe
+%%R_MOD_DIR%%/help/Ask
+%%R_MOD_DIR%%/help/Baumann
+%%R_MOD_DIR%%/help/Bfox
+%%R_MOD_DIR%%/help/Blackmoor
+%%R_MOD_DIR%%/help/Burt
+%%R_MOD_DIR%%/help/Can.pop
+%%R_MOD_DIR%%/help/Chile
+%%R_MOD_DIR%%/help/Chirot
+%%R_MOD_DIR%%/help/Contrasts
+%%R_MOD_DIR%%/help/Cowles
+%%R_MOD_DIR%%/help/Davis
+%%R_MOD_DIR%%/help/DavisThin
+%%R_MOD_DIR%%/help/Duncan
+%%R_MOD_DIR%%/help/Ellipses
+%%R_MOD_DIR%%/help/Ericksen
+%%R_MOD_DIR%%/help/Florida
+%%R_MOD_DIR%%/help/Freedman
+%%R_MOD_DIR%%/help/Friendly
+%%R_MOD_DIR%%/help/Ginzberg
+%%R_MOD_DIR%%/help/Greene
+%%R_MOD_DIR%%/help/Guyer
+%%R_MOD_DIR%%/help/Hartnagel
+%%R_MOD_DIR%%/help/Leinhardt
+%%R_MOD_DIR%%/help/Mandel
+%%R_MOD_DIR%%/help/Migration
+%%R_MOD_DIR%%/help/Moore
+%%R_MOD_DIR%%/help/Mroz
+%%R_MOD_DIR%%/help/OBrienKaiser
+%%R_MOD_DIR%%/help/Ornstein
+%%R_MOD_DIR%%/help/Pottery
+%%R_MOD_DIR%%/help/Prestige
+%%R_MOD_DIR%%/help/Quartet
+%%R_MOD_DIR%%/help/Robey
+%%R_MOD_DIR%%/help/SLID
+%%R_MOD_DIR%%/help/Sahlins
+%%R_MOD_DIR%%/help/Soils
+%%R_MOD_DIR%%/help/States
+%%R_MOD_DIR%%/help/Transformation.Axes
+%%R_MOD_DIR%%/help/UN
+%%R_MOD_DIR%%/help/US.pop
+%%R_MOD_DIR%%/help/Var
+%%R_MOD_DIR%%/help/Vocab
+%%R_MOD_DIR%%/help/Womenlf
+%%R_MOD_DIR%%/help/av.plots
+%%R_MOD_DIR%%/help/box.cox
+%%R_MOD_DIR%%/help/box.cox.powers
+%%R_MOD_DIR%%/help/box.cox.var
+%%R_MOD_DIR%%/help/box.tidwell
+%%R_MOD_DIR%%/help/car-internal
+%%R_MOD_DIR%%/help/car-package
+%%R_MOD_DIR%%/help/ceres.plots
+%%R_MOD_DIR%%/help/cookd
+%%R_MOD_DIR%%/help/cr.plots
+%%R_MOD_DIR%%/help/durbin.watson
+%%R_MOD_DIR%%/help/hccm
+%%R_MOD_DIR%%/help/influencePlot
+%%R_MOD_DIR%%/help/levene.test
+%%R_MOD_DIR%%/help/leverage.plots
+%%R_MOD_DIR%%/help/linear.hypothesis
+%%R_MOD_DIR%%/help/logit
+%%R_MOD_DIR%%/help/n.bins
+%%R_MOD_DIR%%/help/ncv.test
+%%R_MOD_DIR%%/help/outlier.test
+%%R_MOD_DIR%%/help/panel.car
+%%R_MOD_DIR%%/help/qq.plot
+%%R_MOD_DIR%%/help/recode
+%%R_MOD_DIR%%/help/reg.line
+%%R_MOD_DIR%%/help/scatterplot
+%%R_MOD_DIR%%/help/scatterplot.matrix
+%%R_MOD_DIR%%/help/some
+%%R_MOD_DIR%%/help/spread.level.plot
+%%R_MOD_DIR%%/help/subsets
+%%R_MOD_DIR%%/help/symbox
+%%R_MOD_DIR%%/help/vif
+%%R_MOD_DIR%%/help/which.names
+%%R_MOD_DIR%%/html/00Index.html
+%%R_MOD_DIR%%/html/Adler.html
+%%R_MOD_DIR%%/html/Angell.html
+%%R_MOD_DIR%%/html/Anova.html
+%%R_MOD_DIR%%/html/Anscombe.html
+%%R_MOD_DIR%%/html/Ask.html
+%%R_MOD_DIR%%/html/Baumann.html
+%%R_MOD_DIR%%/html/Bfox.html
+%%R_MOD_DIR%%/html/Blackmoor.html
+%%R_MOD_DIR%%/html/Burt.html
+%%R_MOD_DIR%%/html/Can.pop.html
+%%R_MOD_DIR%%/html/Chile.html
+%%R_MOD_DIR%%/html/Chirot.html
+%%R_MOD_DIR%%/html/Contrasts.html
+%%R_MOD_DIR%%/html/Cowles.html
+%%R_MOD_DIR%%/html/Davis.html
+%%R_MOD_DIR%%/html/DavisThin.html
+%%R_MOD_DIR%%/html/Duncan.html
+%%R_MOD_DIR%%/html/Ellipses.html
+%%R_MOD_DIR%%/html/Ericksen.html
+%%R_MOD_DIR%%/html/Florida.html
+%%R_MOD_DIR%%/html/Freedman.html
+%%R_MOD_DIR%%/html/Friendly.html
+%%R_MOD_DIR%%/html/Ginzberg.html
+%%R_MOD_DIR%%/html/Greene.html
+%%R_MOD_DIR%%/html/Guyer.html
+%%R_MOD_DIR%%/html/Hartnagel.html
+%%R_MOD_DIR%%/html/Leinhardt.html
+%%R_MOD_DIR%%/html/Mandel.html
+%%R_MOD_DIR%%/html/Migration.html
+%%R_MOD_DIR%%/html/Moore.html
+%%R_MOD_DIR%%/html/Mroz.html
+%%R_MOD_DIR%%/html/OBrienKaiser.html
+%%R_MOD_DIR%%/html/Ornstein.html
+%%R_MOD_DIR%%/html/Pottery.html
+%%R_MOD_DIR%%/html/Prestige.html
+%%R_MOD_DIR%%/html/Quartet.html
+%%R_MOD_DIR%%/html/Robey.html
+%%R_MOD_DIR%%/html/SLID.html
+%%R_MOD_DIR%%/html/Sahlins.html
+%%R_MOD_DIR%%/html/Soils.html
+%%R_MOD_DIR%%/html/States.html
+%%R_MOD_DIR%%/html/Transformation.Axes.html
+%%R_MOD_DIR%%/html/UN.html
+%%R_MOD_DIR%%/html/US.pop.html
+%%R_MOD_DIR%%/html/Var.html
+%%R_MOD_DIR%%/html/Vocab.html
+%%R_MOD_DIR%%/html/Womenlf.html
+%%R_MOD_DIR%%/html/av.plots.html
+%%R_MOD_DIR%%/html/box.cox.html
+%%R_MOD_DIR%%/html/box.cox.powers.html
+%%R_MOD_DIR%%/html/box.cox.var.html
+%%R_MOD_DIR%%/html/box.tidwell.html
+%%R_MOD_DIR%%/html/car-internal.html
+%%R_MOD_DIR%%/html/car-package.html
+%%R_MOD_DIR%%/html/ceres.plots.html
+%%R_MOD_DIR%%/html/cookd.html
+%%R_MOD_DIR%%/html/cr.plots.html
+%%R_MOD_DIR%%/html/durbin.watson.html
+%%R_MOD_DIR%%/html/hccm.html
+%%R_MOD_DIR%%/html/influencePlot.html
+%%R_MOD_DIR%%/html/levene.test.html
+%%R_MOD_DIR%%/html/leverage.plots.html
+%%R_MOD_DIR%%/html/linear.hypothesis.html
+%%R_MOD_DIR%%/html/logit.html
+%%R_MOD_DIR%%/html/n.bins.html
+%%R_MOD_DIR%%/html/ncv.test.html
+%%R_MOD_DIR%%/html/outlier.test.html
+%%R_MOD_DIR%%/html/panel.car.html
+%%R_MOD_DIR%%/html/qq.plot.html
+%%R_MOD_DIR%%/html/recode.html
+%%R_MOD_DIR%%/html/reg.line.html
+%%R_MOD_DIR%%/html/scatterplot.html
+%%R_MOD_DIR%%/html/scatterplot.matrix.html
+%%R_MOD_DIR%%/html/some.html
+%%R_MOD_DIR%%/html/spread.level.plot.html
+%%R_MOD_DIR%%/html/subsets.html
+%%R_MOD_DIR%%/html/symbox.html
+%%R_MOD_DIR%%/html/vif.html
+%%R_MOD_DIR%%/html/which.names.html
+%%R_MOD_DIR%%/latex/Adler.tex
+%%R_MOD_DIR%%/latex/Angell.tex
+%%R_MOD_DIR%%/latex/Anova.tex
+%%R_MOD_DIR%%/latex/Anscombe.tex
+%%R_MOD_DIR%%/latex/Ask.tex
+%%R_MOD_DIR%%/latex/Baumann.tex
+%%R_MOD_DIR%%/latex/Bfox.tex
+%%R_MOD_DIR%%/latex/Blackmoor.tex
+%%R_MOD_DIR%%/latex/Burt.tex
+%%R_MOD_DIR%%/latex/Can.pop.tex
+%%R_MOD_DIR%%/latex/Chile.tex
+%%R_MOD_DIR%%/latex/Chirot.tex
+%%R_MOD_DIR%%/latex/Contrasts.tex
+%%R_MOD_DIR%%/latex/Cowles.tex
+%%R_MOD_DIR%%/latex/Davis.tex
+%%R_MOD_DIR%%/latex/DavisThin.tex
+%%R_MOD_DIR%%/latex/Duncan.tex
+%%R_MOD_DIR%%/latex/Ellipses.tex
+%%R_MOD_DIR%%/latex/Ericksen.tex
+%%R_MOD_DIR%%/latex/Florida.tex
+%%R_MOD_DIR%%/latex/Freedman.tex
+%%R_MOD_DIR%%/latex/Friendly.tex
+%%R_MOD_DIR%%/latex/Ginzberg.tex
+%%R_MOD_DIR%%/latex/Greene.tex
+%%R_MOD_DIR%%/latex/Guyer.tex
+%%R_MOD_DIR%%/latex/Hartnagel.tex
+%%R_MOD_DIR%%/latex/Leinhardt.tex
+%%R_MOD_DIR%%/latex/Mandel.tex
+%%R_MOD_DIR%%/latex/Migration.tex
+%%R_MOD_DIR%%/latex/Moore.tex
+%%R_MOD_DIR%%/latex/Mroz.tex
+%%R_MOD_DIR%%/latex/OBrienKaiser.tex
+%%R_MOD_DIR%%/latex/Ornstein.tex
+%%R_MOD_DIR%%/latex/Pottery.tex
+%%R_MOD_DIR%%/latex/Prestige.tex
+%%R_MOD_DIR%%/latex/Quartet.tex
+%%R_MOD_DIR%%/latex/Robey.tex
+%%R_MOD_DIR%%/latex/SLID.tex
+%%R_MOD_DIR%%/latex/Sahlins.tex
+%%R_MOD_DIR%%/latex/Soils.tex
+%%R_MOD_DIR%%/latex/States.tex
+%%R_MOD_DIR%%/latex/Transformation.Axes.tex
+%%R_MOD_DIR%%/latex/UN.tex
+%%R_MOD_DIR%%/latex/US.pop.tex
+%%R_MOD_DIR%%/latex/Var.tex
+%%R_MOD_DIR%%/latex/Vocab.tex
+%%R_MOD_DIR%%/latex/Womenlf.tex
+%%R_MOD_DIR%%/latex/av.plots.tex
+%%R_MOD_DIR%%/latex/box.cox.powers.tex
+%%R_MOD_DIR%%/latex/box.cox.tex
+%%R_MOD_DIR%%/latex/box.cox.var.tex
+%%R_MOD_DIR%%/latex/box.tidwell.tex
+%%R_MOD_DIR%%/latex/car-internal.tex
+%%R_MOD_DIR%%/latex/car-package.tex
+%%R_MOD_DIR%%/latex/ceres.plots.tex
+%%R_MOD_DIR%%/latex/cookd.tex
+%%R_MOD_DIR%%/latex/cr.plots.tex
+%%R_MOD_DIR%%/latex/durbin.watson.tex
+%%R_MOD_DIR%%/latex/hccm.tex
+%%R_MOD_DIR%%/latex/influencePlot.tex
+%%R_MOD_DIR%%/latex/levene.test.tex
+%%R_MOD_DIR%%/latex/leverage.plots.tex
+%%R_MOD_DIR%%/latex/linear.hypothesis.tex
+%%R_MOD_DIR%%/latex/logit.tex
+%%R_MOD_DIR%%/latex/n.bins.tex
+%%R_MOD_DIR%%/latex/ncv.test.tex
+%%R_MOD_DIR%%/latex/outlier.test.tex
+%%R_MOD_DIR%%/latex/panel.car.tex
+%%R_MOD_DIR%%/latex/qq.plot.tex
+%%R_MOD_DIR%%/latex/recode.tex
+%%R_MOD_DIR%%/latex/reg.line.tex
+%%R_MOD_DIR%%/latex/scatterplot.matrix.tex
+%%R_MOD_DIR%%/latex/scatterplot.tex
+%%R_MOD_DIR%%/latex/some.tex
+%%R_MOD_DIR%%/latex/spread.level.plot.tex
+%%R_MOD_DIR%%/latex/subsets.tex
+%%R_MOD_DIR%%/latex/symbox.tex
+%%R_MOD_DIR%%/latex/vif.tex
+%%R_MOD_DIR%%/latex/which.names.tex
+%%R_MOD_DIR%%/man/car.Rd.gz
+@dirrm %%R_MOD_DIR%%/man
+@dirrm %%R_MOD_DIR%%/latex
+@dirrm %%R_MOD_DIR%%/html
+@dirrm %%R_MOD_DIR%%/help
+@dirrm %%R_MOD_DIR%%/data
+@dirrm %%R_MOD_DIR%%/R-ex
+@dirrm %%R_MOD_DIR%%/R
+@dirrm %%R_MOD_DIR%%/Meta
+@dirrm %%R_MOD_DIR%%