aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-07 00:38:15 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-07 00:38:15 +0000
commita14f69f82dcd436229cd3afa5c9918aa8b3305fd (patch)
treea91710e036de497ec1d679a23f61e7934c83147d /math
parent4601d4e923dd56c32bfae6c99b38f9a12fe9eb7b (diff)
downloadports-a14f69f82dcd436229cd3afa5c9918aa8b3305fd.tar.gz
ports-a14f69f82dcd436229cd3afa5c9918aa8b3305fd.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/gcalctool/Makefile1
-rw-r--r--math/gcalctool/files/patch-gcalctool::get.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/math/gcalctool/Makefile b/math/gcalctool/Makefile
index a568a80f5b37..c857795bd522 100644
--- a/math/gcalctool/Makefile
+++ b/math/gcalctool/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gcalctool
PORTVERSION= 4.3.35
+PORTREVISION= 1
CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/4.3
diff --git a/math/gcalctool/files/patch-gcalctool::get.c b/math/gcalctool/files/patch-gcalctool::get.c
new file mode 100644
index 000000000000..a3f0ed9ec1fe
--- /dev/null
+++ b/math/gcalctool/files/patch-gcalctool::get.c
@@ -0,0 +1,11 @@
+--- gcalctool/get.c.orig Tue Jan 6 19:18:44 2004
++++ gcalctool/get.c Tue Jan 6 19:19:01 2004
+@@ -234,7 +234,7 @@
+ tsep = g_locale_to_utf8(tsep, -1, NULL, NULL, NULL);
+ }
+
+- if (tsep == NULL || tsep[0] == '\0') {
++ if (tsep == NULL) {
+ return(",");
+ } else {
+ return(tsep);