aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-09-19 19:43:47 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-09-19 19:43:47 +0000
commita513da3ae94ba56dc7fa72a699571f5ec5b30293 (patch)
tree262e143c650d2540eaeb1ca198ddd5f1293c1f72 /math
parentcd698a32e0bc5d580a8e13074a1a7becd0375558 (diff)
downloadports-a513da3ae94ba56dc7fa72a699571f5ec5b30293.tar.gz
ports-a513da3ae94ba56dc7fa72a699571f5ec5b30293.zip
math/casadi: fix build on GCC architectures
Use C++11 compiler: Cannot enable C++11 features. Use it also for math/ipopt to be able to link math/casadi against it. Approved by: mentors (implicit approval)
Notes
Notes: svn path=/head/; revision=512370
Diffstat (limited to 'math')
-rw-r--r--math/casadi/Makefile2
-rw-r--r--math/ipopt/Makefile3
2 files changed, 3 insertions, 2 deletions
diff --git a/math/casadi/Makefile b/math/casadi/Makefile
index 0db06204c310..29edfaed07be 100644
--- a/math/casadi/Makefile
+++ b/math/casadi/Makefile
@@ -12,7 +12,7 @@ COMMENT= Symbolic framework for numeric optimization
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= cmake pkgconfig
+USES= cmake compiler:c++11-lang pkgconfig
USE_GITHUB= yes
USE_LDCONFIG= yes
diff --git a/math/ipopt/Makefile b/math/ipopt/Makefile
index 0df5d0e9a0a1..c37b873abe1b 100644
--- a/math/ipopt/Makefile
+++ b/math/ipopt/Makefile
@@ -17,7 +17,8 @@ COMMENT= Software package for large-scale nonlinear optimization
LICENSE= EPL
-USES= blaslapack fortran libtool pathfix pkgconfig tar:tgz
+USES= blaslapack compiler:c++11-lang fortran libtool pathfix \
+ pkgconfig tar:tgz
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
TEST_TARGET= test