aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-30 12:24:12 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-30 12:24:12 +0000
commit39ecea83646e7e90b75ca85473d80140022ac6db (patch)
treee17709b45cee06b91919e42cbb509243ec0638c0 /math
parentb5988a489aad6633e318b430a55ac11cd27004ec (diff)
downloadports-39ecea83646e7e90b75ca85473d80140022ac6db.tar.gz
ports-39ecea83646e7e90b75ca85473d80140022ac6db.zip
Fix build
A C pre-processor conditional interpreted decimal numbers with a leading zero as octal number, which was rejected since it included the digig 8. Removal of the leading 0 from both condition arguments causes the correct interpretation of these numbers as decimal values.
Notes
Notes: svn path=/head/; revision=550692
Diffstat (limited to 'math')
-rw-r--r--math/wxmaxima/Makefile8
-rw-r--r--math/wxmaxima/files/patch-src_Version.h.cin11
2 files changed, 15 insertions, 4 deletions
diff --git a/math/wxmaxima/Makefile b/math/wxmaxima/Makefile
index 25f8243850d6..b701ac5d71ba 100644
--- a/math/wxmaxima/Makefile
+++ b/math/wxmaxima/Makefile
@@ -3,8 +3,8 @@
PORTNAME= wxmaxima
PORTVERSION= 20.04.0
-PORTREVISION= 1
DISTVERSIONPREFIX= Version-
+PORTREVISION= 2
CATEGORIES= math
MAINTAINER= ports@FreeBSD.org
@@ -16,20 +16,20 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= maxima:math/maxima
USES= cmake compiler:c++11-lang desktop-file-utils shared-mime-info
-USE_WX= 3.0
USE_GITHUB= yes
GH_ACCOUNT= wxMaxima-Developers
-PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S,${PREFIX}/,,}
+USE_WX= 3.0
WX_COMPS= wx
WX_CONF_ARGS= absolute
+PLIST_SUB= DESKTOPDIR=${DESKTOPDIR:S,${PREFIX}/,,}
PORTDATA= COPYING README README.md
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
-NLS_EXTRA_PATCHES_OFF= ${PATCHDIR}/extra-patch-CMakeLists.txt
NLS_USES= gettext
+NLS_EXTRA_PATCHES_OFF= ${PATCHDIR}/extra-patch-CMakeLists.txt
.include <bsd.port.mk>
diff --git a/math/wxmaxima/files/patch-src_Version.h.cin b/math/wxmaxima/files/patch-src_Version.h.cin
new file mode 100644
index 000000000000..b9034dd53787
--- /dev/null
+++ b/math/wxmaxima/files/patch-src_Version.h.cin
@@ -0,0 +1,11 @@
+--- src/Version.h.cin.orig 2020-04-18 07:14:02 UTC
++++ src/Version.h.cin
+@@ -2,7 +2,7 @@
+ #ifndef GITVERSION
+ #define GITVERSION "@VERSION@"
+ #endif
+-#if 0@OpenMP_CXX_SPEC_DATE@ > 0201510
++#if @OpenMP_CXX_SPEC_DATE@ > 201510
+ #define HAVE_OPENMP_TASKS 1
+ #define OPENMP_SPEC_DATE "@OpenMP_CXX_SPEC_DATE@"
+ #define HAVE_OMP_HEADER @HAVE_OMP_HEADER@