aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-09-23 15:49:10 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-09-23 15:49:10 +0000
commit568f6ed2d499ecbc22d509fc7d4da60113e777b0 (patch)
tree09bf8d84d858b84dbb6a40ad0ad6cfceaeb86a84 /math
parent43d5d21d0fda1e6486ac70166b4218bd962b1978 (diff)
downloadports-568f6ed2d499ecbc22d509fc7d4da60113e777b0.tar.gz
ports-568f6ed2d499ecbc22d509fc7d4da60113e777b0.zip
math/lrslib: fix build on GCC architectures
Use C11 compiler: lrslong.h:191: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'lrs_mp' lrslong.h:192: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token lrslong.h:193: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token lrslong.h:194: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token lrslong.h:218: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'lrs_alloc_mp_t' lrslong.h:219: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'lrs_alloc_mp_vector'
Notes
Notes: svn path=/head/; revision=549744
Diffstat (limited to 'math')
-rw-r--r--math/lrslib/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/lrslib/Makefile b/math/lrslib/Makefile
index 8971f6f3b759..9746037ecc41 100644
--- a/math/lrslib/Makefile
+++ b/math/lrslib/Makefile
@@ -16,7 +16,7 @@ BROKEN_i386= error: __int128 is not supported on this target
LIB_DEPENDS= libgmp.so:math/gmp
-USES= gmake libtool localbase:ldflags
+USES= compiler:c11 gmake libtool localbase:ldflags
USE_LDCONFIG= yes
MAKEFILE= makefile