aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-10-19 11:00:55 +0000
committerWen Heping <wen@FreeBSD.org>2010-10-19 11:00:55 +0000
commit84c152485458c5d8febb90dc01c1871f99160858 (patch)
treed397daf28ea3ee21d91ebd3f156b0cf56efab56c /math
parentc6642bdd62beb1c83e304d47d32410ab5e0c0b2f (diff)
downloadports-84c152485458c5d8febb90dc01c1871f99160858.tar.gz
ports-84c152485458c5d8febb90dc01c1871f99160858.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/libtsnnls/Makefile57
-rw-r--r--math/libtsnnls/distinfo3
-rw-r--r--math/libtsnnls/pkg-descr5
-rw-r--r--math/libtsnnls/pkg-plist14
5 files changed, 80 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 2caaf935b5ee..d9e63f5ae61e 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -169,6 +169,7 @@
SUBDIR += librandlib
SUBDIR += libranlip
SUBDIR += libtommath
+ SUBDIR += libtsnnls
SUBDIR += linalg
SUBDIR += linpack
SUBDIR += linux-SHA-1_collision_search_graz
diff --git a/math/libtsnnls/Makefile b/math/libtsnnls/Makefile
new file mode 100644
index 000000000000..91a2e9cd2feb
--- /dev/null
+++ b/math/libtsnnls/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: libtsnnls
+# Date created: 18 October 2010
+# Whom: Tz-Huan Huang <tzhuan@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtsnnls
+PORTVERSION= 2.3.3
+CATEGORIES= math
+MASTER_SITES= http://www.jasoncantarella.com/downloads/
+
+MAINTAINER= tzhuan@gmail.com
+COMMENT= Fast Sparse Nonnegative Least Squares Solver
+
+GNU_CONFIGURE= yes
+USE_FORTRAN= yes
+USE_LDCONFIG= yes
+
+OPTIONS= GOTOBLAS "Use gotoblas (conflict with USE_ATLAS)" off \
+ ATLAS "Use atlas (conflict with USE_GOTOBLAS)" off
+# DMALLOC "Use dmalloc" off
+
+.include <bsd.port.options.mk>
+
+WITH_BLAS?=reference
+.if defined(WITH_GOTOBLAS)
+WITH_BLAS=gotoblas
+.endif
+.if defined(WITH_ATLAS)
+WITH_BLAS=atlas
+.endif
+
+# FIXME compiling error when using dmalloc
+#.if defined(WITH_DMALLOC)
+#CONFIGURE_ARGS+=--with-dmalloc
+#LIB_DEPENDS+=dmalloc.1:${PORTSDIR}/devel/dmalloc
+#.endif
+
+.if ${WITH_BLAS} == reference
+LIB_DEPENDS+=blas.2:${PORTSDIR}/math/blas
+LIB_DEPENDS+=lapack.4:${PORTSDIR}/math/lapack
+BLAS=-lblas
+LAPACK=-llapack
+.elif ${WITH_BLAS} == gotoblas
+LIB_DEPENDS+=goto2:${PORTSDIR}/math/gotoblas
+BLAS=-lgoto2p
+LAPACK=-lgoto2p
+.elif ${WITH_BLAS} == atlas
+LIB_DEPENDS+=atlas:${PORTSDIR}/math/atlas
+BLAS=-lptf77blas -lptcblas -latlas_r
+LAPACK=-lalapack_r
+.endif
+
+CONFIGURE_ARGS= --with-blas="${BLAS}" --with-lapack="${LAPACK}"
+
+.include <bsd.port.mk>
diff --git a/math/libtsnnls/distinfo b/math/libtsnnls/distinfo
new file mode 100644
index 000000000000..f8d6a9010883
--- /dev/null
+++ b/math/libtsnnls/distinfo
@@ -0,0 +1,3 @@
+MD5 (libtsnnls-2.3.3.tar.gz) = 5edf293fdf084818482847f2a52c6338
+SHA256 (libtsnnls-2.3.3.tar.gz) = edaa1f9356c5f95df2800cdcfd08dc713a63ef1f8d56681baf482160f38e5b9a
+SIZE (libtsnnls-2.3.3.tar.gz) = 1750216
diff --git a/math/libtsnnls/pkg-descr b/math/libtsnnls/pkg-descr
new file mode 100644
index 000000000000..ce11ec881c92
--- /dev/null
+++ b/math/libtsnnls/pkg-descr
@@ -0,0 +1,5 @@
+libtsnnls is a fast solver for least-squares problems in the
+form Ax = b under the constraint that all entries in the
+solution vector x are non-negative.
+
+WWW: http://www.jasoncantarella.com/webpage/index.php?title=Tsnnls
diff --git a/math/libtsnnls/pkg-plist b/math/libtsnnls/pkg-plist
new file mode 100644
index 000000000000..6c6cd2c58edb
--- /dev/null
+++ b/math/libtsnnls/pkg-plist
@@ -0,0 +1,14 @@
+include/libtsnnls/tsnnls.h
+include/libtsnnls/lsqr.h
+include/libtsnnls/taucs_basic/colamd.h
+include/libtsnnls/taucs_basic/f2c.h
+include/libtsnnls/taucs_basic/taucs.h
+include/libtsnnls/taucs_basic/taucs_config_build.h
+include/libtsnnls/taucs_basic/taucs_config_tests.h
+include/libtsnnls/taucs_basic/taucs_private.h
+lib/libtsnnls.a
+lib/libtsnnls.la
+lib/libtsnnls.so
+lib/libtsnnls.so.0
+@dirrm include/libtsnnls/taucs_basic
+@dirrm include/libtsnnls